Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: This file does not have a program associated

10 Jan 2012   #1

Wi8ndows 7 Home Premium 64bit
This file does not have a program associated

Hi, all. I know this title has been used before several times, but the most recent ones talk about problems in the Libraries area, and I have no problems there. Almost all the desktop icons (24 of 27) give me this message when I left-click on them. Also almost all the items in the start menu give me the same message, and all the items on the taskbar.
When I right-click, some of the icons allow me to "run as administrator" and the program will open. However, not all the icons give me this option when I right-click. I cannot open my registry either, except via the administrator process.
It appears that all the associations to my exe files have been disabled. How can I resotre those associations?
Thanks for your help!

My System SpecsSystem Spec
10 Jan 2012   #2

64-bit Windows 10 Pro

Hello Jim, and welcome to Seven Forums.

You could download and merge the lnk (LNK) and exe options in the tutorial below to restore their default associations and hopefully fix this for you.

Default File Type Associations - Restore

Hope this helps,
My System SpecsSystem Spec
11 Jan 2012   #3

Wi8ndows 7 Home Premium 64bit

Thanks... the issue was solved by using Malwarebytes... I downloaded it with another computer, put it on a flash drive, and installed it via USB port. It performed a quick scan, identified the virus as "hijacked.exefile" and removed it. The system is back to normal.
My System SpecsSystem Spec

11 Jan 2012   #4

64-bit Windows 10 Pro

That's great news Jim. I'm happy to hear that you got it sorted. :)
My System SpecsSystem Spec

 This file does not have a program associated

Thread Tools

Similar help and support threads
Thread Forum
How can I write a batch file that opens a file in a program?
I wrote this batch file which does what I want it to do so far. @echo off "C:\Users\xxxxxx\Documents\HideTaskbar\HideTaskbar.exe" "C:\Program Files (x86)\VideoLANold\VLC\vlc.exe" "C:\Users\xxxxxx\Documents\HideTaskbar\ShowTaskbar.exe" exit
General Discussion
Locked file in Program File (x86) and I'm administrator
Sorry if I'm placing this question in the wrong place. Please move if necessary. This is a combination question both virus and administrative issues. I have a file called C:/Program Files(x86)/sweetm that is a known virus that I cannot remove. When I try to do so, my system tells me "You...
Performance & Maintenance
File does not have a program associated with it?
Howdy, I received a link from a friend to a video he posted on Dropbox. I have received links to videos from him before and it worked just fine. The video is a MOV file. Now, when I get an email in Windows Live Mail with a link to a video i get the error "This file does not have a program...
Browsers & Mail
batch file open file for program in the startup folder
I have a computer that is a drone specifically for an outside LED sign. This computer is designed to never shut off and doesn't have any other program on it besides Operating System and the sign software. I need to create a batch file that I can place in the "start-up" folder that will open the...
General Discussion
Program File X86
I have uninstalled a program (via control panel etc). And when I check within the ProgramFiles folder it is no longer there. How ever when I look in the Program File X86 folder the program is still there. I thought I must have made a mistake so went back to Control panel / Program files, but the...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:59.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App