Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Can I run Robocopy in "abbreviated" mode?

18 Jan 2012   #1

Windows 7 32-bit
Can I run Robocopy in "abbreviated" mode?

I use Robocopy to do a lot of copies. However, it generates an extraordinary volume of output to the screen; starting with a header, then a list of the copied files and some statistics. This gets annoying when I'm running a BAT file to copy thousands of files. Is there a way to suppress that and only display one line indicating the file that was copied?

My System SpecsSystem Spec
18 Jan 2012   #2

Windows 10 Pro (x64)

Try: "/NP /NJH /NJS"
My System SpecsSystem Spec
18 Jan 2012   #3

XP / Win7 x64 Pro

Here is the list of options for preventing certain logging outputs:

Logging options                 
/L : List only - don't copy, timestamp or delete any files.                
/NP : No Progress - don't display % copied.          
/LOG:file : Output status to LOG file (overwrite existing log).       
/UNILOG:file : Output status to Unicode Log file (overwrite) ##         
/LOG+:file : Output status to LOG file (append to existing log).      
/UNILOG+:file : Output status to Unicode Log file (append) ##                
/TS : Include Source file Time Stamps in the output.                
/FP : Include Full Pathname of files in the output.                
/NS : No Size - don't log file sizes.                
/NC : No Class - don't log file classes.               
/NFL : No File List - don't log file names.               
/NDL : No Directory List - don't log directory names.               
/TEE : Output to console window, as well as the log file.               
/NJH : No Job Header.               
/NJS : No Job Summary.
My System SpecsSystem Spec


 Can I run Robocopy in "abbreviated" mode?

Thread Tools

Similar help and support threads
Thread Forum
robocopy cannot access "my music"
There's a hidden file called "my music" in the documents directory, which bizzarely can be navigated to via "my documents" or "documents" depending upon the situation. I need to make robocopy work on the c:\users\jack\Documents directory. Robocopy cannot get past the hidden "my music" shortcut...
Installation & Setup
Can't change advanced settings from "802.11d" to "wireless mode"
It seems to keep rolling back to 802.11d after I click okay. If you need more information from me I would be happy to fill you in a bit more there. Some basic specs: - 32-bit Service Pack 2 - Acer - AM5620-E1204A - Intel Core 2 Any additional help to further assist would be...
Network & Sharing
Going from "bios mode" to "UEFI mode" with windows7
I have an asus m5a99fx mobo with windows 7 64 bit (retail version) installed in bios mode. Is there any way I can change the mode to UEFI without reinstalling windows?
Installation & Setup
BSOD "Bad Pool Header" and "Page In Nonpage Area" Runs in Safe Mode
Hi, I am having a problem with my newer computer, I just got this rig a few months ago and never had a problem until last Thursday. It Blue Screened on me while I was installing ARC GIS 10.1. From then on it randomly crashes. (I have previously installed ARC GIS 10 and never had a problem.) I...
BSOD Help and Support
ROBOCOPY and not existing folder "c:\Users\"MyUser"\Doc
Hello Fellow 7 users, I have just switched OS to Windows 7, and i am impressed so far. I want to backup my data on an external harddrive. I would like to use the function ROBOCOPY in the command windows because then i don't have to third party program running all the time. But the copying...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:02.
Twitter Facebook Google+