Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: .exe files will not open in Windows 7 64 bit

26 Jan 2012   #1

Windows 7 64-bit Home
.exe files will not open in Windows 7 64 bit

I am currently running Windows 7 64 bit.
I can only open certain files such as Internet Explorer 64 bit, but not the 32 bit version.
All other borwsers, game applications and programs, besides Ventrilo, which is also in the C:Program Files Folder do not open. I can also get Regedit to work, which is also an exe, but outside of the Program files folder.
CMD also opens just fine

I click on the application icon in the containing folder, and the program does not open.
No new process appears in the task manager and I see a momentary spike in CPU usage.
If I right click to run as Administrator In the task Manager I see the dllhost.exe appear twice for about 3 seconds and then it dissappears and the application does not load.
The application never appears in the Applications Tab of the Task Manager.

Attempting to run any installations including system updates also result in failure.

Right Clicking on the application Icon to attempt a Scan will result in the scan not running due to the scanning software not loading.

Attempts to resolve:
I have Merged .exe and .dll associations,
I have ran system restore,
I have attempted to run applications in Safe mode and applications do not load.
Moved Files form other folders into the C:Program files This did not work either.
Ran Applications as differnt versions of windows for campatablity.
Ran Applications as Administrator.

Any Help would be appreciated.

My System SpecsSystem Spec
26 Jan 2012   #2

Windows 7 Home Premium 64bit

Hello Linkmasters, welcome to Seven Forums.

Perhaps this will help:
Default File Type Associations - Restore
My System SpecsSystem Spec
26 Jan 2012   #3

7 x64 | 7 x64

Almost sounds like a virus. I'd take the drive out and hook it up on another PC with malwarebytes installed and run a full scan on it.
My System SpecsSystem Spec

26 Jan 2012   #4

XP / Win7 x64 Pro

Run "sfc /scannow" from an elevated command prompt to see if it finds anything. I would definitely do a virus scan as well.
My System SpecsSystem Spec
26 Jan 2012   #5

Windows 7 64-bit Home

I Ran and Merged sucessfully all File Type Associations from the Zip folder download, by opening it in an Explorer window as Zip files will not open. I then restarted and the issue is the same.

I also ran the sfc/scannow and it stated that system files were currupted but was unable to correct them and that I could view the log in C:Windows\Logs\CBS CBS.log, which I had to change the permissions to allow myself to view it. Upon opening I found an extremely long script of Diagnostic data.
I read some of it and found that the reason why it could not repair is because its source files were also currupted as noted here.

\WinSxS\amd64_microsoft-windows-p..rtmonitor-tcpmonini_31bf3856ad364e35_6.1.7600.16385_none_2e6dc451c0fa9db5\tcpmon.ini do not match actual file [l:20{10}]"tcpmon.ini" :
Found: {l:32 b:as3OOcx5px0XiJa7f7s9BVvlW/FFlKR4NMU/T+UP/Kg=} Expected: {l:32 b:ENtKeUct91LKlHclgfWTvnCdCOHHwDe+SYrPzZTTezU=}
2012-01-26 14:30:55, Info CSI 000002f8 [SR] Could not reproject corrupted file [ml:520{260},l:46{23}]"\??\C:\Windows\System32"\[l:20{10}]"tcpmon.ini"; source file in store is also corrupted
2012-01-26 14:30:55, Info CSI 000002f9 Repair results created:
POQ 123 starts:

I'm honestly not sure what all that means, but after another restart I still have the same issue.

Sadly I do not have another system or another drive that I can attach my current Hard Disk to to run Malwarebytes.

If it is a Virus have you ever heard of a Virus that has similar characteristics?

Luckily I still have iExplorer 64 so that I can research solutions, Thank you very much for your help, hopefully I can get this figured out.
My System SpecsSystem Spec
26 Jan 2012   #6

XP / Win7 x64 Pro

Try to do a System Restore to a time previous to this problem. If a restore point previous isn't available, I'd recommend doing a Repair Install.

Repair Install
My System SpecsSystem Spec
26 Jan 2012   #7
Microsoft MVP

Windows 7 Ultimate X64 SP1

Viruses can do a number of things and manifest themselves differently. This could be a virus. See my sig and download Malware Bytes, update and do a full scan.

Sometimes running the sfc /scannow 2-3 times and rebooting between runs can help too.
If none of that works go with the Repair Install as FliGi7 suggests.
My System SpecsSystem Spec
28 Jan 2012   #8

Windows 7 64-bit Home

I tried to restore my system to multiple restore points all of which have the same problem.
I have Ran SFC/Scannow in Safe mode and normal mode about 4 times now and that hasn't worked.
I ran CHK DSK/r to see if maybe that would help, but I had no results other than a very nice and clean disk with no sector errors

From there I found a very handy tool Called the MRT(Malicious Software Removal Tool and it runs just fine, but found no malicious software.

I went in and edited the regestry for the exefile and .exe defaults which were set incorrectly. even after a .exe fix that I ran earlier.

I also ran a system repair from the F8 option after restarting, but this did not help as it found no errors.

Sadly I do not have a restore disk or an installation disk as my Dell system did not come with one, but it did come with a restore partition, which I can't seem to access.

I read some where while searching for solutions about a Rookit Virus and this sounds alot like it, because its affected other partitions on my hard drive.

I'm still looking for solutions at this point, until I can get a disk to reinstall/repair.
I thank you for all for your advice and help in my current situation
My System SpecsSystem Spec
28 Jan 2012   #9

Windows 7 Ultimate SP1 64-Bit

Look here to get into Dell's restore options: Restoring Your Computer´s Software to the Factory Settings | Dell

This tutorial explains how to create a system repair disc: System Repair Disc - Create
My System SpecsSystem Spec
28 Jan 2012   #10

Windows 7 Home Premium x64

Run a Hitman Pro scan: Home - SurfRight
and a MBAM scan: Malwarebytes : Free anti-malware, anti-virus and spyware removal download

(Do this from another computer) on the drive which doesn't open exe files

Also install SP1 if you can: Download Details Windows 7 en Windows Server 2008 R2 Service Pack 1 (KB976932) (choose the 64-bit version)
My System SpecsSystem Spec

 .exe files will not open in Windows 7 64 bit

Thread Tools

Similar help and support threads
Thread Forum
Help (.hlp) Files - Cannot Open in Windows Fix
How to Open 32-bit Help (.hlp) Files that Require WinHlp32.exe in Windows Windows Help (WinHlp32.exe) is a Help program that has been included with Microsoft Windows versions starting with the Microsoft Windows 3.1 operating system. However, the Windows Help program has not had a major update...
Windows cant open ANY .png files
Hi There, I'm struggling with weird problem. Windows cant show any png files. Thumbnails, png preview, even calculator get freak. Ui elements form excel are missing (my guess is they are png files). It happened after I cleaned my temp folder and I have deleted some files like VC_RED.MSI,...
Music, Pictures & Video
Can not open jpg or png files. OS Windows 10
Hey, I really hope that someone can help me please? I'm not technical at all i'm afraid! I work from home and use the Dropbox cloud system, and for some reason today I am unable to open jpg or png files! Even if I try to open the pictures through my Pictures folder on my desktop, they still...
Music, Pictures & Video
Windows 7 cannot open .zip files
I've been running into this problem for a few months now (I've had Windows 7 longer than that) and recently Windows 7 will not open .zip files if I was to download them from BaseCamp. I used to be able to, but not in a few months. I've already take the steps of downloading WinZip and 7-Zip...
General Discussion
Can't Open Certain .EXE Files In Windows 7
I seem to be having a problem where I can't seem to open certain .exe files that I've downloaded. For e.g. Samsung Kies, SPSS Statistics. InstallShield Wizard will just hang and not do anything. I tried doing Right-Clicking and "Run as Administrator" but it doesn't do anything. I have tried...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 18:58.
Twitter Facebook