Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Task Manager will not run and SFC is unable to fix anything

21 Feb 2012   #1

Windows 10 Pro
Task Manager will not run and SFC is unable to fix anything

Hello, this is my first post on the forum and I'll try to be as detailed as I can.

Today I noticed that Windows 7's task manager is no longer loading. Now I think it would be best if I tell you the things I have tried. This will save you the time or telling me something I've already tried.

I've ran the SCF command at an elevated command prompt, it gets to 44% and then stops with a message that it found some corrupt files but is unable to fix them. I got halted with that approach at that step. Trying to run it from boot turned out to be a nightmare. (I'm still going to tinker with trying to make SFC run off the disk or a USB drive)

The next thing I tried was to extract the taskmgr.exe file from the Install.wim file on the CD. I managed to get a copy of taskmgr.exe off the disk and replaced the one in my system32 folder, still nothing happens.

Did the group policy edit thing as well as the reg trick but still no go.

I've scanned my PC with Malwarebytes Antimalware and also ran Hijack this to look for new entries. Everything it shows is supposed to be there, and Mbam finds nothing.

The only thing out of the ordinary to happen today is I installed the Project64 emulator. Avast popped up when I ran it for the first time and recommened i run it in the sandbox. I didn't though. I've had that program before on previous installs of Windows (Yes I've reinstalled it about 4 times over the last 2.5 years. Seems to just corrupt over all by itself (way to go MS)

Lastly I've scoured the internet looking for answers and they all seem to point to taskmanager not displaying correctly. Which is not the problem I'm having.

The only way to describe what I'm seeing is to say that when I click on taskmanager in my pinned task bar icon. It will bring up the selection box around the icon like its loading then it just fades out. If I right click the task bar and click on start task manager it does nothing at all. No error message, no invalid anything. If I try the hotkey shortcut of ctrl+shift+esc nothing happens. Pressing ctrl+alt+del and selecting start task manager does nothing.

Using process explorer I can bypass TM and when I watch the active task and try to run TM it appears then immediately unloads and disappears from the list of running programs.

I am the admin on this computer, the only user of this computer and all processes are run as administrator so there is no way to "check with my administrator to make sure TM is not disabled" as some of the other guides, like the one on the MS site tells me.

I refuse to reinstall windows just to fix taskmanager. That is a load of BS when everything else is working normally, except for TM and apparently the SFC. There must be a way to manually install all of task managers necessary files/driver/dll's/manifest/ and whatever else is necessary to make it run, with out installing windows from scratch.

If anyone has any ideas, or needs additional information on this issue then please reply to this post. If I have reposted and already asked question then by all means link me to the active thread so as to not clutter up the site with redundant threads and erase this one.

My System SpecsSystem Spec
21 Feb 2012   #2

Win 8 Release candidate 8400

If you upload the cbs.log file we can tell you what else is wrong.
My System SpecsSystem Spec
21 Feb 2012   #3

Windows 10 Pro
CBS Log File

Here is the log file. Hope you can make some sense of it, its all piled up in a mess as far as I can tell.

I've tried to read the log myself, but it's confusing to say the least. It seems that trustedinstaller is not turned on. I found out just now that trustedinstaller is controlled by the Windows Module Installer. Now I remember turning that service off a while back, well setting it to manual rather, and task manager was unaffected. I've turned the WMI back on now, and I'll try to run SCF again. Maybe that was what was stopping it? If anyone else wants to take a look at the log and help me figure this out that would be great :)
My System SpecsSystem Spec

21 Feb 2012   #4

Microsoft Community Contributor Award Recipient

Windows 10, Home Clean Install

If you are just concerned about the information that you cannot get from task manager, you can type resoruce monitor in serach, by the start button, and all information will be available.
My System SpecsSystem Spec
21 Feb 2012   #5

Microsoft Windows 8.1 Pro 64-bit

Britton, I wanted to pop in here just to say please don't disable services. There are some services that might be okay to disable, but in the long run, there is no reason to, nor is there any real benefit. You might try a repair install and see if that fixes the problem: Repair Install - tutorial created by Brink

This isn't an MS problem. This is completely on you.

Hope you are able to resolve this soon :)
My System SpecsSystem Spec
21 Feb 2012   #6

Windows 10 Pro

Yeah it seems I've done something to the system that I won't be able to fix with out a format/reinstall. Doing a repair install is basically the same thing, as it will wipe out all my program associations and force me to reinstall everything. Since it only seems to be task manager that was damaged I'll just have to either use the resource monitor or let process explorer become the default process viewer. I won't format my hard drive over this, it will have to have boot issues before I take that step. Sucks though as I can't stand it when something on my computer is not working properly.

I managed to run SFC from the install DVD and from a USB pen drive. The windows setup gives an error that it can not run on this particular version of the installer. I think that came from me installing it from the USB pen drive and then this time using the DVD. It didn't throw the message when I used the USB drive, but no matter how I attempt to run the SFC command it always fails. Either with a halt mid way like I described earlier or it tells me it has a pending operation and can not continue until the computer has been rebooted. Of course rebooting the computer does not change this. I only get that message if the SFC is run from a boot up command prompt.

It's times like this I wish I had kept system restore turned on. Oh well, thanks for your answers. I'll take a look at Brink's guide and see what it has to say.
My System SpecsSystem Spec
21 Feb 2012   #7

Microsoft Windows 8.1 Pro 64-bit

I am not aware of repair install's wiping any program associations. Are you positive it will do this? Have you read the tips that were posted in that tutorial?

If you don't want to do the repair install, which I recommend, you might try an SFC scan: SFC /SCANNOW : Run in Command Prompt at Boot - created by Bare Foot Kid
My System SpecsSystem Spec
21 Feb 2012   #8

Windows 10 Pro

Yeah I read the guide by Brink in the link above and it says it preserves the file and program associations. So if I absolutely have to redo my install I'll try his method and just upgrade on top of the damaged one. I just can't bring myself to go and do that just to fix task manager though. Instead I just made Process Explorer the new default program for that. It's not a fix, more like a work around but really process explorer provides very detailed system process information. So I'll just stick with that, and if down the road something more devastating happens to the system (hoping not) I can always do what the guide says.

As for the SFC at boot, I've tried that a few times and it always claims it needs to reboot due to a pending operation.

Thanks again for everyone's quick and helpful responses
My System SpecsSystem Spec
21 Feb 2012   #9

win 7 X64 Ultimate SP1
Event Viewer

Look in Event Viewer. Look for errors especially services that failed to start, WMI problems, etc,
My System SpecsSystem Spec
21 Feb 2012   #10

Windows 10 Pro

I've looked at it, one of the first places I checked, but there is nothing useful or informative there. Here's some examples of the warnings and errors in the administrative events log.

  • Error: Session "Homegroup Log" failed to start with the following error: 0xC0000035

  • Warning: Windows detected your registry file is still in use by other applications or services. The file will be unloaded now. The applications or services that hold your registry file may not function properly afterwards.

There's a lot more to that one, it seems Diskeeper likes to hold on to registry keys. That's another issue I looked into but never found any answers for it and it doesn't seem to cause any problems, its been doing it for months. I just ignore it.

  • Diskeeper detected low free space and disabled IntelliWrite on volume (I:).
That's the USB flash drive with my Windows install on it, its only 4Gb so of course it's full.

  • The driver detected a controller error on \Device\Harddisk4\DR4.
That one, I hate to think what it means, but despite what it says all my hard drives seem to be working normally and lag free.

  • The Network List Service service depends on the Network Location Awareness service which failed to start because of the following error:The dependency service or group failed to start.
Network Location Awareness is on and is set to automatic, it's always been on so I don't understand why this is in the log, but its a "common" entry at least for this particular install. Unless it means there yet another unnamed service that needs to run before it can. I doubt if it has anything to do with the task manager not loading.

The log is full of the same entries over and over across a span of a few days. I recently cleared all the logs to try and see what errors were popping up based on what I was doing with Windows to try and troubleshoot them. Though most of them seem to be automated responses that happen when windows is starting up and shutting down. Unless there is some specific place I can look for task manager related logs then I don't think I'll find anything in the event viewer. I looked under the application logs as well and its just listing out the startup applications and subsystem files/services/licensing detail that load up when the PC was rebooted.

Stuff like this has happened before so its not like I didn't expect it at some point. As long as Windows still boots up, I can find/run my local data, and the internet stays connected, all is well. While the task manger not loading thing is mainly just annoying, its a sign that something is wrong even if everything appears good on the surface.
My System SpecsSystem Spec

 Task Manager will not run and SFC is unable to fix anything

Thread Tools

Similar help and support threads
Thread Forum
Unable to install new apps, registry, task manager greyed out
Hi I am unable to install spyware/antivirus softwares, unable to install new apps, unable to open my regisry, task manager is greyed out. Plz help me, dont know what happened. This is newly installed window as yesterday my old one got infected & was showing the same message, so i thought...
General Discussion
Unable to open task manager or install new programs
I recently have encountered a problem with my laptop. Everytime i boot it up and try to load a program it doesnt load and i get the error message "Failure to display security and shut down options" when pressing ctrl+alt+delete to access the options. I have also tried pressing ctrl+shift+esc to...
General Discussion
Unable to open Notepad,Task Manager ,Regedit
Today Suddenly I found notepad ,Registry and Task manager is not working. I scan for virus using Mcafee antivirus but did not found any anything.My cousin brother was using my computer yesterday may he bought some virus in his pendrive. When I open notepad i get this error " windows cannot access...
General Discussion
Game runs from Task Manager with New Task, not from shortcut or exe
I have installed this game, Singularity. The game worked fine for a week then suddenly It would crash as soon as it was opened from the desktop shortcut. The game is patched to it's latest version, I have direct x all other runtimes and PhysX installed from the CD. The shortcut it set to run as...
Mutliple Outlook 2003 instance in task tray and task manager
Every now and then I look down at the task tray ...and whoa!!!! about a dozen instances of Outlook. See attached What is causing this? And how do I prevent it??
Microsoft Office

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:42.
Twitter Facebook Google+