Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: CPU running at 100%

05 Mar 2012   #1
ugreebo

windows 7 home premium 32 bit
 
 
CPU running at 100%

Not sure if this is the right place. Having said that, My son's Acer laptop seems to be running at 100% all the time. When I check Resource Monitor, spool service seems to be the culprit. It runs all of the time?


My System SpecsSystem Spec
.
05 Mar 2012   #2
kegobeer

Windows 7 Ultimate x64 SP1
 
 

What anti-virus software is he running, is it up to date, and has he done a virus scan lately?

Does he have a printer attached?

Is there any other weirdness going on?

One quick thing to do, if he does have a printer attached: turn off the printer, then open up services and stop the printer spooler service. Go to c:\windows\system32\spool\printers and look for any files that end in .spl - then delete them. Turn the printer back on and see what happens.
My System SpecsSystem Spec
05 Mar 2012   #3
ugreebo

windows 7 home premium 32 bit
 
 

1. Anti virus is AVG Free edition
2. We have 2 shared printers on a home network.
3. No other "weirdness".
My System SpecsSystem Spec
.

05 Mar 2012   #4
ugreebo

windows 7 home premium 32 bit
 
 

There is one other weird thing happening on both of my kids laptops (they both have Acer Aspire). Every once in awhile, additional printers seem to be added. They are always the same model as the shared printers, but there is something a little different in the printer name each time.
My System SpecsSystem Spec
05 Mar 2012   #5
kegobeer

Windows 7 Ultimate x64 SP1
 
 

Did you turn off the printer spooler service, delete those files, and re-enable the printer spooler service?
My System SpecsSystem Spec
05 Mar 2012   #6
gregrocker
Microsoft MVP

 

Run a full scan with Malwarebytes

Switch from bloated AVG with issues to Microsoft Security Essentials for best performance.

Run SFC -SCANNOW Command to check for damaged System Files.

Make sure per Kegger's advice you have the spooler service turned off to check if problem stops.

If that fails turn off Network Discovery and Sharing in Network and Sharing Center Advanced Options to see what happens.

Report back results.
My System SpecsSystem Spec
Reply

 CPU running at 100%




Thread Tools




Similar help and support threads
Thread Forum
when running on battery, screen goes black,but laptop is still running
I've got an odd problem here. On my Compaq Presario CQ60-615DX, it runs fine as long as it's plugged in. Once I unplug it and run it on the battery, once it gets down to about 87-88% or so, the screen just goes black, but doesn't shutdown and I'm unable to do anything except remove the battery and...
General Discussion
Windows Update keeps running and running for hours...Clean Install SSD
Hello all... Befuddling problem as I am pretty tech savvy but for whatever reason I can not get windows update to quite "checking" for update: So far.... 1) Downloaded SURT, ran fulling with no reported errors 2) Ran SFC with no reported errors
Windows Updates & Activation
Windows Update not running. Error Code 0xc8000247 when running SURT
Please help me out - I replaced my defective HDD with a new Samsung Spinpoint HDD, re-installed my Windows 7 image using the recovery DVDs, and can't update windows at all after that. I tried following the steps from Windows Update Posting Instructions - System Update Readiness Tool (SURT) and...
Windows Updates & Activation
Running dual Boot w/ Vista and Win 7, question on running programs
Greetings, New to the forum! I recently installed Win 7 on a second Hard drive. Is it possible to run the programs I had installed on the Vista Hard drive? Both are HD's are still installed. Thanks, Brad
General Discussion
BSOD running when running intel driver update utility and more apps
hello sorry if my post isnt great im a newbie here but for some time now ive been getting BSODs and finally figured out how to debug it with WinDbg (x86) and set the symbols for windows but i cant read the text. ive tried reinstalling my GPU and Java but no luck. when i try to run intel driver...
BSOD Help and Support


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:24.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App