Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Workaround for files that cannot be accessed ("Access is Denied")

11 Mar 2012   #1

windows 7
Workaround for files that cannot be accessed ("Access is Denied")

A few thousand of my pictures could not be accessed anymore after I had to re-install my whole computer after a crash. They all got the error message: "Access is Denied".
Also copying and deleting is impossible.
With the great free tool UNLOCKER I could still delete them.

Then, searching for an explanation, I found forum posts trying to explain that the error message had to do with older Windows versions, different folder systems, links instead of real files. I didnt understand at all, but wanted to follow up the advice 'take ownership an change permissions'. So I went to the Reccle Bin and restored the unaccessible files.
After restoring their behavior was completely normal.

Can other people let me know if the following steps work well for them too? Or if they have a different/better solution?
1. Install UNLOCKER
2. Rightclick on the unaccessible files (group selection possible) and select DELETE.
3. Go to the recycle bin, select the same files, right click and select RESTORE.
4. Files should be accessible now.

My System SpecsSystem Spec
11 Mar 2012   #2

win 7 ultimate32bit, Win8.1pro wmc 32bit

Hi WimYogya , You could always try this Take Ownership Shortcut
My System SpecsSystem Spec
12 Mar 2012   #3

windows 7

No, I can't try that: right clicking shows no menu options about taking ownerships
My System SpecsSystem Spec

12 Mar 2012   #4

W7 Pro SP1 64bit

The process of taking ownership of files can be confusing - so Mark made a file that you can download, unzip and merge with your registry so that the "take ownership" option will appear in the context menu.

I have Unlocker and have used it for years. Like you said, it moved the files that you were working with to the recycle bin. My guess is that when the undelete process put them back, they inherited the security settings of the parent folder - so you could get to them. That is pure conjecture on my part because I have no way of knowing just what part of the security descriptors were messed up on the original set of files... so I cannot duplicate/test to see if the steps that you took will always work.

It does not sound all that safe. For instance, Unlocker could be deleting more files than the recycle bin can hold... then some would be lost. People are better off learning the take ownership steps.

Edit: I tested one situation on a folder that I had removed all but the system access to. Unlocker deleted the folder (and a subfolder with the same restrictions) but I could not restore them from the recycle bin. I tested this stuff in a Virtual Machine.
My System SpecsSystem Spec
12 Mar 2012   #5

windows 7

For me it works well with Unlocker > Delete > Restore.
I do it step by step: I locate the unaccessible files (they have no thumbnail, just an icon), select a bunch and delete them, select a few more etc, then after max 250-300 I undelete them and... Voilą! All ok.
I have never understood the whole ownership stuff well - especially in these abnormal conditions where I seem to be owner but am not.
I take your warning seriously and will not delete complete folders through unlocker if I want to restore them.
My System SpecsSystem Spec
12 Mar 2012   #6

W7 Pro SP1 64bit

That is an interesting work around you have found

Yes, the whole ownership/permissions thing can be a bit much.
My System SpecsSystem Spec

 Workaround for files that cannot be accessed ("Access is Denied")

Thread Tools

Similar help and support threads
Thread Forum
"access denied" when using "assoc" and "ftype" from cmdline?
I tried to associate the file extension .txt to a new editor program with the well known cmdline programs ASSOC and FTYPE. No, assigning them through WinExplorer menu does not work. But this is another problem which should not discussed here. When I type now one of the following...
General Discussion
"Destination Folder Access Denied" when modifying Program Files folder Destination Folder Access Denied ------------------------------------ You'll need to provide administrator permission to copy to this folder. <Folder/Sub-Folder Name> Date created: <Creation Date> ------------------------------------ Continue Skip
General Discussion
"Access is denied" - "Unable to display current owner"
Hi, I just tried to install the latest iTunes update, but keep getting an error when it tries to access the C:\Program Files\iPod folder. When I try to access the iPod folder directly through Windows Explorer, I get "Access is denied". The same happens when logged in with the system...
Network & Sharing
"Access denied" to minidump files
Hello, Brand new system here. Windows 7 x64. Have been getting an occasional blue screen. Sometimes many days can go by without one, then twice in one day. I would like to proceed with trying to track down the cause of the BSODs, but before I ask for help on that, I'd like to be able to...
BSOD Help and Support
"Access Denied" for "Documents and Settings"
I have tried logging on as the hidden Admin and I have checked my permissions but I still can't access this folder. I think there are some Firefox files in this folder and I need to see them. Any help? Thanks, Frank
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 16:19.
Twitter Facebook Google+