Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: New user here - 'access denied' problem

03 Apr 2012   #1

Windows 7 Home Premium 64bit
New user here - 'access denied' problem

Hi to you all. I am new to Win7 & to IE9 & I hate it. Or more specifically, I hate having to learn it. I was so happy with XP but now I'm stuck with this & having no fun at all.
However I understand that is another subject.
Today's problem: I need to dl some dll's into SysWow64 in order for Photoshop filters to work in Paint Shop Pro. Everyone who's upgraded to Win7 has done this without any problem that I know of, however I get "Access is Denied you are not allowed to create *name of dll*".
I followed the instructions to change ownership & permissions here to see the update that it doesn't work for many people. I see the advice to use Lockhunter, however I don't know the validity of that advice & also I am not having trouble getting into a file at all.
Can anyone help me please, as my ability to use my graphics program is limited until my plugins work.
I thank anyone who takes the time to read this.

My System SpecsSystem Spec
03 Apr 2012   #2

64-bit Windows 10 Pro

Hello Wyldrose, and welcome to Seven Forums.

You will not be able to save anything directly into a system folder.

Instead, you would need to save (create??) it to say your desktop first, unblock the file, then move/copy it into the SysWow64 folder, and click on Continue and Yes (UAC) to approve it.

Are these .dll files replacing existing .dll files with the same name in the SysWow64 folder, or just new ones that you are adding into the folder?
My System SpecsSystem Spec
03 Apr 2012   #3

Windows 7 Home Premium 64bit

Thank you Brink for such a speedy response!
It's really odd that the dozens of people in my graphics groups who have made this change, haven't made this method clear. It also reminds me of the "new" way I now have to install fonts.
I will follow your instructions & report back. I'll be doing it tomorrow as it's late & I've had a frustrating evening.

These are brand new dll's (they do not already exist within the folder.) HERE is the simple tut that many use with success.

Thanks again - I have a feeling you'll be seeing more of me
My System SpecsSystem Spec

03 Apr 2012   #4

64-bit Windows 10 Pro

You're welcome. I look forward to hearing your results. :)
My System SpecsSystem Spec
04 Apr 2012   #5

Windows 7 Home Premium 64bit

Well that was interesting!
I opened the zip file onto my desktop then opened the folder with the dll's.
Just cos I really wanted it to work, I copied all 10 & went to the SysWow64 folder then opened that & pasted. And it did work!
Turned out 3 of them were already there (I guess they got there on my other attempts) & the other 7 just pasted right in. Didn't have to do anything else.
Every 2nd or 3rd person I know has done this in a slightly different way, including the actual number of dll's they believe is necessary. (I'm going to get a zip of the smaller number & delete the extra's to see if that works too.)
I haven't actually tried any plugins yet cos I have 3 pages on a menu so it would take a long time to get thru all of them but I'll come back if it's a complete disaster & it's made no difference.

Thank you Brink!
My System SpecsSystem Spec
04 Apr 2012   #6

64-bit Windows 10 Pro

You're most welcome. I'm happy to hear that you got it all sorted. :)
My System SpecsSystem Spec
04 Apr 2012   #7

Windows 7 Home Premium 64bit

And yep, I did a test of plugins that did not work 2 days ago & now they do! :)
My System SpecsSystem Spec
13 May 2012   #8

Win 7
Worked for me too, thank you

I don't know if this was a functon of having the UAC on, or that I am now running x64, but this was a first, being denied save to- rights on a System folder.

The save to someplace else and copy/paste worked for me, thank you for the help.

My System SpecsSystem Spec

 New user here - 'access denied' problem

Thread Tools

Similar help and support threads
Thread Forum
Access is denied problem i get this problem whenever i try to install a driver
Directory & User Permissions, access denied
i was working on permissions, ownership, and auditing. i was wondering, a lot of files deny access regardless of whether i assume ownership, or so for my group. are those denials logged somewhere so I can delve into the purpose of those files and reason they are locked? too many to list from...
General Discussion
Import Pictures to NAS "Access Denied" Error Though User Has Access
Hi, All. I've got an interesting situation that I'm hoping can be resolved. I built a server using FreeNAS 8.2 to store family pictures, videos, music, and Windows backups. In my home we have Windows 7 Home Premium 64bit and Windows 7 Professional 64bit. The server is setup with 3 Windows (CIFS)...
Network & Sharing
XP User denied access across network
I have a very simple network with just 2 laptops, one running Windows 7 and the other XP. The XP computer has one user and no password. The Win7 has 2 users, one with a password and one with no password. I have done all the right things to make Win7 files visible across the network but...
Network & Sharing
Access denied and user privileges issues
Hi, I am experiencing weird issues with my Windows 7 64bit Pro installation. Some, but not all, programs won’t start, giving me a “The application was unable to start correctly 0xc0000022 click ok to close the application” error. It seems that 0xc0000022 is linked to some kind of access denied...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 04:21.
Twitter Facebook Google+