Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: A really strange error with Active Directory Domain.

15 Apr 2012   #1

Enterprise 64-bit
A really strange error with Active Directory Domain.

My customer has a small business with 2 x HP Proliant ML110 G6 servers installed ith VMware ESX 4.1.

He has 7 Windows 7 64-bit workstations in a domain. He has a Windows 2003, 32-bit Domain Controller and 5 of the machines are in the domain. The other two are in a Workgroup and have DNS and DHCP on Windows 2003 Servers also 32-bit. All of these run as VMware Virtual Servers on the Proliants.

The workstations in the Domain are all Windows 7 Ultimate 64-bit. Everything has been working well for almost 3 years. A few weeks ago, they setup an extra server but decided that the VMware Server that the DC was on, was running low on memory, so they Cloned the Windows 2003 DC to the other VMware server. They say that everything was fine until they discovered that the shared printers no longer worked and various other problems.

That was when I got involved. When I checked Control Panel --> System --> Advanced System Settings --> Computer Name, it shows the Full Computer name (plus domain), the Domain BUT...

The Network ID is greyed out but the Change Button is OK. If I click the Change Button, Member of Domain shows the domain name, but it's greyed out.

I shut down the cloned Domain Controller and started up the original one, but this didn't make any difference.

I tried taking one of the workstations out of the domain, but when I tried to put it back, the Domain stayed greyed out, so no way to put it back in. Netdom is also missing from all the workstations.

They had a backup of this workstation, so I restored the backup and Voila! the computer was back in the Domain.

Unfortunately all the backups of the other win7 Workstations are WAY out of date.

Does anyone have any idea as to how to fix this problem?

My System SpecsSystem Spec
15 Apr 2012   #2

Windows 7 Home Premium 32bit

First you should never Clone a DC, to make a new DC, you install Windows Server and then run DCPRomo the new one. Then if you don't want the original, you run DCpromo to stop it from becoming a DC.

On a DC, I would expect some Domain settings to be greyed out as they cannot be changed once a server is a domain controller. The only way to to get at some of the settings is to reboot the server into safe mode (or Directory Services Recovery mode) by pressing F8 when it boots.

Have you had a look at the Event Viewer console esp DFS, DNS and Directory SErvices logs to see what it is complaining about?
My System SpecsSystem Spec
15 Apr 2012   #3

Enterprise 64-bit

Hang on, it wasn't ME that did this. I'm just the sucker they call in and expect me to fix the mess that other people make!

I switched OFF the cloned DC and restarted the original DC. The DC seems to be working fine, because the moment I restored the backup of the Win 7 Workstation (taken BEFORE they screwed it up), it was back in the Domain, nothing greyed out and I can use the Domain change Wizard with no problem.

They cleared the Event log before i got there, but it seems to be functioning normally with hundreds of warnings about backing up (normal in small biz around here - why backup, it won't break!!!).

Can't do much more until I go there tomorrow.

I think the problem lies in the Win 7 Workstations, but I have never seen this before and I haven't a clue, so any suggestions will be appreciated.
My System SpecsSystem Spec


 A really strange error with Active Directory Domain.

Thread Tools

Similar help and support threads
Thread Forum
Active Directory Domain Service not currently available
Trying to print to wireless Brother printer that was working perfectly, also lost communication with Ethernet connected HP laserjet. Get errors indicating "printer offline" and Netgear WIMDR3400v2 doesn't have a driver. These printers work from other computers on the LAN, and were working until...
Hardware & Devices
Active Directory Domain Services unavailable - print error
HP 3015 All-in-One has worked fine for years, plugged into wife's PC. Yesterday it stopped communicating and the error message; "Active Directory Domain Services unavailable" is cryptic. This error is discussed in various internet fora but no solution found is pertinent to my problem. ...
Hardware & Devices
Active Directory Domain not available
Hello, I'm having problems connecting a printer to my laptop. The printer was working but when my laptop went away for repair it did not work on its return. The printer works on my macbook and my PC running Vista however it will not run on the laptop running Windows 7 home premium 64 bit. ...
Hardware & Devices
active directory domain services is currently unavailable error
Purchased my Dell Studio 1749 laptop on Mon. and trying to add my printer/copier at my office. when I go to the print page in Word 2007 there is an Find Printer button. I've used this feature before to install printers. but, when I click on the button I get this error message - Active Directory...
Network & Sharing
The Active Directory Domain Services -error
Hi, I'm new to these forms, my name is Kcaz. Today I was trying to add wireless printers to my computer (Toshiba running Windows 7 64 bit). At home, I have one wireless printer (Cannon) which works fine. To install that i think I downloaded the drivers from a CD. Now I was trying to download...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:01.
Twitter Facebook Google+