Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Computer Context menu - Manage not working

26 Apr 2013   #71

Windows 7 x64

Quote   Quote: Originally Posted by enriquep View Post
Quote   Quote: Originally Posted by onlytanmoy View Post
Quote   Quote: Originally Posted by BodgeIT View Post

This did it for me. Much nicer fix than having to copy in old Vista files, but thanks for all the efforts to resolve this, it was a PITA.
that did the trick for me as well thanks a lot Tyseyh.
This is a really old thread, but for others who might be interested... Tyseyh's tip also worked for me
I havent tried it but will surely do it and iam sure it will work, thanks all for saving my time. god bless you all

My System SpecsSystem Spec
18 May 2013   #72

Windows 7 Ultimate x32

Excellent trick guys...!!!
The Computer Management now works great with the right-click...!!!
Cheers from Greece...!!!
Big thanks to Tyseyh for his excellent solution...!!!
My System SpecsSystem Spec
25 Jul 2013   #73

Windows XP, Windows 7, Windows Server 200X

Quote   Quote: Originally Posted by Tyseyh View Post
hello everyone iv been reading through all the posts here and someone was right about the reg key except the one posted here didnt work for me. my problem was Right click my Computer - manage- Loading circle for a sec then goes. Thats it, nothing. I added this key that i found somewhere else an it works just fine. I wish i knew the site which i got it from.

Anyway please by all means check it make sure its not malicious or anything ( If thats even possible from a reg key ) id imagine it could be. Anyway here it is but please be warned this isnt my key, i didnt find the solution i simply found a site with the solution.

Here is it :)
Just signed up to say thanks, this worked for me too! Will stick around on these forums
My System SpecsSystem Spec

10 Sep 2013   #74

Windows 7 Home x64

Same troubles here. None of the suggested solutions in this thread worked (except maybe TheVinesKid solution, but the mentioned attached file is no longer part of his post).
This workaround did it for me: Right Click Manage stops working.

In particular the suggestion to put
%SystemRoot%\system32\mmc.exe %SystemRoot%\system32\compmgmt.msc /s
My System SpecsSystem Spec
11 Feb 2015   #75

windows 7 ultimate x64

yes yes yes yes yes ...that did it for me...replace the default data with %SystemRoot%\system32\mmc.exe %SystemRoot%\system32\compmgmt.msc /s in the registry key [HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\shell\Manage\command]
And manage indeed works...

What is very weird is that the above in bold is not what the tutorial link says to do, however my issue is fixed soooooooooooo.........

THANKYOU TOMVDP,,,thankyou all for your incredible expertise

PS: Go figure; you have to hack the registry simply to get the manage shortcut to work but its a nice hack...I did NOT have to do anything else....

My System SpecsSystem Spec
23 Apr 2015   #76

Windows 7 Pro x64

Before I read tomvdp's solution, I found an alternate that worked as well. It was posted on the windows community site, and it worked when NO other solution worked. Specifically, I changed:

"HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders\Common Administrative Tools" setting=%ProgramData%\Microsoft\Windows\Start Menu\Programs\Tools & Utils\Admin Tools


That is where I move all my tools to. As for many others, the manage link had worked until very recently, and I don't know what caused it to break, but I found the change above did the trick. I have also made the change tomvdp suggested, and that does not cause it not to work, so I'm going to leave both in place. We'll see what happens.

My System SpecsSystem Spec
17 Jul 2015   #77

Windows 7 Ultimate x64
Problem is in Computer Management Launcher

I had the same problem and fixed it with a registry modification.
Go to the CLSID key under HKEY_CLASSES_ROOT and find the computer icon key:

{20D04FE0-3AEA-1069-A2D8-08002B30309D} Go to the sub-key shell\manage\command

Change the value of command from: %SystemRoot%\system32\CompMgmtLauncher.exe
to: mmc %SystemRoot%\system32\compmgmt.msc

This changes Manage right click to use the msc directly instead of calling the launcher.
Works every time!

Also repairs similar complaint that right clicking Manage brings up a window stating no program is associated with launcher.
My System SpecsSystem Spec

 Computer Context menu - Manage not working

Thread Tools

Similar help and support threads
Thread Forum
can't access Manage in Computer context menu
This one is new to me so maybe you guys can help. When right clicking the computer icon on the desktop and selecting "Manage" Nothing happens. I can access MMC console from the startmenu search function and add the snapins I need to do whatever I need to do, such as Disk Management, Services etc....
General Discussion
Computer/Manage context Menu Platinum message
Ok, I'm not sure where to post this, so here it is.... Normally I used to right click on Computer and Choose Manage and do what I needed to do. Now, in Windows 7 Prof x64, I get a message to "Register Context Menu Platinum" and it counts down from what ever number and then I go to the web site...
General Discussion
Manage - Add or Remove from Computer Context Menu
How to Add or Remove "Manage" from Computer Context Menu This will show you how to add or remove the Manage item from the Computer context menu in the Start Menu, desktop icon, and Windows Explorer navigation pane in Windows 7 and Vista. When Manage is selected, it runs the...
Computer context menu manage gives error
Hi, When I go to start>right click on Computer>manage, it gives the following error I have checked that Computer management is in the Administrative Tools folder. Is there a way to restore the shortcut?
General Discussion
Can not open "Manage" using context menu any more
Hello together, when I use my right mouse button and click on Computer -> Manage an error message appears: "This file does not have a program associated with it for performing this action. Please install a program or, if one is already installed, create an association in the Default Programs...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:01.
Twitter Facebook Google+