Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Can't Delete a Folder.

20 Apr 2012   #1

Windows 7 Home Premium 64bit
Can't Delete a Folder.

First off, sorry if this is in the wrong place. I had no idea what section to post this in.
Today I was using a program for the game 'Minecraft' called MultiMC and when deleting files it created I don't need anymore, I came across a folder I couldn't open, delete or do anything with. When I try to open it it says '(location) is not accessible. Access is denied'. When I try delete it, it says 'You need permission to perform this action. You require permission from the computer's administrator to make changed to this folder' (yet, I am the administrator - the only account on the computer). It also gives me 'try again' and cancel options, neither of which help. On properties it says 'Unable to display current owner' and won't let me change the owner, even to the administrator. The folder is 0 bytes, but I would like to get rid of it because I might want to delete the folder it is in in the future, plus I don't know if it is a virus or anything. Please can someone help.

My System SpecsSystem Spec
20 Apr 2012   #2

Windows 7 x64 Ultimate

It is entirely possible that the folder is already deleted and explorer is being stupid. It happens now and then, especially on networked drives.

Try rebooting and see if the folder is still there or not...

Can also try DLing another file explorer like Explorer++ and see if the folder is really there or not.
My System SpecsSystem Spec
20 Apr 2012   #3

Windows 7 Home Premium x64

It's possible a module of MultiMC is still running and controls the folder in question.
My System SpecsSystem Spec

20 Apr 2012   #4

XP / Win7 x64 Pro

Are you sure it's a MineCraft folder? What's the folder path?
My System SpecsSystem Spec
20 Apr 2012   #5

Microsoft Windows 7 Home Premium 64-bit 7600

also right clicking the folder and selecting properties and the the security tab, adding administrator or your pc username to the security permission, then try deleting it.
My System SpecsSystem Spec
20 Apr 2012   #6

64-bit Windows 10 Pro

Hello Joppp, and welcome to Seven Forums.

I agree with what FliGi7 posted above.

I would recommend to not try and delete the folder just yet until you post back with the full path of the folder for us to help make sure that it's not a protected Windows OS file, or a junction point. You wouldn't want to delete it if that was the case.
My System SpecsSystem Spec

 Can't Delete a Folder.

Thread Tools

Similar help and support threads
Thread Forum
'Folder in use!' message, I can't delete/move this folder, help!
'Folder in use! The action can't be completed because the folder or a file in it is open in another program. Close the folder and try again.' This is the message I get, I want to delete the folder since I no longer need it. The folder contains ScpControl.dll and.ScpService.exe. I haven't found...
General Discussion
HELP Me delete this Folder Please
Hi i have a folder that will not let me delete it, I have tried to change permissions but do not really know what I am doing so any advice would help.
General Discussion
Not able to delete folder in folder infinite structure.
I was using Netbeans IDE and xampp, It crashed when I moved a project using its function, and when I checked out the folder it had infinite folder in folder structure. Its not possible to delete it , I can not open more than below . . ...
General Discussion
Can't Delete Folder
I keep getting this error when I try to deleted the folder; I unchecked and applied Read Only, but the box stayed checked like that. I'm logged in as myself, which is an administrator account
General Discussion
Can't delete a folder
Whatever I try, I cannot delete this folder. I've tried to rename it, added files to it, safe mode, nothing works. I might have to format the partition. Any ideas?
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:16.
Twitter Facebook Google+