Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Permissions Denied, can't copy my own files

29 Apr 2012   #1

Windows 7 nVidia 64 bit
Permissions Denied, can't copy my own files

I'm new to this site, so i apologise in advance if this is in the wrong section.

On my external hdd, I recently noticed that one specific folder has reduced permissions ( containing my game ISO's ). I have tried just about every guide on how to set, change, add permissions for myself, all of which end in the same way:

the same window will pop up:

Error Applying Security
An error occurred while applying security to:
G:\ ['here it lists the folder directory']
Access is denied.
Continue / Cancel

Notes: I am on the only Administrative account, with all other accounts disabled, guest disabled, and I did try this with Kaspersky Internet Security enabled and disabled, and i have tried a virus scan and lockhunter x64 2-0-beta.

For all sub folders and files in the Problem folder, 3 permissions exist under the security window:
Everyone (with greyed out permissions, modify, write and Full control UN-checked )
S-1-5-21-['lots of numbers here'] (full permissions )
S-1-5-21-['different numbers, same quantity of digits'] (full permissions )

One additional thing: i have recently re-formatted, but i installed the exact same operating system (Windows 7 nVidia x64 v6.1, build: 7600) just this time i installed more updates with windows updater.

Please help, and thanks in advance.

My System SpecsSystem Spec
29 Apr 2012   #2

Linux CENTOS 7 / various Windows OS'es and servers

Hi there
Sorry if you've already tried it but have you done a right mouse click on the disk==>properties==>security then open the security tag change permissions and add your user name

Then click all the boxes screen shot enc


Attached Images
Permissions Denied, can't copy my own files-capture.png 
My System SpecsSystem Spec
29 Apr 2012   #3

Windows 10 Pro 64-Bit

you can also check the ownership.
My System SpecsSystem Spec

29 Apr 2012   #4

Windows 7 Ultimate SP1 64-Bit

My System SpecsSystem Spec
29 Apr 2012   #5

Windows 7 nVidia 64 bit

@jimbo45: I have tried that method, and it just gives me the message listed above.
@timbog: I'm not completely sure how to tackle this problem via ownership.
@seavixen32: Your suggestion refers to sharing: "To allow full access to files you are sharing". Although, i have tried this method ( it is fundamentally the same as jimbo45's) and gave me the same message listed above.

Thanks to all of you guys, but your recommendations just didn't do the trick.
My System SpecsSystem Spec
29 Apr 2012   #6

Windows 7 Ultimate

I use this "take ownership" rt-click context menu addition:
Add "Take Ownership" to Explorer Right-Click Menu in Win 7 or Vista - How-To Geek
My System SpecsSystem Spec
30 Apr 2012   #7

Windows 7 nVidia 64 bit

flemur13013, thank you so much, seems to have worked perfectly
My System SpecsSystem Spec
19 Dec 2013   #8

Windows 7 Premium 64bit
Take Ownership, ftw!

Reviving the dead here but wanted to thank 'flemur13013' for the "Take Ownership" suggestion. It worked perfectly on Windows 8.1.
My System SpecsSystem Spec

 Permissions Denied, can't copy my own files

Thread Tools

Similar help and support threads
Thread Forum
Cannot open/copy files I have 'Full Control': "you need permissions"
I cannot open/copy files within a folder containing web files. Basically the files that make up my website in a PHP-based CMS, a bit like Wordpress. All the files appear to be created by someone else, but I bought licencing rights (i.e. they are website 'theme' files). All the files were...
General Discussion
Permission denied to access/copy files from my old computer
I built a new desktop and did a clean Windows 7 64-bit install. I hooked up the hard drive from my old PC, which had XP on it, so I could copy all the files over to my new hard drive. But when I try, I keep getting errors that I don't have permission to access the file or copy the file. I was...
General Discussion
Permission denied to copy my own files
Hi there, I know there have been a lot of tutorial/tips on how to deal with permission when you need to copy files on Windows 7. I have turned off UAC, take the ownership of the folder and all sub-folders/files ... but still I have not been able to copy quite a few files in one of my folder. ...
General Discussion
can't copy old windows files...access denied
hey guys. i installed windows 7 pro x64 recently. i'm in the process of copying my own old windows xp files, as well as copying the backed up windows xp files from my friend's installation that were in my old hard drive. i've been battling windows 7 with permissions left and right to copy the...
General Discussion
Acces Denied - copy files external drive (xp)
Hi - In copying files from external drive (xp files) I received a lot of access denied errors on open. I right clicked on drive, and some subsequent folders, and took ownership, and set up full control permissions for admin group (as I am admin). STill got errors on some of the files. They...
System Security

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 12:47.
Twitter Facebook Google+