Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: MBR Error 1 on startup

02 May 2012   #1

Windows 7
MBR Error 1 on startup

I’m having a major problem booting up my PC. I keep getting the error message “mbr error 1 Press any key to boot from floppy” every time I reboot my PC.

The PC is running Windows 7 Professional 64-bit, and everything was working fine until I started to do some cleaning up in preparation for moving my OS from an existing HDD to a new SSD. My PC has a Gigabyte X58A-UD3r motherboard.

I cleaned up my files using Windows System Cleanup and also defragmented the C: drive. All of this seemed to go successfully. On rebooting my PC, and with the SSD installed in an external caddy connected via eSata (because I wanted to clone my existing C: drive across to it to avoid a new installation of Windows 7), I entered BIOS and changed the SATA from IDE to AHCI. (As far as I am aware I didn’t change anything else). Then I booted up the PC and got the error suggesting that there was mbr error 1 etc.

I turned off the PC and went back into BIOS and reset the SATA back to IDE, and rebooted. Same error. I tried rebooting a number of times – no success.

I then put my Windows 7 installation disc into the DVD drive and rebooted from the DVD (after selecting the DVD drive as the boot option in the BIOS startup). It seemed to boot up right into some version of Windows (note: it did not ask me if I wanted to install or repair windows; it just came up with a standard Windows 7 wallpaper and nothing else).
I rebooted again, with the Windows 7 disc in the DVD drive, but when it asked me if I wanted to boot from DVD, I just let it run – and it booted up my Windows as normal. But when I tried and reboot without the DVD in the drive and with the HDD boot option as the primary boot, it still gave me the mbr error.
So I booted once again with the Windows DVD, and created a Windows Repair Disc. I rebooted with this and attempted to carry out a MBR repair (using the CMD line: bootrec.exe /fixmbr – which indicated that it ran successfully). I rebooted the PC – still got the mbr error.

I rebooted with the repair disc again and ran: bootrec.exe /fixmbr, and bootrec.exe /fixboot, and bootrec.exe /rebuildbcd. They all seemed to run successfully – but on reboot I still got the mbr error.
I also downloaded and rebuilt the MBR using the MBR rebuild utility on Partition Wizard Mini Tool – it still hasn’t solved the problem.
I also tried to recover using a previous backup of my C: drive (one created yesterday before I did any clean up or defragmentation, but I am not sure if it had the MBR backed up) – it restored OK, but didn’t solve the error.
I also ran chkdsk on my C: drive – it suggested that the drive was clean with no errors.

So at the moment the only way I can boot up my PC is to have the Windows 7 installation disc in the DVD drive and have the DVD drive selected as the first boot device (even though I don’t subsequently press any button to boot from the DVD) – it just seems to force it to get around the mbr error somehow.

Can anybody suggest how I can resolve this issue ( as I am pulling out what little hair I have left trying to find a solution)?

My System SpecsSystem Spec
02 May 2012   #2
Microsoft MVP


Being prompted for floppy is unusual so I would first power down, drain power by holding power button, then physically unplug any floppy drive.

If that doesn't solve the strange prompt then enter BIOS setup and remove any floppy device from all listings including boot order.

While in BIOS setup first reset to defaults: Clear CMOS - 3 Ways to Clear the CMOS - Reset BIOS

Next set SATA controller to AHCI. Unplug all other HD's and peripherals. Plug in on SATA HD to mobo SATA port 1.

Then boot into Win7 DVD to Clean Reinstall - Factory OEM Windows 7 which steps are the same for retail.

If this fails wipe the HD first from DVD Command Line with Diskpart Clean Command.

If these steps all fail post back any error message and exact failure point during Clean Install Windows 7

After reinstall plug back in your HD to access and copy over data and access program installers which should be stored in your Downloads file.
My System SpecsSystem Spec
03 May 2012   #3

Windows 7


Thanks for the suggestions which I will try - however I am trying to avoid a fresh install of Windows 7 if I can (as I have a lot of programs and reinstalling Windows 7 and then the other programs takes an age).

There is no floppy drive in my system and I have reset the BIOS to "None" for FDD installed - made no difference; I also tried setting the BIOS to continue booting if there were errors - made no difference - I still get the error or need to have my Windows 7 DVD in the DVD drive to get it to boot.

I also tried setting the BIOS to "optimised settings" - still get problem.

Also, when I tried to boot from the Windows 7 install disc - it does not come up with the "Install/Repair" selection window - it reads from the DVD and then says "starting windows" (apparently like a normal boot) before opening a window with the Windows 7 background (the blue one with the bird on the branch). It then just hangs there doing nothing, with no icons and no response from the keyboard or mouse.
My System SpecsSystem Spec

03 May 2012   #4
Microsoft MVP


See if you need to remove the floppy listing elsewhere in BIOS setup including BIOS Boot Order in order to get rid of the bad prompt.

Check the disk to make sure it is clean and not scratched. If it continues to refuse to boot then try the F8 System Recovery Options.

Next try downloading the lastest official installer ISO to burn to DVD or write to flash stick as prescribed in Clean Reinstall - Factory OEM Windows 7. If the disk won't boot then try the flash stick method. If it won't boot when set first to boot in BIOS setup, then try using the one time BIOS Boot Menu key.

Try each of the steps given and report back the results. If all fail you can rescue your data externally with free Paragon rescue CD which will autostart on its own, or by slaving the HD to another computer, then wipe the HD with Diskpart Clean Command in the other computer or using free Partition Wizard bootable CD which will also start itself.

This forces the installer to also autostart to Clean Reinstall - Factory OEM Windows 7 which steps are the same for retail.
My System SpecsSystem Spec
03 May 2012   #5

Windows 7 Ultimate x64

Repair MBR:

Boot From the Windows Install Disc
The first thing you’ll need to do is boot off the install disc, and then click through until you see the “Repair your computer” link in the lower left-hand corner.
You’ll need to choose the correct installation of Windows and then click the Next button.
And then you’ll get to the System Recovery Options screen, where you can get to the Command Prompt.

Repairing the Master Boot Record

If you want to restore the master boot record, you can simply type in the following command:

bootrec /fixmbr

You can also write a new boot sector onto the system partition with this command (which is often more useful):

bootrec /fixboot

And of course, if you just use bootrec /? you’ll be able to see all the options.
My System SpecsSystem Spec
03 May 2012   #6

Windows 7

alishathomaz: thanks for the response, but if you look at my original post you'll see that I was unable to get to the repair option on my Windows Install disc and none of the bootrec.exe commands succeeded in fixing the problem. When I tried to carry out a repair using a Windows Repair Disc - it found no errors and made no changes.

I'm still working through some of the suggestions of gregrocker.
My System SpecsSystem Spec
09 May 2012   #7

Windows 7

After days of pulling my hair out I have finally solved the issue – but unfortunately the saga seems to have damaged/corrupted my HDD.

First of all I had a 2Tb HDD divided into 2 partitions ( 1 = C: 500Gb for the operating system and key files; 1 = D: 1500Gb for data). My plan was to have cloned the C: portion as it was only ca. 80Gb in size and so would have fitted neatly onto my new 128Gb SDD.

The error arose when I first of all tried to defrag the C: partition and then set the drive to ACHI (rather than IDE mode). This messed up the MBR. I tried resetting the BIOS SATA back to IDE, but got the error detailed in my initial post. I tried resetting the BIOS and also clearing the CMOS but still got the mbr error 1 message on boot.

So in the end, I downloaded and installed a later version of the BIOS for my motherboard (Gigabyte X50-UD3r rev2; changed from BIOS version FA to FH), and reset all of the SATA back to IDE. I then booted up with my Windows 7 installation disc in the DVD, tried to boot from DVD, and at long last it booted up from the DVD and gave me the option to repair the mbr. My PC booted up and then I was able to restart it again without having the DVD in the drive.

I then decided that rather than try and clone my C: drive onto the new SSD, that I would carry out a fresh install of Windows 7 Professional 64-bit. I disconnected all HDDS, installed the SDD, and went in to the BIOS and set the SATA regime to ACHI. I was then able to install Windows 7 successfully without having to worry about setting up TRIM or aligning the SDD (as luckily Windows 7 carried this out on installation).

After installing/updating Windows, MS Office and the other programs I use, I then tried to install the software for my HP Officejet printer (which I had previously installed without problem on this and other PC's using either the 64-bit or 32-bit copies of the software). I downloaded the latest version of the 64-bit software from HP, and started the install. It ran into a problem and didn't install properly, and then I found that I was unable to uninstall it as it was missing some files to uninstall smoothly. I tried an uninstall using Revo Uninstaller and that also failed.

So I decided to go back to square 1, and reinstall Windows from scratch (again!). I didn't erase or reformat the SDD – just deleted the MBR and main partition at the start of the Windows 7 installation. His time I installed the Officejet software immediately after I had installed/updated Windows 7 and MS Office 2010, and before I had installed any firewall (Comodo) or AV (Avast). The installation went smoothly. I then installed the rest of my software.

On a separate PC, I reformatted my HDD (the one with the C: and D: partitions) and restored a recent backup of my D: (data) drive – BTW this PC had SATA ports set to IDE. I then installed this into my main PC (the one with the SDD and SATA ports set to ACHI). Everything seemed to be OK, until the drive seemed to disappear at times when I was copying data to it, or if I was accessing Outlook 2010 (I had the .pst file on my D: drive).

As it is a WD drive, I ran the WD Lifeguard program – the quick test showed an error, but on rebooting and retesting the quick test ran OK; I'm now running an extended test – but I don't really trust this HDD anymore, so I'll probably restore my data onto a different one.

Now all I have to do is figure out if I can get my Outlook 2010 to search through my emails again – I switched off the Windows Indexing function when I reinstalled Windows as a number of other sites suggested that it was better if it was switched off when using an SDD – however it seems that this function is needed for Outlook searches; so that's another problem to solve!

So I'm really not sure at this stage if the original problem was due to wrong BIOS settings, a corrupted mbr, or a corrupted/failing HDD. All I know is that I never expected that installing a SSD would end up being such a trial!

Oh, and if you are using a Gigabyte X58a-UD3r motherboard - it is recommended that you don't use the Marvell SATA 3 ports for your SSD as these seem to give problems according to other posters (I ended up using the slower SATA 2 Intel ports).
My System SpecsSystem Spec
09 May 2012   #8
Microsoft MVP


On the HD run the WD Lifeguard bootable CD extended test which may repair any problems, followed by a full Disk Check. You'll then know with certainty the condition of the HD. It may only have had some file system errors.

I would not run Comodo firewall unless you have a customized Firewall need. Use the fully perfected Win7 Firewall kept updated automatically.

While Avast was once recommended here equally with Microsoft Security Essentials the clear favorite now is MSE with the Win7 Firewall.
My System SpecsSystem Spec
10 May 2012   #9

Windows 7

Gregrocker: The first time I ran the WD Lifeguard Quick Test I got an error; the second and subsequent times it ran OK. I then ran the Extended test and it seemed OK. I finally ran the chkdsk /r and it hummed away for 7 hours, seemed to find a few bad sectors, but otherwise was OK. So it seems as if the disk is OK (though I have to admit I am reluctant to trust it as my main data disk). Many thanks for your help & suggestions.
My System SpecsSystem Spec
05 Mar 2016   #10

Windows 10 Pro x64

I fixed the problem by changing the boot order of my drives in the BIOS.

I have two internal drives in my PC. A 1TB hitachi drive that has the Windows OS and a 3TB Samsung drive that is used only for storing data. For some reason, the 3TB samsung drive was ahead of the 1TB Hitachi drive in the boot order. I changed the boot order in the BIOS so that Hitachi drive was ahead of the Samsung drive. Then the PC booted properly.

This PC has been working for while with both drives with no problems. So I am not sure why this problem started showing up. Initially I thought the 3TB drive had become corrupt and the boot got stuck at the corrupt drive. But after booting, I was able to open the 3TB drive without problems.
My System SpecsSystem Spec

 MBR Error 1 on startup

Thread Tools

Similar help and support threads
Thread Forum
BSOD on startup, unknown error, startup repair running too long
As the title suggests, my Acer Aspire has been running startup repair for over 20 hours following a BSOD yesterday. I'm not sure if it's worth the wait so maybe you all can shed some light. Yesterday I was stressfully trying to search for something (using Chrome) and the website I was on froze;...
BSOD Help and Support
Error 0101003 Keyboard no detected, stuck on startup/startup repair
Hi guys I was cleaning my laptop turned it on and it just wouldn't work so I turned it off and on again and it was giving me this error code saying my keyboard is not detected in start up. It then says there was a problem and shoots me to startup repair where it's just stuck not doing anything. My...
BSOD Help and Support
Update error 80246008, Restart on Shutdown, dll startup error
This is a family member's laptop. It is a Dell Inspirion N4110 running Win 7 Home Premium x64 They gave it to me complaining that the shutdown button restarts the computer and will not actually shut it down. So I checked its preferences, they were fine. I went into the registry and changed the...
Windows Updates & Activation
Startup Repair Error (Forever Loop) Error Code 0x80070003
Here's my story: My sister's PC had been corrupted in lots of unnecessary programs and apps. I deleted those craps. Windows Action Center then prompts me to update my windows, and I did. PC restarted and POOF!!!, I am seem to be forever stuck in the Startup Repair Loop. So I tried System...
General Discussion
BSOD on startup , error 0x000000f4 . startup takes half an hour
so everything was fine when my laptop started to become very slow and i used to get the BSOD very often so i decided to recover the system to the initial state . i did that and everything was fine , then i updated the windows 7 service pack 1 and finished the installation and rebooted my computer ,...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 19:05.
Twitter Facebook Google+