Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: 32-bit processes hang under Win7 x64 Ultimate

29 Aug 2009   #1

7 Ultimate
32-bit processes hang under Win7 x64 Ultimate

I did a fresh install about a week ago and I've started to notice processes that do not run properly.

For example, Internet Explorer 8 32-bit. If I click it on the start menu I get the 'hourglass' circle to indicate it's loading but after about ten seconds it goes back to the normal cursor and IE never loads. If I look in the Task Manager iexplore.exe (32-bit) is listed even though it hasn't appeared. I can keep running it and each time no window appears but I still get an additional process listed in the Task Manager. Any time I run the 64-bit version it loads immediately.

I've also not been able to run various other programs, including the installer for Kaspersky Internet Security 2010 and DigiGuide. The common theme is they are all 32-bit applications.

Does anyone have a clue what might be wrong with my install?

My System SpecsSystem Spec
29 Aug 2009   #2

Win 8 Release candidate 8400


could you go into event viewer (type event viewer in search) go to the app tab and see what errors are listed relating to the IE problem

My System SpecsSystem Spec
29 Aug 2009   #3

Windows 7 Pro X64 SP1

You don't list your system specs.

32 bit applications would not run for me due to a problem with the drivers for my Asus Xonar DX PCI-E soundcard. (There's a fix available.)
My System SpecsSystem Spec

30 Aug 2009   #4

7 Ultimate

The event viewer doesn't have any errors under the app tab, only two warnings from the last day or so:

Event ID: 3
The Bluetooth solution has encountered a problem and may not function properly. Keyboard connection failed after 2 retries (Timeout).

I know about this anyway as my wireless keyboard is turned off.

Event ID: 1530
Windows detected your registry file is still in use by other applications or services. The file will be unloaded now. The applications or services that hold your registry file may not function properly afterwards.

I always get this warning with XP as well, I suppose something is not unloading quickly enough on reboot.

As for my specs they are as follows:

Abit IP35 Pro
Intel C2Q Q6600
HIS ATI 4850 512MB PCI-e graphics card
Auzentech Mystique PCI sound card

I have three devices I don't yet have drivers for, they are all disabled at the moment:

- Creative Live! Pro webcam (no Windows 7 driver)
- a PL-2303 Serial->USB driver (cannot install driver, 32-bit installer hangs!)
- an ABT2005 ACPI device I cannot identify yet

There are some 32-bit apps running in task manager, loaded at startup. It just won't let me start new ones. As this problem has only started in the last day or two it must be something I've done or installed that's broken it.

Other than the WOW DLLs in the Windows\System* folders are there any other file requirements to run 32-bit apps?

My System SpecsSystem Spec
30 Aug 2009   #5

Win7 RTM

Looks like the Auzentech Mystique uses the same C-Media chipset as the Asus Xonar sound cards. Its drivers are most likely based on the same releases from C-Media, albeit customized by the sound card manufacturer. That means the 32-bit issue Xonar owners have been dealing with will probably exist with your card as well.

Asus released a patch a couple of months ago that fixed the 32-bit app issue on the Xonars. Check Auzentech's website for a newer driver or patch that does the same for their driver set.

The problem with the Asus cards was the resident software that provides EAX emulation for older games. I don't know if the X-Mystique has the same thing, but if it does you can also disable those programs on startup. That fixed the Asus issue until they released a patch.
My System SpecsSystem Spec
30 Aug 2009   #6

Windows 7 Pro X64 SP1

It appears that the Auzentech drivers may also contain the hsmgr pieces that affected the Asus cards. They caused the inability to launch 32 bit apps with Win7 X64 build 7201 and later. (It wasn't a problem with the RC, build 7100.) If there is no patch available from Auzentech, the services can be disabled. (You'd lose EAX emulation.)

I suppose that the "ABT2005 ACPI" mystery device is the uGuru chip. It's a hardware component on the IP35 Pro that is part of the uGuru monitoring and control system. (I had an IP35 Pro, but never used most of the uGuru features. I tended to overclock the old-fashioned way: BIOS settings.) The latest uGuru utility installer is supposed to support Vista X64, os maybe it'll work with Win7 as well. I've read that Abit has gotten out of the motherboard business, which may mean that their support for Win7 on their old products may be limited.
My System SpecsSystem Spec
30 Aug 2009   #7

7 Ultimate

Thank you for the excellent advice. Indeed I do have HsMgr.exe and HsMgr64.exe on my system so I applied the patch for the Asus Xonar card and it has fixed the problem for me as well. That has saved me from reinstalling Win7 and ending up with the same problem all over again.

I will try the Abit uGuru driver. Now I can get back to installing all my other software.
My System SpecsSystem Spec
01 Apr 2010   #8

Windows 7 Home Premium x64

Recently added a 2nd audio card, an Auzentech X-plosion, to listen to music on headphones while others are watching movies using the on-board sound. After installing the only drivers available from Auzentech I ran into the same 32-bit processes hang under Win7 x64 Premium problem. The CmAux64 patch fixed my problem also.

BTW to use a second audio card you need a player that allows you to select which audio card to use. MediaPlayer Classic Home Cinema - it's free, comes in 32 and 64 bit version and does not require additional codecs.
Download Media Player Classic Home Cinema, Free Video Player Download
My System SpecsSystem Spec
25 Sep 2013   #9

X32, V64, S64, E64

Sorry for bumping an old thread, but thought it prudent considering that a recent Broadcom driver pushed via Windows Update (Aug 24th, 2013) caused the same issue. I found this thread via Bing search phrase "32 bit applications keep hanging" second from the top result.

Physically unplug or disable (via "devmgmt.msc") your BroadCom BlueTooth adapter. From "appwiz.cpl" uninstall the BroadCom software, then restart the system. The issue should then cease.

Additional Details:
Windows 7 64-bit Professional.
"ProgramData", "Users" & "Temp" folders are 'SymLinkD' to a different physical drive.
(note: the windows kernel may not 'see' any driver files placed under the above folders)

The 32-bit applications would load up fine, but would hang the second you tried to enter any input via (USB) keyboard. As a work-around you could copy & paste the keyboard input using the mouse and avoid the hang. I do not own any Bluetooth keyboards and have never attempted to setup any such device with this system.

The BlueTooth adapter has been installed since I've had the desktop, but the issue didn't start until after the Windows Update.

The following quotes the update that caused the issue...
Broadcom Corporation - Bluetooth Controller - Broadcom 2046 Bluetooth 2.1+EDR USB Device with First Connect
Installation date: ‎8/‎24/‎2013 12:40 PM
Installation status: Successful
Update type: Optional
Broadcom Corporation Bluetooth Controller software update released in August, 2013
More information:
Driver Information
Help and Support:
Product Solution Centers
The HWID of my device...
My System SpecsSystem Spec
26 Sep 2013   #10

X32, V64, S64, E64

Incidentally, removing this update may have solved another recent issue.

Windows 7 Task Scheduler would ignore the empty checkbox for "Run task as soon as possible after a scheduled start is missed".

When resuming from hibernate/sleep, Task Scheduler would rerun the task for all the missed scheduling points for when the system was off.
My System SpecsSystem Spec

 32-bit processes hang under Win7 x64 Ultimate

Thread Tools

Similar help and support threads
Thread Forum
Win7 Ultimate - Random hang/freeze
Hello there, As the title says, I get random hang/freeze while on desktop. Usually, the system gives some 2-3 freezes (for 4-5 secs) before is hangs out! Then you can't alt-tab or even ctrl+alt+del. I don't know if it matters but I'm also losing sound while freezing. Last but not least, once,...
BSOD Help and Support
Startup Processes Hang Significantly on Windows 7
Hello, It has come to my attention recently that my startup processes completely hang or freeze my computer when they never did before. I'm going to try and give as much information as I can about this issue(s). This is a compact list of all of the items I have checked that are running on...
General Discussion
WIN 7 ultimate x86 RANDOMLY hang (freeze)
I bought a Samsung notebook NP350E5X I clean installed Win7 Ultimate x86 But sometimes it happens that Win7 completely freeze, mostly happens when surfing the net. Sometimes when I'm working in excell. I have the same copy of Win7 installed on another machine, but I had no problems with...
Performance & Maintenance
Upgrading to Ultimate - Hang at 18%
I ran the Windows 7 Ultimate installation on my 64-bit Intel machine with Windows Vista. The installation goes through the process just fine, until it is at 18% of "Expanding Windows files". It never gets past this point. Below it shows "Windows needs to restart your computer", but it never does....
Installation & Setup
Windows 7 Ultimate RTM 64 bit hang up at bios boot
Hello every one, I am new in this forum. I just download Windows 7 ultimate 64 bit RTM from Technet. After intstall windows reboot my system hang up at Auto Detecting AHCI, I can not get into the bios if I am not disconnect my hard drive. I did not had this problem with last test version. this...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:14.
Twitter Facebook Google+