Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Sysprep failed, Windows 7 Ult. 64 bit, new CPU+MB

14 May 2012   #1

Windows 7 Ultimate x64
Sysprep failed, Windows 7 Ult. 64 bit, new CPU+MB

Hi all,

So I recently bought a new CPU+MB (going from AMD to Intel) to upgrade my system; everything else is staying the same. I ran sysprep.exe and it gave me an error. So I searched around and found out it was the WMP service preventing it from working. So I disabled that and then tried Sysprep again. I chose OOBE and generalize since there would be new hardware.

Once I swapped out the motherboards, I booted up and Windows started configuring, but once it got to the "starting services" screen, it came up with an error and rebooted. Rebooting never fixed anything and just kept doing it over and over again. So I browsed the web for some answers and came across a few possible solutions.

First one was to open up cmd (Shift+F10) after the error and check for the errors. I did cd C:\windows\panther
and then
tracerpt setup.etl -o logfile.csv however, no file was found.

I also tried booting into safe mode, which gave an error saying that it could not complete, but upon rebooting normally, appeared as though it would work. It then gave an error at the end saying it couldn't complete, and then the cycle started again.

I also tried a repair from the installation disk to no avail.

I ended up reinstalling my old CPU+MB and re-imaging my hard drives (I have programs installed on multiple drives). The re-imaging took a day to complete, just on the 128GB SSD. The 2TB drive finished in a few hours. I'd rather not have to go through that again if I don't have to.

I'm at a loss as to what went wrong. I'm going to try again this week, but I'm wondering if something else is preventing Sysprep from working correctly. I hope I included enough info for troubleshooting.

Thanks in advance!

My System SpecsSystem Spec
14 May 2012   #2

Windows 10 Pro/ Windows 10 Pro Insider

Here is the tutorial on running sysprep. I don't know why it didn't work. I have used it before and it ran perfect, just as the tutorial said it would. Maybe reading through the tutorial will give you some idea.
My System SpecsSystem Spec
15 May 2012   #3

Windows 7 Ultimate x64

The tutorial is pretty much how I did it the first time, but I tried again. Opened up services.msc and disabled the WMPNetworkSvc, rebooted. As soon as I rebooted, opened up sysprep.exe, set to OOBE, generalize, and shutdown. It ran and the computer shut down. Transferred hard drives to new MB, and booted up, same error. Gets to "Starting Services" and the an error box pops up. "Windows could not complete the installation. To install Windows on this computer, restart the installation."

If I restart, it just goes back to the same error again and again. I tried a safe mode trick someone said worked for them. You boot into safe mode, but windows gives you an error saying you can't complete the install in safe mode, and you need to restart. So I restarted normally, and this time, it makes it through the starting services screen, and goes to the "Setup is installing devices", with a % next to it. Once it makes it to 100% (after the screen, keyboard, and mouse have blinked off a few times), it goes to the 'Setup is applying system settings' screen, and the following error pops up:
"Windows setup could not configure windows to run on this computer's hardware.

Once I hit ok, it just goes right back into the original "Starting services" startup loop.

I haven't reimaged the HDDs yet, as I'm hoping someone can point me in the right direction.
My System SpecsSystem Spec

15 May 2012   #4

Windows 10 Pro/ Windows 10 Pro Insider

Your best option is a clean install. You are not just changing boards but going from AMD to Intel. Any imaging you try to do will most likely not work. Your OS contains AMD drivers from your old board but needs the Intel drivers to work, and an image will carry those AMD drivers. Even if you could get it to work, you most likely will have problems with conflicting drivers.
My System SpecsSystem Spec
15 May 2012   #5

Windows 7 Ultimate x64

I know a clean install is always better, but I was trying to avoid having to reinstall all the software and user settings over again. I was under the impression that using sysprep /oobe /generalize cleaned out the existing drivers and allowed this change. Microsoft even made a note about it here Unsupported Sysprep scenarios . They specifically note you can change CPU vendors with Vista or later by using /generalize.
My System SpecsSystem Spec
16 Feb 2013   #6

XP 32bit

Hi all

I am posting this as a possible solution only, based on the myriad hardware\software configurations which could influence the outcome of a SYSPREP exercise:

I helped a friend upgrade his buggy mainboard\CPU. The old and new mainboards both had Intel chipsets so I hoped we might avoid SYSPREP,,,. Alas, it was not to be, so after tripping over the WMPNETWK.EXE problem, we finally got an OOBE + Generalize SYSPREP to run through to completion.

We placed the prepped hard-drive into the rebuilt system and.... it halted with the dreaded 'Windows could not finish customizing your machine' error, followed by 'Will continue after restart'.

So - in the pursuit of insanity we re-booted 3 times and got the same gut-wrenching result.

We then tried Safe Mode only to be informed that this process cannot be done in Safe Mode.

In total desperation, I re-booted the machine and kept the LEFT-SHIFT key depressed.

I remember this from Windows 95 days of preventing startup items from interfering with problematic boot issues,,, and would you believe it - IT ACTUALLY WORKED!

The PC is now up and running perfectly after updating drivers.

I cannot guarantee that this will work for everyone experiencing these startup errors, but what have you got to lose by trying? After all the alternative is several hours of format\reloading Windows7 + apps + everything else....
My System SpecsSystem Spec

 Sysprep failed, Windows 7 Ult. 64 bit, new CPU+MB

Thread Tools

Similar help and support threads
Thread Forum
Sysprep Win 7 64 bit process failed (have 7 setupact.log entries)
Sysprep almost make it! But I received the following log entries. something occured when drmv 2clt.dll was executed. The file is there? Any thoughts greatly appreciated!! Info SYSPRP RunRegistryDlls:Found entrypoint in registry at...
Installation & Setup
Sysprep - Windows 7 - unable to sysprep image that joins domain
Good morning all: Below is my unattend.xml. I am using the sysprep + win7 for creating virtual machines in Red Hat Enterprise Virtualization 3.0 but having difficulty getting them to auto-join the domain. My sysprep progression proceeds normally and completes. The initial boot of the image...
sysprep failed
Im trying to run sysprep to swap over to some new hardware(mb, cpu, ram) and whn i press enter in the cp (ran as administrator) I get a cursor box when I try to run sysprep that says it cant be run on a computer with an upgraded version of windows, and that it needs a "custom (clean)" version. ...
Installation & Setup
Aero theme failed after sysprep
After a sysprep I found that the Aero theme was not active, so, google is my friend and found, before running sysprep, type winsat prepop, this will create a copy of the Windows experience index in xml file and after /oobe will give you Out of the Box working Aero theme. Followed all the leads,...
Installation & Setup
Failed to reboot after sysprep (deploying windows 7 x32 image)
I have created a base image of Windows 7 x32 to deploy to same systems. After a sysprep, with drivers and programs installed. I capture the image using Clonezilla and reboot. Once reboot occurs I get "Setup is updating registry settings" followed by the error message "Windows could not...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:42.
Twitter Facebook Google+