Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Error 80070641 + unable to open some programs

07 Jun 2012   #11
Hairfallingout

Windows 7 x64
 
 

It's asking for the Image Mastering API. What's that?

Opps, I forgot my old laptop is XP. I found a download.


My System SpecsSystem Spec
.
08 Jun 2012   #12
Hairfallingout

Windows 7 x64
 
 

I've been at this for about four hours now, so any additional help you can give would be very much appreciated.

Windows & USB-DVD tool cannot be installed on my Windows 7 laptop because of the Windows Installer Service problem that I've been having. I downloaded the iso file onto another DVD from a Mac. (Actually, it was downloaded then burned to the DVD.) I then tried to run this DVD and got a message that "Windows cannot open \Sources\install.wim." (error 0x8007000D) After researching that a bit, I found something that said the DVD is probably not good, so I copied the iso folder to a backup drive connected via USB. I was going to use that file to create a bootable disc on my old laptop.

I can't use the USB-DVD tool on that computer, however, because I do not have a thumb drive that holds 4 GB. (And I read that it has to be a thumb drive -- other backup devices will not, and did not, work.) So, then I figured I needed an ISO burn program for Windows XP and found Burn to Disc. After a couple of hours, I was able to get this installed, but it came with a bunch of other garbage I really don't want, so I did a custom install without the other stuff. Unfortunately, I think that is why the program failed to start -- it could not find MSVCR100.dll. (I tried re-installing, but I still came up with the same error.)

I've done all I know how to at this point. I'm going to see if a techi I used before will create the bootable disc for me. If the Mac disc is bootable and you think I'll still have problems with a bootable disc created from Windows, please let me know.
My System SpecsSystem Spec
08 Jun 2012   #13
Hairfallingout

Windows 7 x64
 
 

Okay. I created what I think is a bootable USB. I started the installation and got to step 10 -- checking compatibility. I don't understand the first message. It says the "current version of Windows is more recent than the version you are trying to upgrade to. Windows cannot complete the upgrade."

Does this mean that I do have SP1 on my laptop but not in the iso file? I did check that before I started this whole process.

I'm going to try to download the iso file for Windows with SP1. If my interpretation is incorrect, please let me know.
My System SpecsSystem Spec
.

09 Jun 2012   #14
Ztruker

Windows 10 Pro X64
 
 

If you typed that message correctly it says the DVD is at SP1 while the computer is not. Apparently they need to be at the same Service Pack level.

As long as your data is backed up, do a Clean Install instead of a Repair Install. That doesn't care what is on the computer or DVD. The main difference is you boot the DVD rather than run it from a booted Win 7.
My System SpecsSystem Spec
10 Jun 2012   #15
Hairfallingout

Windows 7 x64
 
 

After many hours of trying to get a bootable DVD, I actually ended up making a bootable USB thumb drive. The repair took about 3.5 hours, and my data survived. I had to run setup on my tax programs, and I'm still working with QuickBooks. Firefox has a couple of issues (can't download some files like .NET Framework 4 or view pdf files), but otherwise I think the repair worked.

I still don't know what caused all of this, but a lot of it seems to do with compatibility. I would blame compatibility on all of it if IE had worked with the problems as Word and Excel did. Anyway, I'm not quite certain everything is set, so I'm going to leave this open for now.
My System SpecsSystem Spec
Reply

 Error 80070641 + unable to open some programs




Thread Tools




Similar help and support threads
Thread Forum
Extreme lagging, unable to open programs, malware issue?
I began experiencing problems with my computer yesterday. It's a custom build from 2011 that has run flawlessly until yesterday. It suddenly became extremely laggy, some programs won't open, some won't close, Windows error messages I've seen before, circular spinning loading icon when trying to do...
System Security
Error related to comctl32.dll, unable to open programs
Hi all, A few days back I started to encounter problems with my laptop. When I boot up and log into windows an error message appears saying that "This application failed to start because comctl32.dll was not found, Re-installing the application may fix this problem." The message continues to...
General Discussion
Unable to open task manager or install new programs
I recently have encountered a problem with my laptop. Everytime i boot it up and try to load a program it doesnt load and i get the error message "Failure to display security and shut down options" when pressing ctrl+alt+delete to access the options. I have also tried pressing ctrl+shift+esc to...
General Discussion
Unable to open programs after system restore
Hi there. Last night, I foolishly forgot to disable automatic updates and when I woke up to use my computer in the morning, alas, a magnitude of drivers suddenly stopped working. I quickly turned to a system restore, but that's when things somehow got worse. Now, when I boot up my machine,...
General Discussion
Virus? - unable to to do system restore or open many programs
hi, i think i have a virus on my computer, it happened a couple of days ago, i've messed around with it a little but with no joy, i had error msg's so tried to do a system restore but got this msg c:\windows\system32\rstrui.exe the extended tributes are inconsistent, i had errors with norton so...
System Security


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:22.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App