Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: "The specified service does not exist as an installed service" problem

13 Jun 2012   #1

Windows 7 Ultimate x32
"The specified service does not exist as an installed service" problem

Hi. I am having really bad problem on my WIN 7 x32. I would appreciate some help. Here's brief description of the problem:

The problem started when my mcafee anti virus removed ZEROACCESS trojans from my system.
After the scan was completed, my system rebooted and I lost control of all Administrator permissions.
I can open user files, installed software but cannot access any of the Windows system functions. Whenever I try to execute a program with a shield icon (run as administrator) I get the message "The specified service does not exist as an installed service."
This means that basically everything in Control Panel is out of access. I lost my network connection. My USB ports are not recognized by Windows so I cannot transfer my files to external disc so I can re install Windows.
I tried the system file scan in safe mode but it didn't show any errors. The message it returned was "Windows Resource protection did not find any integrity violations." I tried system restore in safe mode but there were no restore points.
I also ran anti virus scan one more time (with newly updated protection files) but there were no viruses reported. I even rebooted with mcafee disabled thinking it is the cause of the problem, but to no avail.

I also cannot access services console in normal mode (only in safe mode but many services cannot be started in safe mode).

Although I am not an expert, but it looks like something is blocking all "run as administrator" operations on my windows 7. This is a very serious problem in my opinion.

Please help!

My System SpecsSystem Spec
13 Jun 2012   #2

Windows 7 Pro with SP1 32bit

Hi dino2007,

Welcome to the Seven Forums.

Kindly fill up your System Specs to the extent possible. There are plenty of repair options in W 7 to restore your system. Either read at Tutorial search - Windows 7 Forums for all that can be done or read at Repair Install in the Tutorials.

However I always prefer to reinstall W 7 afresh if the system gets messed up like yours has. That I find the best thing to do.

With so much written about the inefficacy of McAfee on these Forums I wonder why you use it. Either install MSE of Avast! A-V instead of McAfee.

Good luck.
My System SpecsSystem Spec
20 Jul 2012   #3

Windows 7 Ultimate x64

Hi dino2007 and wanchoo
I have exactly the same problem, i run McAfee once and everything changed, whenever I try to execute a program with a shield icon (run as administrator) I get the message "The specified service does not exist as an installed service."
The problem is that I have tried to reinstall system, and repair system, they are all denied.
I am wondering if you have fixed the problem, I have no idea what i can do with my laptop.
Please help !!!!!!!
My System SpecsSystem Spec

21 Jul 2012   #4

Windows 7 Pro with SP1 32bit

Welcome to the Seven Forums sli6.

You should download Windows 7 Ultimate 64-bit installation ISOp Image from Official Windows 7 SP1 ISO from Digital River My Digital Life and burn it on a DVD to produce the Windows 7 Installation DVD.

Use this DVD for a fresh and clean installation of Windows 7 Ultimate 64-bit on your Laptop. Then you activate it with the same Product Key that you are using at present.

Then install all your third-party Programs including the Anti-Virus Program and Firewall etc. Don't use McAfee but instead use one of the Programs that I had suggested in my earlier message.

Please also be informed that what I have suggested is completely legal and you would not be infringing any law. In addition you shall be getting a bloatwareless OS.

Good luck to you.
My System SpecsSystem Spec

 "The specified service does not exist as an installed service" problem

Thread Tools

Similar help and support threads
Thread Forum
SP1 won't install - "Unknown error" / "Service does not exist"
Hello - I've repeatedly tried and failed to install Service Pack 1. I have run the update readiness tool, and have run chkdsk and sfc. I've tried installing through Windows Update, as well as downloading the standalone installer from Microsoft. The former results in an "unknown error"; the...
Windows Updates & Activation
Problem with MsConfig Service called "Power" and also my audio
I was having huge lagging and crashing problems until I found out it was the Microsoft Service called "Power" in MsConfig that was the culprit. When I disable it, it fixes my problems, but now I don't have audio anymore. Can anybody help?
Performance & Maintenance
windows defender service does not exist as an installed service
I get an error stating windows defender service does not exist as an installed service 0x80070000424 I don't have microsoft essential. It was working fine until today. When I open the program and click on tools and others it will not click at all. Also, real protected is off. Also, its not under...
System Security
.Net 4.0 error 0x00000424 "the specified service does not exist"
Hi! I'm Having trouble installing Microsoft .Net 4.0. I've tried every solution I found on the internet and still nothing. Also I may have accidentally removed it before from my programs. Is there any way I could fix this without having to lose my files(i.e. reformatting). Thanks a lot!
Windows Updates & Activation
KB976932 "Windows 7 Service Pack 1" Installed Again Today??????
On my 7 machine where the OS was installed including SP1 anyway, in comes this update today which I think is rather odd. Anyone have any explanation for the apparent anomaly? :sarc:
Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:15.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App