Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows Installer - can't install ANY msi package

19 Jan 2009   #51
a7an

Windows 7, Vista, OSX
 
 

Not just on x86. I had on x64 as well. I can verify that the fix works.

@DarkAssassin thanks for posting that.


My System SpecsSystem Spec
.
19 Jan 2009   #52
jota

Windows 7 Build 7000 x86
 
 

Well, I didn't had this problem on x64, just on x86.
My System SpecsSystem Spec
19 Jan 2009   #53
wierdo124

 
 

I had this problem on X64 after trying to install Java (failed) and that fix worked. Thanks, rep+
My System SpecsSystem Spec
.

19 Jan 2009   #54
BakaPenguin

Windows 7 x32
 
 

I had the same issue, but I tried the registry fix and it seemed to help. I can now install .MSI packages again.
My System SpecsSystem Spec
19 Jan 2009   #55
w3rdup

windows 7
 
 

Confirmed this problem also occurs with x64 which im also running.

Thanks for the fix
My System SpecsSystem Spec
19 Jan 2009   #56
darkassain

Windows 7 Ult x64(x2), HomePrem x32(x4), Server 08 (+VM), 08 R2 (VM) , SuSe 11.2 (VM), XP 32 (VM)
 
 

i had this happening since the longest when i acquired the beta....
(when it was leaked both x86 and x64...)

for some reason i never thought of this before since the first thing i did is disable the CEIP after the second reinstall (for another reason to see if it disabled the WMP CEIP (? is that how its called) and so far so good it was gone.... at that time....) ( i thought it was those ramdom time when you get errors that are fixed with a reinstall....)

so i tried a install of the beta (from MS servers) and lo and behold and there it was again....

never thought it was that though...lol
My System SpecsSystem Spec
20 Jan 2009   #57
iwantwindows7naw

Vista x64 Windows7 x64
 
 

Quote   Quote: Originally Posted by w3rdup View Post
Hey guys, I had the same problem also and had to reinstall windows 7 to solve. What happened is I was trying to install fallout 3, the installer started to try to install windows live and i think some other .net stuff and it crashed. After that I couldnt get the installer to work at all, I downloaded the games for windows-live 2.0 because I couldnt even start fallout 3 without it and the installer would stop working. Id try windows update and explorer crashed with the same error.

So I reinstalled a fresh copy of windows7 and the first thing i did was install windowslive2.0 and it installed fine after that I installed fallout3 and everything went smooth. I have a feeling something in the fallout 3 installer corupted some files or something. I know it tries to install .net maybe that was the problem.
I'm having the SAME indentical problem.
I will try to use the solution posted before resisntalling.
My System SpecsSystem Spec
20 Jan 2009   #58
iwantwindows7naw

Vista x64 Windows7 x64
 
 

Ok I jsut tested the up mentioned fix fixed everything with no need to reinstall! amazing thanks!
My System SpecsSystem Spec
20 Jan 2009   #59
Sexie

Windows 7 x64 (Build 7000)
 
 

Quote   Quote: Originally Posted by jamesvdm View Post
my error was slightly different but the solution was the same.

while installing office enterprise 2007 i received "microsoft setup bootstrapper has stopped working"

it's still just an msi behind the fancy installer graphics but just so people who google that error might find the solution.
I have the same problem !!!
My System SpecsSystem Spec
Reply

 Windows Installer - can't install ANY msi package




Thread Tools




Similar help and support threads
Thread Forum
BSOD after presumably after Install of Fonts package using GPO
Hi, I have been deploying out fonts to our Windows 7 machines to Install a new font via MSI software roll out and registry setting via GPO: HKLM\Software\Microsoft\WindowsNT\CurrentVersion\Fonts\(Font name) Since the Install we have noticed a few machines BSOD with: STOP: 0x0000008E
BSOD Help and Support
I can't install anything that is related with msi or windows installer
I have tried several times to install but when it comes to the loading bar, it remains still, still running but the bar does not move. I tried the fix using cmd with the registry but it is still not working Currently runnning on Windows 7 64-bit Home Basic Because of these I also can't...
Installation & Setup
Itunes wont download because of issue with Windows Installer Package.
I've tried to download the newest addition of Itunes and it won't let me because of an issue with Windows Installer Package. What do I do to fix this?
Software
How to install Language Package
I have an English version of windows home premium, and want to intall a dutch language package, but when I go to "control panel" and "clock, language and region" I can't find the place to install the language packages. It is supposed to be below "keyboard and other input methods" but it is empty...
Installation & Setup
Windows 7 x86 and x64 installer package folders and files- Diferrence
I am working on automation project in which we are installing the Windows OS on client machine with the help of different OS packages available on server. While installing Windows XP/2003 we are checking for the OS installer packages to get the difference between x86 and x64 architectures. ...
Installation & Setup
Windows Installer won't let me install
Trying to install a Silverlight Update, a Java update or other software, I get this window: http://img707.imageshack.us/img707/6228/capturewq.jpg http://img694.imageshack.us/img694/7798/capturelu.jpg What could be the problem ?
BSOD Help and Support


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:09.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App