Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: GPL error 193 in script using C:\windows\system32\appwiz.cpl

29 Jun 2012   #1

Windows 7 Home Premium
GPL error 193 in script using C:\windows\system32\appwiz.cpl


I'm using a script, that enables hidden password, domain and username to run a command. It works in Windows XP SP2, but not in Windows 7 Home Edition or Windows 7 Enterprise.

Using my script this command doesn't work in Windows XP SP2:


I don't know why, but using my script this command works in Windows XP SP2:

%ComSpec% /C %SystemRoot%\system32\appwiz.cpl

But no one of the above works in Windows 7, where I get an 193 error about not having the needed credentials.

If I in Wndows 7 change my command to:

%ComSpec% /K %SystemRoot%\system32\appwiz.cpl

I get the same error, but I can now use the command line box, and if I type SET, I am told, that my domain and username is my domain administrators credentials.

It's strange because some other cpl commands works when using my script, but the appwiz.cpl doesn't work. These one works on Windows 7 using my script:

%ComSpec% /C %SystemRoot%\system32\collab.cpl
%ComSpec% /C %SystemRoot%\system32\hdwwiz.cpl
%ComSpec% /C %SystemRoot%\system32\inetcpl.cpl

I also tried this one with no luck:
%ComSpec% /C %SystemRoot%\system32\control.exe %SystemRoot%\system32\appwiz.cpl

If I use the Start button and just type appwiz.cpl it works.
If I use the Start button and types cmd.exe, and in the command lne box just types appwiz.cpl it works.

I've found out that my script that enables the hidden password, domain and username needs that the seconday logon service is running. and it is. If I run my script from my own computer using e.g. pseexec.exe to get access to a remote computer, both computers must run the secondary logon service. And the secondary logon service needs the workstation service and netlogon service. The netlogon service only runs on domain computers, not on workgroup computers. And I am working on a domain computer, and all 3 services is running. But if I was working on a workgroup computer, my script wouldn't work, because the netlogon service would only start and immidiately stop again (because of the workgroup).

Please note, that my problem isn't about the script I use, it's a general problem using appwiz.cpl in Windows 7, maybe using Windows builtin runas.exe commad, or e.g. sysinternals pseexec.exe.

If anybody wants to know I'm using the latest version from, but as already told, it's the same problem using a .cmd, .bat or .vbs script

Any help or suggestions would be appreciated.


Jorgen Malmgren
Denmark - UTC+1

;o) Your brain is like a parachute. It works best when it's open

My System SpecsSystem Spec
29 Jun 2012   #2

Windows 7 Home Premium


I just examined all the *.cpl I have in C:\Windows\System32

I don't know why, but these ones works with my script on Windows 7:


These ones doesn't work with my script on Windows 7:



Jorgen Malmgren
Denmark - UTC+1

;o) Your brain is like a parachute. It works best when it's open
My System SpecsSystem Spec

 GPL error 193 in script using C:\windows\system32\appwiz.cpl

Thread Tools

Similar help and support threads
Thread Forum
Error : C:\ Windows\System32\WindowsPowerShell\v1.0\powershell.exe"
Hi to all forum mates, As soon I am online on the task bask bar i see an icon with the following information and goes out within seconds:- C:\ Windows\System32\WindowsPowerShell\v1.0\powershell.exe" Please inform if it is an error how to get rid off it as soon as possible as I do not want...
System Security
Windows Explorer shuts down automatically when running appwiz.cpl
The message "Windows Explorer has stopped working" appeared on my notebook computer screen after I restarted Windows and opened Control Panel / Programs and Features. WE then shut down and restarted. The message usually didn't appear when I subsequently opened P & F or ran appwiz.cpl. It has,...
General Discussion
explorer.exe error ( c:\windows\system32\PROPSYS.dll ) on startup
Hello, I recently started having trouble with windows 7. I tried to install new ram cards but they did not work so i put the old ones back in and once i turned the computer in the error c:\windows\system32\PROPSYS.dll appeared. I have tried to tun it in safe mode and nothing worked, i tried...
General Discussion
Unable to install Win7 to new hard drive. X:\windows\system32> error.
Greetings! I'm installing Win7 64bit Home Premium on a Dell Inspiron 1545. Right after the Starting Winoews logo screen it gets stuck at a Dos terminal. Withing the Dos terminal it says: X:\windows\system32> The window itself is titled Administrator: X:\windows\system32\cmd.exe I am...
Installation & Setup
Runtime Error! Program: C\:windows\system32\nvvsvc.exe
There are a half dozen threads from the past several years addressing the same issue - none have a solution or explain what the cause is. This is the exact text of the error: MS Visual C++ Runtime Library Runtime Error! Program: C\:windows\system32\nvvsvc.exe ...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:28.
Twitter Facebook Google+