Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: NTLDR + non system disk error

02 Jul 2012   #1

Windows 7 Professional 32 bit
NTLDR + non system disk error

Hey guys, I have an HP Elitebook laptop. I got it new about 2 years ago and have had it attached to a docking station since I bought it. Connected to the docking station is an external hard drive where I store a complete backup of my laptop (I use the program "Norton Ghost"). I should probably also mention that the HP laptop used to have Windows Vista installed on it. I installed Windows 7 over it.

The Problem
Recently when booting my computer I have noticed that I sometimes get a NTLDR or non-system disk error. Two things confuse me about this:
1) They only started within the last 4 months. I haven't changed anything.
2) They are random and don't always occur.

My attempts
First off, here is my current boot order:

Notebook Hard Drive
Notebook Upgrade Bay
USB Floppy
External SATA
USB Hard Drive
Docking station upgrade bay
... some other stuff

Playing around with the boot order yields interesting results. If I change the order, the NTLDR error will disappear an the non-system disk error will appear and vice-versa. I would tell you the exact cause-and-effect relationship but I don't remember.

Help would be greatly appreciated.


My System SpecsSystem Spec
03 Jul 2012   #2

Windows 7 Professional 32 bit

Bump to the top.
My System SpecsSystem Spec
03 Jul 2012   #3
Layback Bear

Windows 10 Pro. 64/ version 1709 Windows 7 Pro/64

To the best of my memory Windows 7 doesn't have NTLDR. I believe XP was the last operating system that use it.
My System SpecsSystem Spec

03 Jul 2012   #4

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bits 7601 Multiprocessor Free Service Pack 1

NTLDR is winxp or win2000 stuff. One of the boot devices causes this. Put some other device on top for example "Notebook Upgrade Bay". If "Notebook Upgrade Bay" has some crappy winxp stuff you see that error. Test it and put the order back later.
My System SpecsSystem Spec
03 Jul 2012   #5

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bits 7601 Multiprocessor Free Service Pack 1

Laptop is booting from "Notebook Hard Drive"???? Put is as the only possible boot device
My System SpecsSystem Spec
17 Jul 2012   #6

Windows 7 Professional 32 bit

Sure, will attempt this now.


Attempt 1
I moved the "Notebook Hard Drive" to the top of the list and disabled everything else. Unfortunately now it has the tendency to hang on the "HP Invent" startup screen... sometimes it goes through and sometimes it just seems to get stuck. It doesn't respond to any input in this stage.

I turned the "startup from upgrade bay" option on temporarily. It's still hanging on the startup screen. Sometimes I restart and it's fine, other times it gets hung up. I have yet to get any NTLDR/non system disk errors though, but I'd rather have those than the hang-ups. Any thoughts?

Also, I had disabled something called PAXE internal boot, could that have been causing the hang-up problem?
My System SpecsSystem Spec
17 Jul 2012   #7
Microsoft MVP


Most tech enthusiasts won't even run a factory preinstalled OS which is corrupted by layered bloatware and duplicate factory utilities which have better versions built into Win7. But you have on top of that an in-place Upgrade of Win7 which transferred all the crap and corruption from the bloatware AND the worst OS ever, Vista.

And the error you're getting is from an even older OS which has somehow leeched into your boot loader.

If there was ever a candidate for a Clean Reinstall - Factory OEM Windows 7 you are the one.
My System SpecsSystem Spec
24 Jul 2012   #8

Windows 7 Professional 32 bit

Thanks for the response. Yea, I kind of figured that was necessary. The previous person who did the Win7 install on my employer's computer apparently didn't wipe the old hard drive, which contained the older iteration of Windows. I mentioned a clean re-install to my employer but the problem is it'll take 40 or so hours according to her (re-installing old programs, restoring settings to what she wants, etc.).
My System SpecsSystem Spec

 NTLDR + non system disk error

Thread Tools

Similar help and support threads
Thread Forum
Windows 7 Installation error DISK BOOT FAILURE, INSERT SYSTEM DISK
I'm trying to install a PC with Windows 7 threw USB (2.0). Therefore I've used Windows USB/DVD Tool. To note, I've installed a NEW hard drive, the old one broke down due to it's age. Now I'm getting the next message: DISK BOOT FAILURE, INSERT SYSTEM DISK. I've tried setting the boot...
Installation & Setup
NTLDR is Missing error. Dead Hard Drives to blame?
Here is my situation. About 8 months ago I had fixed up my computer, got new a harddrive, upgraded the processor and videocards, yadda yadda. Only problem was, I haddn't been able to use the computer for 8 months. It was sitting at my old house, and unfortunately I never got to confirm if it...
Backup and Restore
Error while installing XP (NTLDR missing)
Hi, my problem is the following: when installing XP Pro, my PC wants to reboot (after the steps of choosing the partition and copying the first files) to finish installation. But while rebooting, it chooses Win7 automatically. I tried to repair the bootloader using EasyBCD 1.7, it shows XP in...
Installation & Setup
Different NTLDR issue: caused by non-system hard drive
I am getting an "NTLDR is missing" message on bootup, but the origin of the problem is, I think, different from the other NTLDR problems I've see on on this and other forums, because it is not related to the main (system) drive. In fact, when I remove the problem drive -- the E: drive, or in other...
BSOD Help and Support
NTLDR Error Messege
Trying to install secondary drive in my desktop. got it all hooked up started my comp went into my BIOS but when I go into the boot priority menu it wont let me switch my primary drive to load as the first drive, it is booting from the slave. If I disconnect the slave and restart everything is fine...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:54.
Twitter Facebook Google+