Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Can't delete a file - Access is denied

19 Jul 2012   #1

Windows 7 Enterprise 64bit
Can't delete a file - Access is denied


I have a compiled .dll file that I want to delete - but I can't do it in any way.
I already tried del command line and take ownership (both GUI and cmd) but nothing helped so far. I always get the Access is denied error.

Any idea will be appreciated!


My System SpecsSystem Spec
19 Jul 2012   #2

Windows 10 Pro (x64)

Probably because something has it open...
My System SpecsSystem Spec
19 Jul 2012   #3

Microsoft Community Contributor Award Recipient

Win 7 Pro x64 / Win 10 Pro

Welcome to the Seven Forums
Download and burn ubuntu Home | Ubuntu and use it as a live disc (do not install it) and then navigate to the file you want to delete and delete it.
My System SpecsSystem Spec

19 Jul 2012   #4

64-bit Windows 10 Pro

Hello Sharon, and welcome to Seven Forums.

In addition, you might see if you may be able to use the free program Unlocker to delete it.

Hope this helps,
My System SpecsSystem Spec
22 Jul 2012   #5

Windows 7 Enterprise 64bit

Thank you guys, problem solved after the computer slept well over the weekend
BTW - this Unlocker seems like a very useful piece of software. Like it.
My System SpecsSystem Spec
22 Jul 2012   #6

64-bit Windows 10 Pro

You're most welcome Sharon. I'm glad that we were able to help.
My System SpecsSystem Spec

 Can't delete a file - Access is denied

Thread Tools

Similar help and support threads
Thread Forum
Unable to Delete Folder from Desktop: Access Is Denied?
I had a folder on my Desktop that just won't delete. It was apparently being shared with my Xbox360. I right-clicked it, pressed Delete, and it said it was being shared and if I was sure I wanted to do it anyways. So, of course, I said Yes. It deleted everything within the folder, yet the folder...
Can't delete folder - access denied
Hello! I have a small issue concerning deleting folder. Here's situation: I had a folder that I wanted to delete. I used shift+del combo for instant deletion, but than issue occured. Basicly, folder stayed, yet files deleted themselves. And when I try to delete the folder, it says I need...
General Discussion
Can't delete folder - access denied (despite attempts to fix)
I'm trying to delete an obsolete directory. When I try to do so, I get a message "Folder access denied: You require permission from Administrators to make changes to this folder." Based on forum advice for a similar problem that worked in the past, I did the following: Right-click the...
System Security
I cannot delete a particular file Access Denied
I am tryiong to save, delete or overwrite the file "Clear Print Spooler.bat" in C;\windows\system32 and in each case get "ACCESS Denied" error. I have tried the above in the command window with admin. priviledge. Same error. I had added a line that contained the word "Runas". Now I try to remove...
Security Basics
Trying to delete a primary partition in diskmanagement - Access Denied
I have confirmed that I have admin privileges. The HDD in question is a small 80gb HDD with a 75 gb primary partition. When trying to delete the partition with diskmanagement or diskpart, it just says Access Denied. Currently I can not provide a screenshot, not for the next couples of hours. ...
General Discussion
Trying to Delete Program Files, Access Denied
This entire morning thus far I've been attempting to delete files from Norton Internet Security, which has been inactive for a long time (we are not going to renew our account) and has been bugging us constantly. I assumed it would be an easy task, and I couldn't have been farther from the truth. ...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:12.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App