Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Win7 and bios can't find drives, even while PC running

06 Aug 2012   #1

Win 7-64 SP-1
Win7 and bios can't find drives, even while PC running

I'm not sure where to put this one as it involves several things.

So my system (updated specs in my profile) has been running perfectly since first built in January.

Saturday, a Steam update came out. Ever since then, I have had major problems. It starts with the entire system totally freezing and occasionally BSOD.

If I reset (hardware reset button), then bios can't find any of my hard drives (two different SATA channels), but it can usually find the DVD (also SATA). Sometimes it will hang on the drive part of boot up. (ACHI mode is enabled.)

If I do a cold boot (hardware off, wait 15 seconds, then on), then it boots and runs fine... for about an hour, maybe two... then the above happens again. It doesn't matter what I'm doing, games, surfing, or not even at my computer.

I did notice that the drives were running much slower than normal, so I updated the Intel Response Time thing (whatever you call it). That greatly improved drive response and boot time. But it did not cure the crashes.

Other than verifying all the case wires were firmly connected, I haven't had time to do anything else.

I can't imagine how a software update (Steam) could frack up my bios or my mb, but that is the only thing that has changed between running perfectly to totally unstable.

Once i get home, I'm planning to uninstall steam and reinstall. I'm not confident that will help if the update has caused another problem.

I don't know if it's Win7, Steam, hardware, or a bios issue. I have tech support calls out to Gigabyte and Steam, but I'm not confident of a quick response.

Any suggestions?

Thanks in advance.

My System SpecsSystem Spec
06 Aug 2012   #2
Carl Lawrence

Dual-boot: Windows 7 HP 32-bit SP1 & Windows XP Pro 32-bit SP2.

Have you tried system restore?
My System SpecsSystem Spec
06 Aug 2012   #3

Windows 7 Ultimate x64 SP1

The BSoDs are going to be your key, so look into the codes those are showing. If you know the rough date and time, you can get them from your Event Viewer.
My System SpecsSystem Spec

06 Aug 2012   #4


Try turning off or uninstalling the Intel bloatware - unless you're overclocking you only need the driver itself for best performance in Win7.

Test your HD's, establish a Clean Boot and work through the other steps in Troubleshooting Steps for Windows 7
My System SpecsSystem Spec
06 Aug 2012   #5

Win 7-64 SP-1

OK. So far, I have

1) reset the system to a restore point from last week. That had no effect as the system froze a bit later, while looking to download the latest Intel drivers.

2) That removed Steam as well.

3) Verified that all hard disk and ACHI drivers were the most recent. That didn't help either.

4) Reset the bios.

5) moved the SATA cords to another plug in. I only have one space SATA3 plug, but two spare SATA2 plugs.

So far, the system is running OK. That doesn't mean anything as it usually takes an hour to fail. I ran the Prime95 Torture test for about 20 minutes and it seemed to hold up OK. But that's not really a disk I/O test.

So, I'm going to hold what I have and see if it fails on me.

I'm not sure the event log will be all that useful. It just contains the aftermath of the events. I'm not sure where the memory dumps go, but I've seen that happen 2-3 times yesterday. I don't see anything that seems like a precursor to the fail, just x service stopped unexpectedly.

I'll let you know what happens.
My System SpecsSystem Spec
06 Aug 2012   #6

Windows 7 Enterprise X64/Windows 10 Enterprise X64/Windows 10 Pro X64/Linux Mint

Windows dumps are located in C:/windows/minidump You'll have to provide administrator permission, but copy the dumps and paste them to somewhere easy to find like the desktop. Right click the and select send to then compressed(Zip) folder and include them in your next post. Steam by default wants to start with windows. Hold the windows key ( the one with the flag on it) Hold it down and press R. In the box type msconfig, go to the start up tab and uncheck Steam and any other thing you don't need to start at startup. You can still use them, but they won't automatically start with windows. You really only need your A/V to start.
My System SpecsSystem Spec
07 Aug 2012   #7

Win 7-64 SP-1

I think I have discovered the problem. Check my thinking on this.

So, when I reset with the SSD in SATA_0, no drives appear during the AHCI part of the boot process.

When I move the SSD to SATA_1 and leave SATA_0 empty, then during a reset, the SATA_0 drive spot appears (correctly as no drive) and then nothing else appears during the boot process.

The other thing that I noticed is that during the last couple of fails, the HDD light (connected to the SSD drive) has been lit and remained lit as if there is a massive amount of data flowing to and from it... but nothing is actually happening.

With that discovery, I'm confident that the SSD is failing or has some other issue that is causing the problem. Unfortunately, 2 hours of effort last night and I still can't get the SSD firmware updated. It has a 3year warranty and is only 6 months old.
My System SpecsSystem Spec
07 Aug 2012   #8

Windows 7 Enterprise X64/Windows 10 Enterprise X64/Windows 10 Pro X64/Linux Mint

Try connecting another drive to port 0 and the SSD to another port and see if the same situation occurs. Also, when you say that the SSD can't be seen during the boot screen if connected to port 0, does your computer boot into windows? If you determine it is the SSD, Crucial tech support will RMA it with no problem, however they will have you try some things first to make sure it is the SSD. But, they are pretty easy to get along with.
My System SpecsSystem Spec
08 Aug 2012   #9

Win 7-64 SP-1

Got it sorted. Thanks everyone.

Turns out the Crucial M4 SSD had a known flaw where it pretty much freaked out after 5000 hours of use. A power cycle and a firmware update and it's back to stable (so far).

Thanks for your help everyone.
My System SpecsSystem Spec

 Win7 and bios can't find drives, even while PC running

Thread Tools

Similar help and support threads
Thread Forum
Please help find bios update
I can not find it anywhere. My motherboard is a Lancaster8. I found software that would search and download what bios update you needed but the reason I need the bios update is because my new nic card gives me a code 35 Your computer's system firmware does not include enough information to...
Windows 7 and Bios does not detect my drives
Hello, Lately, my computer has been crashing a lot and a few BSODs have occurred. So I decided to open my computer up and give it a clean. I also took the RAM out and cleaned it and slotted it back to its original position. However, I now have a much larger problem. Whenever, I turn on the...
General Discussion
No drives detected in bios
Hi guys, My corsair ssd and Samsung hard drive appear in the safely remove hardware and media icon in windows. I was told I could try disabling the hot plug option on my bios. When I looked the sata ports 1 and 2 say nothing present but both drives work and appear in the boot priority part of the...
Hardware & Devices
Bios not detecting any Sata drives
My pc had suddenly decided to not recognising any of my Sata drives. Win 7 32 bit, 4 gig ram, asus psn d motherboard,ati sapphire 1g pci card, 1 250g western digital Sata drive 1 x 1tb seagate hdd. Sata DVD drive Yesterday my pc froze up while surfing the web, so reset it and that where the...
Hardware & Devices
Moved OS to ssd, now Win7 running from both drives!
Win 7 Home Premium 64bit came pre-installed on my Dad's HP. He bought an OCZ Vertex 4 SATA III 128 Gb ssd to run the OS on. HP does not provide a Windows install disk, and can't download it from Microsoft without buying another copy of Win 7. We burned the recovery disks (4 DVD's) from the...
Installation & Setup
Cannot find update for Bios
I am trying to update BIOS on my system in order to OC my CPU. I already tried on the MSi official website but its very confusing and i could not find the ms-7312 model. Mother Board version: MSI MS-7312 Bios: Phoenix Technologies LTD Bios Version : 6.00 PG Date:01/25/2007 If other system...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:33.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App