Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Transfer to USB Drive stalls at 5 Seconds left

21 Aug 2012   #1

Win 7 Ultimate 64 Bit
Transfer to USB Drive stalls at 5 Seconds left

I have a 16 gb flash drive (sandisk) that I have been using for about 6 months now. It has worked completely fine up until about a week ago. Now whenever I transfer any files above about 500 mb they will transfer at the normal speed (between 5-15 mb/s) until it gets down to 1 or 2 mb's left and it will just stop at 5 seconds left.. for at least 10-20 minutes. The files do eventually transfer fully, it's just a huge pain for them to take so LONG!

on a side note I started playing AOE3 again about a month ago and I would have problems about once or twice a day where the game would stop responding for seemingly no reason (right in the middle of a campaign level or skirmish) so I decided to install windows xp in a dual boot just to play some older games. (all the games work fine since I've been running them on xp, but this problem with the flash drive transfer didn't start to occur until AFTER I set up the dual boot and that's the only thing that I have changed since last week.)

Please help (:

My System SpecsSystem Spec
18 Jan 2014   #2

Windows 7 Ultimate x64 SP1

any luck or solution on the transfer problem? I am having it too
My System SpecsSystem Spec
18 Jan 2014   #3

Windows 7 Professional SP1 - x64 [Non-UEFI Boot]

My System SpecsSystem Spec


 Transfer to USB Drive stalls at 5 Seconds left

Thread Tools

Similar help and support threads
Thread Forum
USB transfer hangs at 5 seconds to completion
Recently my USB drive that i have been using all this while hangs at 5 seconds to completion. I have to wait more than a minute for it to finish. I also tried cancelling the copying of the file and this will also take a minute or two to cancel. However after cancellation, the file surprisingly is...
Hardware & Devices
USB Locks up with 5 Seconds Left.
Hello, Please before you answer read the following. I have read way too many posts on this site and others where people answered with generic questions. I have exhausted all remedies I can find on the net, the next one is to pave over with Linux. My issue is that ALL USB sticks I have...
Hardware & Devices
External hard drive corrupted, CHKDSK stalls at 76% complete
I am trying to fix a new Toshiba Canvio 3.0 1.5TB drive that has errors. Each time I plug it in, I'm directed to run CHKDSK, but CHKDSK fails to complete with the /f parameter. The process stalls at 76%. If I run CHKDSK without the /f parameter, I get the following result: Again, if I run...
Hardware & Devices
Hard drive activity shows every 60 seconds
About a week ago, when I was online, I noticed the opaque desktop background that is visible at the top of my screen above the browser, would blink. Its doing it now as I type this post. After a while, I realized that it seemed like the computer hard drive was activating every 60 seconds. Exactly...
General Discussion
BSOD - Drive irq not or less equal - seconds after logon
Gentlemans, I wake up nicely then i turn on my computer and get two crashes refering to the same. just a few seconds after the logon Bugcheck analasys doesnt seems quiet clear to me, im sure You can help me on that ps_escuses for my bad english ...
BSOD Help and Support
Copying files to USB Portable Hard Drive stalls system
Hi guys, Today a friend of mine came to get some files from my computer and we ran into a bit of a problem. We were copying some huge files using windows explorer, some were around 10GB in size. Total size of about 90GB. Check system specs please. We were copying from the RAID spindle drives...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:31.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App