Bootmgr missing? Acer Revo problem.

  1. Posts : 3
    Genuine Windows® 7 Home Premium 64bit

    Bootmgr missing? Acer Revo problem.

    Hello there! I seem to have a problem with my Acer Revo R3610 which I cant seem to solve myself. Ive been trying for a week now and have decided to seek outside help, so thanks for taking the time to listen to (or read) about my issue.

    Right. I turned on my Revo and left the house to do a bit of shopping. Upon returning I discovered that the Revo was on Startup Repair. So I followed the instructions to repair the issue that was restricting the Revo from fully booting. However, I soon discovered that I was stuck within the Startup Repair infinite loop where upon completion the Revo would reboot and encouter the same issue. I decided that I would just reinstall windows as I didnt have anything of value saved to the hard drive.

    The Revo does not have an optical drive, so using a bootable usb was my only option. I stuck the usb in and booted the pc. Pressed F12 for Boot options, and selected the usb which had my Windows 7 64bit. When the setup was ready and I could select the hard drive and partitons to edit and use, I deleted the partions and then reformatted the drive (thinking I was clever, hopefully removing any malware or viruses ). When this completed I proceeded to install Windows. However the installion failed. It had copied the files across to the hard drive but would not expand the windows files. Sometimes I would get blue screen, other times I received and error and explanation (I will try and again to get this information) and sometimes it would be stuck in limbo not doing anything. So, after a couple of attempts, I decided perhaps my copy of windows has been corrupted. I have a copy of Ubuntu 10.04 LTS on a bootable usb which I then decided to use. This didnt work either, it just freezes when I try to install, however I can boot from the usb and use Ubuntu, I just cant install.

    After getting a bit frustrated I decided to try windows again. This time I forgot to hit F12 and select usb. The computer began to boot from the hard drive, but suddenly a message appeared, "Bootmgr is missing Press Ctrl+Alt+delete to reboot".

    And thus, I am stuck within an eternal loop of misery.

    I hope someone can help, any advice would be invaluable and sorry for the long story.

    PS I was thinking of upgrading the Hard drive to a larger one, If i did this, could I just fit the hard drive, boot the Revo with my usb and reinstall windows? Or is it a little bit more complicated than that?


      My Computer

  2. Posts : 240
    Win 8 RP, Win 7, XP

    Maybe a disk clean command is needed before starting installation of Windows 7.
    See how to - Disk - Clean and Clean All with Diskpart Command
      My Computer

  3.    #3

    Download the latest official ISO for your licensed version and write to stick with the tool in Steps 1 and 2 of Clean Reinstall - Factory OEM Windows 7 then follow those steps to get a perfect reinstall.

    If that fails be sure to wipe the HD with Diskpart Clean Command as suggested.

    If those both fail, there will be other steps based on what you report back.
      My Computer

  4. Posts : 3
    Genuine Windows® 7 Home Premium 64bit
    Thread Starter

    Thanks for the prompt reply guys!

    Right, I fear the diskpart wont work as I cant get to a command prompt. However I will download the windows installer and try Gregrockers method. Hopefully this will resolve the issue.

    Thanks again for the help! I will report back soon.
      My Computer

  5.    #5

    You have to run Diskpart Clean Command from the installer or System Repair Disk command line anyway. But try the booted install with partition delete first.
      My Computer

  6. Posts : 3
    Genuine Windows® 7 Home Premium 64bit
    Thread Starter

    Ah silly me, I didnt fully read the Diskpart tutorial.

    Right, I downloaded the iso and created a bootable usb again. Booted up the computer to attempt a clean install of windows, unfortunately the same error occured. I then followed the instructions to clean the hard drive. Once complete I tried again to reinstall windows. Same problem occured.

    I'm tried to add images of the error but this computer doesnt register any image saved on my phone, hence why I've typed them out.

    This error occurs during installion whislt files are expanding-
    Setup.exe - Corrupt File

    The file of directory
    C:\Windows\assembly/NativeImages_v2.0.50727_32\Microsoft.Windows.D~\aa3fa7748881ce096939deba06e3cfc3 is corrupt and unreadable. Please run the CHkdisk utility.


    At the same moment I also get anot error-
    Install Windows

    Windows cannot install the required files. The file may be corrupt or missing. Make sure all the files required for installation are available, and restart the installation. Error code 0x80070570


    After these errors I close the installation and get the blue screen of death. So I restart the Revo and opt to repair my computer instead but the repair process doesnt pick up any restore points or iso images to use. However, I can select to load drivers, this lets me browse around the boot usb and or stuff. I notice here that it registered my hard drive as having 232GB free space which I think is correct, but after clicking properties the hard drive details changed. It now has 0bytes freespace and used space. Because of this I believe my hard drive may be banjaxed.

    Thanks again for having a read and helping, sorry about the messy reply...
      My Computer

  7.    #7

    Are you sure you only have the target HD plugged in and that Diskpart Clean command completed? The first error means it is attempting to read something on the C partitions. Try Cleaning again.

    The second error is normally the installer. Are you sure it completed download and wrote to stick correctly?

    Test the HD using maker's HD Diagnostic extended CD scan.

    If you don't have a working CD drive then download and run Ultimate Boot CD (UBCD) from a USB flash drive | USB Pen Drive Linux to use your maker's bootable diagnostic app. If it isn't present use Seagate Seatools.

    Follow this with Disk Check on a full disk partition formatted and marked Active using Step 2.2 here: SSD - HDD Optimize for Windows Reinstallation. Then try install again.

    I would also test my RAM - Test with Memtest86+ for 5-6 passes following the steps in tutorial closely.

    Unplug all other HD's and peripherals. Reset BIOS to defaults, set SATA controller to AHCI to try install, then IDE if it fails.
      My Computer


  Related Discussions
Our Sites
Site Links
About Us
Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 08:10.
Find Us