Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Mbr corrupt and i/o device not found.

27 Sep 2012   #1

Windows 7 home premium 64bit
Mbr corrupt and i/o device not found.

Guys iam having a problem with my assus n55sf. I try to clean my asus every weekend (clean, scan disk & defrg) and shut down. When i try to on it show me windows 7 repair (recom). I dont know whats wrong. I start repair my asus and the result (mbr corrupt) i try fix mbr it show me (i/o device not found) i go to bios and check my hard disk its there..
Please guys help me...

My System SpecsSystem Spec
27 Sep 2012   #2

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bits 7601 Multiprocessor Free Service Pack 1

boot into windows recovery environment "repair your computer" and select command prompt.

list vol
sel disk 0
list part
All partitions are still there?
you saw volumes and drive letters. Ignore the dvd drive letters. Assume you have C,D,E (and F dvd)

chkdsk/f c:
chkdsk/f d:
chkdsk/f e:
no errors? if errors... run it again. All errors gone and repaired?

Both command succesfully?
My System SpecsSystem Spec
27 Sep 2012   #3


Why are you runnning Scandisk as part of regular maintenance? That's ridiculous. Win7 doesn't need that much cleaning and defragging anyway. Just monthly at the most run CCleaner and Puran Defragger's boot-time defrag. Periodically add Disk Check option to the defrag.

Boot the Win7 installer System Recovery Options or System Repair Disk to run Startup Repair - Run 3 Separate Times.

If this fails work through these steps for Troubleshooting Windows 7 Failure to Boot
My System SpecsSystem Spec


 Mbr corrupt and i/o device not found.

Thread Tools

Similar help and support threads
Thread Forum
WD SES Device USB Device driver not found from old internal hard drive
I have an old Western Digital drive that came with Dell Inspiron One 2305 and replaced it after 5 years. There are some files I need from it now and I'm trying to connect via usb to sata. The WD volume does not show up. I got to device manager and found it listed in in unknown devices and it needs...
Hardware & Devices
No bootable device found-please enter a new boot device
Hi guys, im new here and i wish you can help me cuz im really stucked. I have a toshiba satellite L350, and it cant boot. Firstly there was just a blue screen and then it switched to a blaack screen and says no bootable device, please enter e now boot device. I knew my HDD was gone beause he...
Hardware & Devices
WRP found corrupt files but was unable to fix some of them
Recently, some of the installs I run give me "The source file is corrupted" error, so i decided to run the sfc /scannow program. It says that "Windows resource protection found corrupt files but was unable to fix some of them". I've attached the log. Thanks in advance.
Performance & Maintenance
Bluetooth Peripheral Device Driver Device Unplugged/Not Found
Hello! So I did some searching for a way to fix this problem but I believe that my problem is different than the Bluetooth Peripheral Device problem that most people have. I am NOT trying to connect a cell phone to my laptop. I am not trying to connect anything I don't think (unless my...
sfc found corrupt files - CBS log file
Hi. I was runing the system maintenance program troubleshooting and it tells me that I have a "Disk Volume Error" Issue and tried to do the error checking in the properties and tool tabs of the drive for when I restarted the computer because is my main drive but the check never happens so later...
Performance & Maintenance

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:08.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App