Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Storage disk stopping Win7's startup. Only Win7 O_o

30 Sep 2012   #1

Windows 7 Ultimate x64
Storage disk stopping Win7's startup. Only Win7, not Linux, argh !


I have a storage disk that is recognized by Linux live CDs (like Mint), that works once encased in an external USB rack, but that makes the startup of Win7 either freeze or hang forever at the "animated windows logo" step.
I'm coming seeking for help

First, how the problems appeared.

- I went through a recent ordeal, a PSU stopping working with a strong smell of burnt material. Replaced by a widely locally trusted PC repairman at a local PC parts shop with a brand PSU.
- The next day, I start up my computer for the first time, Windows takes unnaturally long to startup (stuck at the animated windows logo stage), I open my PC case just in case, and... I swear I am not kidding, with a familiar smell of burnt plastic, a point on my video card (4 years cheap old nvidia GF6) suddenly started twinkling, sparkling, minuscule flames appeared - and then I unplugged the power button and cursed heavens.
- Back to the PC shop, the owner was flabbergasted and embarrassed (he had air-cleaned my PC tower before and after installing the new PSU, and let my PC run during 30 minutes in his shop in my presence after the PSU installation, with no problems), but had no explanation to offer . I had to buy a new video card.
And this is here that we noticed a problem, the present problem.

Second, the actual problem description.

I have 4 hard disks (I'm a backup freak), 1 SSD SATA and three 3.5' SATAs.
The latest is a Western Digital Green 2 TB, 6 months old.
And Windows7 won't leave the "animated windows logo" state if that disk is plugged in.
Win7 will load perfectly and work flawlessly if that disk isn't plugged.
Even though during the bios startup phase, the disk is perfectly found and recognized.
And yet, that disk is readable and writable when I run a Linux Live CD like Linux Mint, or insert that hard disk into an USB external hard disk rack.

The only change I performed on my OS after the burnt parts affair was to uninstall the previous nvidia display drivers, and reinstall a freshly downloaded copy.

In the PC shop, we tried experiments with my hard disk inside my PC tower :
- Slightly tilting the hard disk by 20-30 degrees once allowed the disk to be usable with windows, but it only worked once (in 7-8 attempts). So : maybe the reading head is partly damaged.
- brand new SATA cable between the faulty disk and my motherboard.
- switching SATA cables and power cables between the faulty disk and the other working disks
- swapping where the 4 SATA cables were plugged on the motherboard
- unplugging various combos of disks, to see if there was a mutual incompatibility
-----> Eventually, nothing changed the problem, everything worked in all combos, save for when that hard disk was plugged

In Linux Mint LiveCD, I copied that disk's contents to another disk for safety (it worked at normal speed) and then, using GpartEd, I formatted one of the hard disk's 3 NTFS partitions, resizing another one, and tried rebooting windows... same problem.

I tested, windows won't even start up in failsafe mode (default options) or failsafe mode (command prompt), there's the same freeze halfway. I vaguely remember the last sys driver loaded being something like *pnp.sys, but maybe the actual driver causing the hangup wasn't printed to screen when the freeze occured.

And this is my present case.
I'm really lost for words and I don't know where to search further.

That is a backup disk so I may format whatever is required. But I don't know if that would help.
I don't even know if Western Digital will accept me sending back the HDD for an exchange since I witness myself that it still works with Linux and externally O_o

Please, would you have a suggestion, or an idea, for this problem ? Thank you VERY MUCH if you can help

My System SpecsSystem Spec
30 Sep 2012   #2


Please post back a screenshot of your maximized Disk Management drive map and listings:

1. Type Disk Management in Start Search box.
2. Open Disk Mgmt. window and maximize it.
3. Type Snipping Tool in Start Search box.
4. Open Snipping Tool, choose Rectangular Snip, draw a box around full map and all listings.
5, Save Snip, attach using paper clip in Reply Box.

Tell us what is on each partition.

What frequently causes the problem you describe is bad boot code interfering from the problem HD. To try to resolve this move the data off of it using a rescue disk if necessary, then test the HD with all others unplugged by booting into Data Lifeguard Diagnostic for DOS (CD) to run an Extended scan, followed by Quick wiping the HD of possibly problematic boot code. Copy & Paste - in Windows Recovery Console
Paragon rescue disk to recover data

Then boot into Win7 with HD connected to repartition in Disk Mgmt. If it still causes problems check the cabling.
My System SpecsSystem Spec
30 Sep 2012   #3

Windows 7 Ultimate x64

It's good that I had a screenshot ready, made one month ago, then, it will display what it was with my problematic disk, then, here's your screenshot Greg, thanks for your answer

Basically, only the 60GB SSD disk contains system files, the rest is storage stuff, videos, isos, image collections, and more backups.

The "c:\program files (x86)\games\" folders were installed in the now missing disk, with a "mklink/j" command, apart from that, there's nothing fancy. I tested, removing this symbolic link and creating a new one to point to an existing partition, it didn't change anything.


Edit : was your post edited, Greg, I didn't see your recommendations first !

That's stuff I'll test after a night's sleep, it's 1 AM here. Thanks, I'll report after testing

Attached Thumbnails
Storage disk stopping Win7's startup. Only Win7 O_o-good-delete.png  
My System SpecsSystem Spec

30 Sep 2012   #4

Windows 7 Ultimate x64

Oh - sorry if it's in French, I can't help it.

And the following picture is what we have right now. I didn't grab the USB DVD reader/writer in the screenshot.

Attached Thumbnails
Storage disk stopping Win7's startup. Only Win7 O_o-what-now.png  
My System SpecsSystem Spec
01 Oct 2012   #5

Windows 7 Ultimate x64

All right, I unplugged all HDDs save the problem one and made all the possible tests, with puzzling results.

- The bootable DOS version didn't recognize my WD20EARS, Western Digital apparently forgot to update it for a frigging long time :
Western Digital drives were found, however noone of them are supported in this version of this program. Please contact WD Support for help in getting an earlier version

- So I took the non-bootable DOS version of the WD Data Lifeguard Diagnostics tool, since that other version was said to be up to date. I copied it to an USB key, booted with UBCD (Ultimate Boot CD) in Freedos, went to c:\ (the USB key) and manually ran DLGDiag~.exe (or something like that, DLGDiagv519.exe in MS DOS). Result ?
Western Digital drives were found, however noone of them are supported in this version of this program. Please contact WD Support for help in getting an earlier version
Hey, seriously, Western Digital !!

- I tried again a pair of times, and the one that made me give up was this message, instead of the previous error messages, always after launching the DLGDiagv519.exe program in FreeDos.
Please contact technical support and report the following error.
DLGDIAG 5.19 - Data Lifeguards Diagnostics

(I did my googling, there was no cable change since the previous attempt, however I managed to eventually reproduce the situation with another SATA cable, this cable working flawlessly with another disk)

- "Dying on me, are you ?" I rebooted again and again, and indeed, there were two times during which the bios hardware recognition process froze when the culprit disk was mentioned.

- Just in case, I once again plugged all the other disks, giving another SATA power and data cable to the disk (exchagned with another working disk), and ran Win7. Same problem as initially, no more progress while there's the animated windows logo.

- And the finishing touch, I booted with Linux Mint Live CD. First attempt, kernel panic. Second attempt, successful boot with all 3 partitions of the problem disk showing and working.


This is infuriating.

In your opinion, please, please

- Are there still other possible steps to take, possible ways to solve the problem ?

- May I safely send the disk to the WD customer support for an exchange, or might they object that the disk is still working for them (as it is for me with Linux O_o )

As before, I'm open to all remarks and suggestions, thank you very much
My System SpecsSystem Spec
01 Oct 2012   #6


If the HD is under warranty, contact WD SUpport to see what they require to RMA.

There are other HD Diagnostics on UBCD or Hiren's including Seatools which works on most models. I'd also want a Disk Check from Win7 installer or Repair CD command line or UBCD. Partition Wizard CD (also on Hiren's) has a Surface scan.

Since you've rescued the data you can also wipe the HD with Diskpart Clean Command and then try a full format to see if it can resurrect the drive by quarantine of bad sectors. But I wouldn't rely on it again unless it passed HD Diagnostics and Disk Check.
My System SpecsSystem Spec
04 Oct 2012   #7

Windows 7 Ultimate x64

Thanks Greg,

Surprisingly, my disk was as good as dead for most of the third party disks (who either couldn't open, or decided they couldn't help), and then there was Linux Mint LiveCD still perfectly reading my data when the disk would manage to make it through the BIOS loading all the existing elements (50% of the time).

Go figure, haha ^^

I eventually gathered enough info, phoned Western Digital, and they're sending me a replacement disk.

I can't say I'm ecstatic about having a disk die when it's only a few months old, but at least the customer service is top notch, that's better than nothing.

Let's call it a solved case, once again, I'm grateful for the help, Greg
My System SpecsSystem Spec

 Storage disk stopping Win7's startup. Only Win7 O_o

Thread Tools

Similar help and support threads
Thread Forum
Storage HDD Starting/Stopping At System Idle
Hello- This machine has an SSD for the OS and an HDD for storage, Downloads, My Documents, My Pictures, My Videos, etc. Page File is also on Storage HDD. I have the Power Plan set up for High Performance, the SSD set to Sleep in an hour (NO hibernation!), and the Display shuts down in...
Hardware & Devices
clone multiboot two disc win7 xp install to win7 ssd plus disk XPx64
I have a multiboot win7 /xpx64 TWO DISK system, showing win7 as the C; drive and XPx64 as D: when examining via My Computer. Cloned the C: drive (win7) using Samsung tool to same size Samsung evo SSD. When put in computer the dual boot option gone. The SSD clone of win7 runs ok, but with that in...
Installation & Setup
Swapping storage hdd to win7 from xp
Can anyone help. I have a 500gb hdd in my current but nearly dead xp machine which has only ever been used for the storage of photographs. I have ordered my new win 7 machine and would like to do a plain swap from the old machine to the new. However, although the old drive has only ever had...
Hardware & Devices
Wireless network storage and Win7
Hi, I have been using a d-link wireless access point for some time now, with a worldbook 1tb networked HD plugged into it, which i used to access/share files wirelessly. Since upgrading to windows 7 i can no longer access my hard disk files, just not showing in network places. this is the same...
Network & Sharing
Win7 can't see shared storage partition
Hi there I used to have three partitions: Win7, Fedora 12 and a NTFS-Storage-Partition Now I had to reinstall Win7, it doesn't see any files on the storage partition; Windows shows the whole rest of the disk including the linux partition as one drive with 7gb of 80gb free, I can also open it...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:08.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App