Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Stalls and terrible file copy speeds

22 Sep 2009   #1

OSX10.6, W7, Ubuntu
Stalls and terrible file copy speeds

Hey guys,

So after a year on one Vista installation, I decided it was time for me to finally reinstall and upgrade to W7 so that I can actually see what is happening in my games again (damn that Vista installation got bogged down).

I prepped for the reinstallation - backed up all my files onto a second hard drive I have internally, which Vista did at reasonable speeds; not fantastic, but I recall they were around 60MBps between a 10k rpm WD Raptor and a 7200rpm 320GB Caviar.

Windows 7 seemed to install effortlessly - I left the room to go to dinner and came back and it seemed to have completed without error and presented a username creation dialog I do believe.

However, after I installed some drivers, which seemed to go very well, I started to copy files back from my backup drive to the main drive. I tried to copy my 40GB "steamapps" folder from the program Steam. While doing this, my computer would complete the first 2GB or so at about 80MBps, and then stall the file transfer. It would make opening any window almost impossible - firefox wouldn't load, and if it did the second you clicked a link it would freeze again. Control Panel would take about 20 seconds to display its contents. Just an absolute wreck. Almost as if my primary hard drive, the raptor, had stopped responding entirely.

Now, I doubt this is the case, as I can stop the file transfers and it starts to work again, but you can see how frustrating this is for me. I even got 20GB of the files to transfer by manually selecting them (20GB is spread over about 60 files, while the remaining 20 is in about 10,000 files). But trying to copy over a 1.5GB folder has taken more than 15 minutes and it isn't even half way there!

I'm curious if anyone here has any ideas as to what could be causing this problem. I am running a fresh install of Windows 7 from MSDN. I was told it was RTM. Drivers I have installed are the latest 64 bit W7 nForce drivers, as well as the latest 64bit W7 geForce drivers from nVidia. I have also installed nVidia's "System Tools" package.

Programs installed are Firefox, Steam, Logitech g-series Key Profiler, Logitech Setpoint, Foxit Reader, Fraps, AVG Free, and HD Tune Pro (was trying to test write speeds on the HD as well as smart status. HD Tune Pro is reporting that the raptor is reading and writing at about 90MBps (I don't know what is standard though!).

Would love some help. I am more than willing to completely reinstall (and will probably do just that if I do not get any responses).

My System SpecsSystem Spec
22 Sep 2009   #2


Great problem description! I like that. Have rep :)

Assuming for a moment the problem is caused by software, it'll probably come down to something like the anti-virus filter drivers interferring with the file copy process - a not uncommon occurrence.

Hence, I have two quick suggestions:

1) Test what happens when you attempt the same drive-to-drive transfers in safe mode, preferably using the command prompt to rule out Explorer issues.

2) Temporarily uninstall the AV and any other non-default "security" utilities you may have added, long enough to ascertain whether their complete absence from the system makes a difference to the file copy issue.
My System SpecsSystem Spec
23 Sep 2009   #3

OSX10.6, W7, Ubuntu

Hey! Thanks for the reply. I actually figured out what it was after google-ing to see if anybody was having problems with Windows 7 and nForce drivers. I read a post somewhere that said Windows 7 already has the nForce IDE/Sata drivers preinstalled. However I did not find post abut anyone having problems like I did.

However, after reading this, I reformatted yet again, and reinstalled my nForce drivers but opted out of installing the storage driver included in the latest driver pack (and it was even a W7 driver!). Now, everything is working wonderfully.

I submitted a driver feedback to nVidia regarding this, but I'm guessing this doesn't happen to everyone or it probably would have had more google search results.
My System SpecsSystem Spec

06 Nov 2009   #4


Hey jomanscool2...thanks for your post. I'm having the exact problem and it's driving me nuts. Thanks again.
My System SpecsSystem Spec

 Stalls and terrible file copy speeds

Thread Tools

Similar help and support threads
Thread Forum
Batch File .bat to copy file from File Sharing & FTP Hosting
Hi all, Any idea how to write Batch File .bat to copy file from File Sharing & FTP Hosting to local directory. Current the File Sharing & FTP Hosting is SMARTFILE. I don't want to use WINSCP as the connector. Thanks
General Discussion
Slow Copy Speeds 10 MB/s w/Teracopy and system Freezes!
First off, Happy New Year all. And thanks in advance to contributors. I have looked at every thread on this issue and there doesn't seem to be definitive solution. I've googled this on and off over the last two years and I don't have a solution. I'd like to know if this is what is supposed...
Performance & Maintenance
how do I copy a BIG single file (using richcopy?) big file copy
I'm trying to copy a VHD (22g, dynamic I think...) I tried richcopy. It says copy started, but then stops.... I saw someone mention xcopy /j, to achieve the unbuffered I/O perf. you get with richcopy... it's running, but no indication as to how long it takes (EDIT: just finished, > 10...
General Discussion
64 bit app stalls/freezes, dump file added
App takes a long time to load and generally runs slow when in use. As far as I know it was designed for Vista 64 bit. BTW the cmd "cscript adplus.vbs -crash -nodumponfirst -minionsecond -quiet -pn dpeg.exe" needed to be changed to "cscript adplus_old.vbs -crash -nodumponfirst -minionsecond -quiet...
BSOD Help and Support
Ridiculously slow copy and read speeds on my Asus Dvd drive..Help!
Hey guys, It seems this problem has been annoying me for quite some time now but I have never really bothered to fix it simply because I really don't use the drive to install my games and stuff. But NOW the time has come for me to install a game from a disc (GTAIV) it's taking FOREVER! I mean...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:09.
Twitter Facebook Google+