Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows 7 x64 "Event Viewer has stopped working"

12 Oct 2012   #1

Windows 7 Home Premium 64bit
Windows 7 x64 "Event Viewer has stopped working"

Whenever I launch Event Viewer, I get this message. Ditto when I try launching Computer Management. I sometimes get a message about Adding a snap-in to console. But it never works. I ran SFC SCANNOW and it fix some stuff requiring a restart and is running clean now. No improvement.

I tried going back to an image from several weeks ago. Event Viewer worked but when I ran SFC SCANNOW and restarted, it stopped working again. If I run mmc.exe, I get a single folder Console Root. Trying to launch Event Viewer from the File menu crashes it. Running services the same way works. Running Component Management crashes.

Any ideas?


My System SpecsSystem Spec
12 Oct 2012   #2

7 x64

Check your system for BUGS. It is infected. That or the hard drive is corrupted and starting to fail.

These things don't Just Happen. Windows 7 is a very good operating system and does not have these problems unless something causes them.
My System SpecsSystem Spec
13 Oct 2012   #3

MS Windows 7 Home Premium 64-bit SP1

I had a similar problem in the past:

Event Viewer Error: MMC could not create the snap-in
My System SpecsSystem Spec

13 Oct 2012   #4
Layback Bear

Windows 10 Pro. 64/ version 1709 Windows 7 Pro/64

Have you been using any Tuneup, Speedup, Optimize or registry programs?
Please list them. Also if you could list all the anti virus programs and the like you are using.
My System SpecsSystem Spec

 Windows 7 x64 "Event Viewer has stopped working"

Thread Tools

Similar help and support threads
Thread Forum
Frequent system hangs, "atapi Event ID 11" in Event Viewer
Hi, I recently made some upgrades to a (previously fine) PC - they were - Installing 4GB extra RAM, of the same variety - Reinstalling windows on a new SSD (a Samsung SSD 850 EVO 500GB) I previously also upgraded to Windows 10, but a bunch of blue screens and other issues later I reinstalled...
"Program" has stopped working Problem Event Name: CLR20r3
Lately several of my programs have been unable to start giving the same error. example: Description: Stopped working Problem signature: Problem Event Name: CLR20r3 Problem Signature 01: ds3_tool.exe Problem Signature 02:
cannot start event viewer "Error code 1899"
Hi All, I've had an issue with Event viewer unable to start due to "endpoint mapper database entry could not be created" Error 1899. I have done a SFC and have had some but not all issues fixed, I have a log of the result and maybe could post if needed. I've also done a system restore to a...
Performance & Maintenance
"Disk error" invisible except to event viewer, when imaging hard drive
My Windows 7 configuration is relatively bullet proof (ha ha, nervous laughter). My OS and programs are on C, which I image using RDriveImage every month after Patch Tuesday. My data is on software-mirrored D/F drives. So as long as I don't have a catastrophic event affecting my computer,...
Hardware & Devices
"Windows Live Mail has stopped working" - Files describe event; Fix?
Three times in the last 24 hours this warning has opened on my Desktop, after I have just closed Windows Live Mail . After the warning disappears from the Desktop, WLM opens yet again. Naturally I've allowed the issue to be reported to MS and sent the information, but I note that there is...
Browsers & Mail

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:32.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App