Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Missing qlidx.dll?

14 Oct 2012   #1

Windows 7 Ultimate x64
Missing qlidx.dll?

I don't believe that this is in anyway related to the problems reported in my most recent thread because this message started showing up weeks ago. When I'd restart, as opposed to waking it up from hibernation, I would a message telling me that

is not found. I have no idea which application is looking for this dll. I googled qlidx.dll and didn't find anything.

Any ideas?


My System SpecsSystem Spec
14 Oct 2012   #2

Microsoft Community Contributor Award Recipient


Any time there's no information available on a .dll file or an .exe file I become suspicious. Legitimate files will usually have several references when they are googled. If no info is available I think malware. Suggest you do a full scan with your resident anti-malware suite. No anti-malware program is 100% effective 100% of the time. If there was such a thing we'd all be using it. So I'd also run these additional free scans.


ESET Online Scanner

Windows Defender Offline (This is a bootable malware and virus remover. You'll need to create the CD/DVD/USB Flash on a computer that's known to be malware-free.)
My System SpecsSystem Spec
15 Oct 2012   #3

Windows 7 Ultimate x64

Well, I ran Malwarebytes and it found a bunch of stuff. Then I ran ESET and it found a bunch of other stuff. Then I ran both again and neither found anything. I don't know where that stuff came from. I run AVG anti-virus and I'm usually pretty careful about what I download.

I then looked in MS-CONFIG and found that the dll in question was mentioned in there. It doesn't exist on my computer which is why I was getting that message at startup but it was still listed in the "RUN" section of the registry. Simple solution, delete the entry.

One of life's mysteries that may never be solved.
My System SpecsSystem Spec

15 Oct 2012   #4

Microsoft Community Contributor Award Recipient


If your computer had been previously infected it's possible that the mysterious .dll file was added to different system files. Running Malwarebytes and ESET probably removed the "poisonous head of the snake" leaving behind the benign tail in msconfig. And now that's gone as well.

Hopefully your machine is back to normal but periodic scans with Malwarebytes and ESET won't hurt. Just in case there's something lying dormant waiting for another chance to go active. Thanks for posting back with the update.
My System SpecsSystem Spec

 Missing qlidx.dll?

Thread Tools

Similar help and support threads
Thread Forum
Bootmgr.exe missing... mpio.sys missing or corrupted. Unable to boot
I just got a computer for free, a Dell Studio 1555. When I got it, it would try to boot, then come to a screen that said that bootmgr.exe was missing. Sometimes I got a message that said something like mpio.sys was corrupted or missing. I have a Win 7 disk, so I put it in and tried to repair the...
General Discussion
Missing MBR and missing OS after sleep problem
My setup had an MBR issue a few days ago after installing Skyrim. I was unable to repair it using the windows 7 instal disc. I tried the automatic fix as well as bootrec.exe. After giving up and reinstalling a fresh windows 7, my rig has not been starting up properly. It insists on waking up from...
BSOD Help and Support
Pictures missing suddenly and backgroung picture missing
i got on the pc this morning and noticed that where i have the picture saved on the desktop it was just black so i went into where my pictures are saved and there missing ?? but when i double click on one it will show any ideas please im lost on this ??
General Discussion
Win Explorer arrows missing, cursor spinning, libraries missing
New laptop (Lenovo W510), but I swapped boot disk for an SSD and reinstalled Win 7 64bit from recovery disks. I moved My Documents to D: and when I open Windows Explorer all looks fine. When I click on an arrow beside My Documents (or Music or anything), the arrow selected disappears, folder...
General Discussion
Missing boot menu and missing data partition
Hi there, I'm still very happy with my XP Pro, but I thought I'd set up a dual boot with Win7 ultima 64 and check it out. So I popped in another hdd that was sitting idly in a drawer and installed 7 on it. I fully expected that Win7 would be able to see there's an XP installation and create a...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:38.
Twitter Facebook Google+