Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Bootmgr is missing, even after rebuilding bcd

25 Nov 2012   #1

Windows 7 Professional x64
Bootmgr is missing, even after rebuilding bcd

Hey all,

I'm helping a buddy of mine repair his laptop (we've all been there before!) and I'm stumped. He claimed he didn't do anything wrong to it, but apparently, the laptop displays the "BOOTMGR is missing. Press Ctrl Alt Del to restart". I've tried the following, all to no avail:

Ran Startup Repair 3 separate times - it either found problems it couldn't repair, or repaired the problems, which didn't help.
bootsect /nt60 c:
BootRec /FixMbr -
BootRec /FixBoot
BootRec /ScanOs - I get the message "Total identified Windows installations: 0"
BootRec /RebuildBcd - I get the message "Total identified Windows installations: 0"
sfc /scannow - the scan won't run at all. I get a "Windows Resource Protection can't run now", or something similar

I removed the drive and hooked it up to a couple of different Windows machines using different drive docks just to be sure the drive wasn't bad. It mounted with no issue, and the drive had three partitions: one with the main Windows files on them, one labeled "RECOVERY" which is probably an OEM partition, and another 200MB partition which I assume is the Windows 7 System Protection partition.

I ran chkdsk on the drive, and it ran without issue, however when it reached the end, the scan locked up, and chkdsk wouldn't finish, even after several hours, so I canceled it.

I've also checked the SATA cable in the laptop, and it's fine. I've also checked the drive for viruses with AVG, but it came up clean.

After attempting to manually repair the bootmgr with the commands above, I decided to get a little more in depth. I attempted to copy over the bootmgr file from the Windows 7 isntall DVD that I have, which didn't help.

I also decided to follow the advice from EasyBCD's website on recovering the Windows bootloader from the DVD. Unfortunately, none of that worked either.

I decided to move the active partition from the System Reserved partition to the primary Windows partition, so that it would simply the process of rebuilding the bootloader. I've included a screenshot of the drive from Disk Management for reference. It's attached at the end of the post.

After making that active, I tried running the command prompt repairs again, but no luck. However, after I installed EasyBCD, I decided to try rebuilding the MBR and bootloader files on the Windows partition using that program. I did have some better luck here: after starting Windows Startup Repair, it recognized a Windows partition, however it reported the installation as being 0MB!

When I attempted to reboot the laptop, I got the error:
"Windows failed to start."


Status: 0xc000000e

Info: The selected entry could not be loaded because the application is missing or corrupt.

So it looks like I've traded one problem for another! The good news is that, before I used BCDedit, a partition on the drive was reported as being unallocated, and now it is reported as being a 100MB partition named HP Tools, and it is the active partition, not Windows. This leads me to believe that the partition was deleted, and I have since recovered it by rebuilding the bootloader info somehow. Unfortunately, it hasn't fixed the boot error.

When I run the bcdedit command, this is the output:

Windows Boot Loader
identifier GUID (very long sequence of letters and numbers)
device partition=c:
path \Windows\system32\winload.exe
description Microsoft Windows
osdevice partition=c:
systemroot \Windows

Windows Boot Loader
identifier GUID
device ramdisk [E:] \Windows Recovery Environment
and more details that just pertain to that entry.

Windows Memory Tester
identifier (memtest)
device partition=c:
path \boot\memtest.exe
description Windows Memory Diagnostic

Now the first entry I know I made myself, the second must have been made by Startup Repair from the Win installer DVD, and the last one was there when I started working on the computer.

I think that just about covers it. A very nasty situation, but I'm afraid a reinstall isn't possible: my friend has a copy of MS Office on there, and he has since lost the product key, so he wouldn't be able to reactivate it if Windows were reinstalled.

I'd love to hear someone offer some advice, as I'm out of luck and ideas! I think the best thing to do would be to simply the whole setup. Deleting the extra partitions would be a good start, as my friend doesn't use the recovery options that are offered by the OEM, and he probably wouldn't use the Windows recovery options either. If he does need them, I'll just burn him a Recovery CD. What I'd like to do is remove the partitions, and try and make the Windows partition the sole logical, active, boot volume. Then the system would boot correctly, and I wouldn't have to fiddle around with four separate partitions, most of which are unnecessary.

Attached Thumbnails
Bootmgr is missing, even after rebuilding bcd-disk-management.jpg  
My System SpecsSystem Spec
25 Nov 2012   #2
Microsoft MVP


Mark the System Reserved partition Active and then run Startup Repair - Run up to 3 Separate Times with only the Win7 HD plugged in to it's PC.

Under no circumstances should HP tools be marked Active. And the repairs will not work on the boot files on System Reserved (where they live) if it is not marked Active first so WinRE knows where to repair or rewrite the boot files.

If this fails work through the other steps for Troubleshooting Windows 7 Failure to Start
leading up to if necessary rescuiing the files to run a Clean Reinstall - Factory OEM Windows 7 which is vastly superior to HP preinstalled bloatware.
My System SpecsSystem Spec
25 Nov 2012   #3

Windows 7 Professional x64

Thanks for your prompt and helpful reply gregrocker!

I marked the System Reserved Partition as active, but when I ran Startup Repair, it simply told me that it couldn't fix the problem. The specific error in the details list was that no OS was found or present.

I'm going to continue to follow the other links that you posted, and keep trying to get the main system booting.

I have made one discovery: if I mark the RECOVERY partition as active, then I can access the HP Recovery options by pressing F11 at boot without issue. Maybe I need to leave that as the active partition, and simply repair the others?
My System SpecsSystem Spec

25 Nov 2012   #4

Windows 7 Professional x64

Interesting. When I run sfc /scannow from the computer using the F11 recovery environment, I get the message

There is a system repair pending which requires reboot to complete. Restart Windows and run sfc again.
Yet if I give the command sfc /scannow /offbootdir=c:\ /offwindir=c:\windows (where c: is the main Windows installation partition), I get the error:

Windows Resource Protection could not start the repair service.
My System SpecsSystem Spec
25 Nov 2012   #5
Microsoft MVP


As stated you need to run Startup Repair - Run up to 3 Separate Times with reboots, no matter what it reports. Make sure only Win7 HD is plugged in in its own PC.

In the rare case that this doesn't work then it explains in Troubleshooting Windows 7 Failure to Start how to mark C Active to try to write the System boot files to it by running three successive Repairs with reboots.

If Recovery was meant to be System Active there would be no System Reserved partition. But if you decide to rescue your files and run Recovery you can mark it Active to do so.
My System SpecsSystem Spec
26 Nov 2012   #6

Windows 7 Professional x64

OK, thanks again for the suggestions greg. Sadly, I ran Startup Repair three separate times - with reboots in between each run - with both the System Reserved partition and the Windows partition marked active, using Diskpart in the command line to change the active partitions, but no luck.

Startup Repair still finds no bootable installation of Windows, but I know it's there! Maybe I need to post some screenshots of each partition's contents from the root directory, just so you have an idea of one each one is about.

I'm not sure if the System Reserved partition is really that. It was actually unlabeled, along with the Windows partition. I simply labeled them System Reserved and Windows because I assumed that is what each one is for. I have no idea if the 200MB is something that was created by my friend, or if it really is it, because it wasn't labeled when I got the laptop to work on it.

You are correct about the RECOVERY partition; I can always label that active to get into it, and the good news is that it has the lean OS reinstall option - without all the crapware - as mentioned in the Windows 7 - Troubleshooting Windows 7 Failure to Boot guide (emphasis added):

Special notes to HP owners:

On newer models HP Recovery may offer a Minimized OS Recovery option when booting from F11, which retains only the OS, Recovery Manager, HP Support Asst, and HP Wireless LAN. This is as close to a clean reinstall as you can get without doing one yourself.

● If you clean reinstall only to C and leave all other partitions intact, F11 Recovery key should still work later if you need it.

● You can also Extract HP 3rd Party Software from RecovCD.

● Problems with volume control lighting and HP Quick Launch buttons have been dealt with here and here.
My System SpecsSystem Spec
26 Nov 2012   #7
Microsoft MVP


There are still other steps there to last resort attempt to start Win7, including running the Bootrec tool using the sequencing shown in the link in step 6.

Then I would rescue your files from Step 9 of Troubleshooting Failure to Boot and run the HP Minimal install which is as close to a Clean Reinstall as you can get without doing one.
My System SpecsSystem Spec
26 Nov 2012   #8

Windows 7 Professional x64

Right you are gregrocker: there are other steps still available, and after trying some of them, I think I must be getting close to fixing the issue!

OK, so I followed the link in step 6: Use the Bootrec.exe tool in the Windows Recovery Environment and I found that none of those options helped me, as I had already tried them (as mentioned in my first post). However, in the article, there was a link to another Windows KB article: Error message when you start Windows Vista, "The BCD file is missing required information."

Now although I haven't mentioned it yet, when I boot up the laptop, I get that error, rather than "Bootmgr is missing" error.

Following the steps in that KB article, specifically, Method 3: "Rebuild the BCD store manually using the bcdedit tool" I was able to get Startup Repair to recognize the Windows partition!

However, even after running startup repair three times again, still no luck. This time, Startup Repair gives me a "OS mixmatch" error, which is absolutely ridiculous, as it has never given me that before in the entire time I've spent working on this machine! I do know why it does that though: the CD is for Pro, and the installation on the laptop is Home Premium, so Startup Repair sees the discrepancy, and won't proceed. Unfortunately, my buddy doesn't have the OEM discs that came with the computer - if they came with any at all - so I'm not sure if I should try to download the Home Premium ISO from the Seven Forums link, and burn that to a disc and try that.

Additionally, I've noticed a couple of other things of note. First, after running the repair from the KB article, the computer now boots up to the error:

" file: \windows\system32\winload.exe

status: 0xc000000f

info: the selected entry could not be loaded because the application is
missing or corrupt.

I went back and checked the steps to make sure I hadn't done anything wrong. I found a very interesting situation in step eight:

Type the following command, and then press ENTER:
bcdedit /enum all
In the Windows Boot Loader section of the output from this command, note the GUID that is listed for resumeobject. You will use this GUID later.
I ran the enum command, and that's just the thing: there is no resumeobject value, or entry at all! I'm not sure if that's relevant or not, but I used the GUID from the drive itself, instead of the resumeboject value, which doesn't exist here.

Another thing I tried was the helpful Seven Forums thread, "Recovering from endless Windows Repair reboot." After I followed those steps, I made yet another discovery: the Windows drive has no Registry Hives files (SECURITY, BCD_Template, etc.,) in either the \windows\system32\config directory, or in the regback folder!

Should I try to recover the hives from my Windows retail disc? Or am I out of luck at this point?
My System SpecsSystem Spec
27 Nov 2012   #9
Microsoft MVP


Someone may know how to do that, but I'm not sure why you would want to go to all of that trouble when doing the vastly superior Clean Reinstall will likely take less time, and you end up with a Win7 better than on a new PC - given the amount of crapware larded on which throttles the OS.
My System SpecsSystem Spec
27 Nov 2012   #10

Windows 7 Professional x64

Yeah, you are probably right greg; the problem is, my friend has a copy of MS Office on there, and he doesn't have the disc or key for it - he lost it awhile ago. If I did a clean install, he'd lose it for sure.

I have a couple of other ideas that I'd like to run past you:

What about doing an in-place repair install with my retail disc, or a copy of the OEM discs for his laptop? Wouldn't that fix the boot files and registry, without destroying the Office installation?

The winload.exe file is corrupted, supposedly. Well, what if I could copy that off of my computer, which has a good working version of Windows 7? Would it make the difference, or would it screw up activation because the machine has a different version of Windows than mine?
My System SpecsSystem Spec

 Bootmgr is missing, even after rebuilding bcd

Thread Tools

Similar help and support threads
Thread Forum
Bootmgr.exe missing... mpio.sys missing or corrupted. Unable to boot
I just got a computer for free, a Dell Studio 1555. When I got it, it would try to boot, then come to a screen that said that bootmgr.exe was missing. Sometimes I got a message that said something like mpio.sys was corrupted or missing. I have a Win 7 disk, so I put it in and tried to repair the...
General Discussion
BOOTMGR is missing on my SSD
Hi I have just bought a new laptop and also installed a new 256gb SSD... I have just used Norton Ghost and copied the win7 64 bit OS from the HDD direct to SSD. I chnaged the proity boot sequence in the BIOS to SSD but get BOOTMGR is missing error... Ghost doesnt seem to assist you with...
Installation & Setup
bootmgr missing
OK for starters I suck at computer issues, but I'm your guy if you want your computer to have Anyways I have an Acer 5532 laptop with Windows 7 Home Premium installed. Yeah its an old unit, but it serves my purpose. My computer was running real slow, so I thought I would try to...
General Discussion
bootmgr missing error, became bootmgr MISSING.
I compressed my entire C drive. When I rebooted I got the error "Bootmgr is compressed" I don't have a optical drive, so I made a bootable USB drive using YUMI 0.2.3 and added the windows 7 recovery ISO. The USB drive boots and I can enter the recovery console, etc. It couldn't auto-repair...
General Discussion
BOOTMGR is missing need help pls
:cry:Hey guys turned my laptop on today and on boot it take me to a black screen where it says "BOOTMGR is missing press ctrl alt del to restart" i have read many things online on how to fix them but to no joy,so thought what better site to go on than an actual windows 7 forum. Anyways i have...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:22.
Twitter Facebook Google+