Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: No Autorun?

02 Oct 2009   #1

Windows 7 Ultimate and Ubuntu 9.04
No Autorun?

OK, so I'm not sure why this is happening...

For some reason it seems that autorun prompts are entirely disabled on my laptop, I'll put in a CD and nothing happens, I plug in a hard drive and nothing happens, etc. I don't get the options window like I did before I did a clean install.

I even did a reset of the settings:

And that didn't help. I set them all to "Ask me every time", but still, nothing.

Another question I had... Once I GET autorun working, is there a way to add an option to the list of choices? I use Media Player Classic for video DVDs, and in XP I actually HAD that on the list - but for some reason it's not there anymore. It just has WMP, VLC, and a couple other ripping programs I have installed. I want to have the option to play my DVDs with MPC - right now I have to keep manually opening MPC and doing it.

My System SpecsSystem Spec
02 Oct 2009   #2

64-bit Windows 10 Pro

Hello DrfSuperCenter,

The AutoPlay feature has been disabled for external storage devices, except for Microsoft certified programs, for security reasons. This way malware will not have a chance to autorun by mistake using AutoPlay from a external device. You will have to manually open and run these instead.

My System SpecsSystem Spec
02 Oct 2009   #3

Windows 7 Ultimate and Ubuntu 9.04

I'm aware of that - but usually when I put in a CD it'll say something like "Run Setup.exe" or "Open folder to view files".

I mean, literally, NOTHING pops up. It used to.
My System SpecsSystem Spec

02 Oct 2009   #4

Windows Seven x64

There is a difference between Autoplay and Autorun functions.

(I am going to looking around the web for the answer)

From what I am getting is that your Autorun and or Autoplay has been disabled..
Did you install anything before this started happening..
When you say clean install what are you installing? The OS?
My System SpecsSystem Spec
02 Oct 2009   #5

Windows 7 Ultimate and Ubuntu 9.04

Yes, clean install of the OS.

My hard drive broke, so I got a replacement from Seagate and then just did a fresh install of Windows 7 on it. I don't think Autoplay worked at all.

I don't know if some other program did it - all I know is if I insert a CD I don't get that option, and I liked being able to just click "Run setup.exe" and not have to manually browse and run the file.
My System SpecsSystem Spec
02 Oct 2009   #6

Windows Seven x64

I know Windows 7 disabled autorun.inf in USB drives because of viruses but The CD and DVD drive should work..

and you did a fresh clean install of Windows 7
Try this... This came from Microsoft Support ..
  1. Click the Start button , click All Programs, click Accessories, right-click Command Prompt, and then click Run as administrator. If you're prompted for an administrator password or confirmation, type the password or provide confirmation.
  2. At the command prompt, type net start shellhwdetection, and then press Enter.
  3. Restart your computer.
Hope This Helps..
My System SpecsSystem Spec
02 Oct 2009   #7

Windows 7 Ultimate and Ubuntu 9.04

C:\Users\Danny>net start shellhwdetection
The requested service has already been started.

More help is available by typing NET HELPMSG 2182.
Any ideas? :/
My System SpecsSystem Spec
02 Oct 2009   #8
Microsoft MVP

Windows 7 Ultimate 32bit SP1

If you want a CD to run when you put it in, click on Computer, then click on your CD drive. You can 'open' files from there.
See this link
My System SpecsSystem Spec
02 Oct 2009   #9

Windows 7 Ultimate and Ubuntu 9.04

That's what I do.

But it used to give a screen like:

Any idea how to get that back?
My System SpecsSystem Spec
02 Oct 2009   #10

Windows Seven x64

Try this..
  1. Click the Start button and go to your search bar(at the bottom of your Start Menu) and type services.
  2. You should see under programs the name Services with two gears as icons Click on that program.
  3. A window should pop up and scroll down until you see Shell Hardware Detection
  4. Right Click and Select Properties
  5. Another window should pop up and make sure you are in the General Tab and look until you see Startup Type make sure it is Automatic...
If it is set right then your Autoplay is working...

Also Try this..

If that is the case put a BLANK CD or DVD in the CD tray does anything come up?? (Something should come up)

If so then Autoplay is working..
If not then it has to be something with Control Panel in the Autoplay settings...

I have no more ideas I have tried them ALL... :)
I Hope this Helps...

EDIT: There is registry edit (I think) I will have to check on that to make sure..
My System SpecsSystem Spec

 No Autorun?

Thread Tools

Similar help and support threads
Thread Forum
USB autorun
when my USB is plunged or is opened in the file explorer i want a bat file run how would i do this
General Discussion
DVD/CD won't autorun
I'm pretty sure I have set all the options so that the disks _ought_ to autorun but they won't. I have to go into Powerdesk (File Manager) and select a vob file. I' installed a codec package but that made no difference. I have had problems with this drive, Samsung TSST CDDVDW 288BB, in fact...
Hardware & Devices
How to Autorun USB on Win 7
Hi, I want to make a USB flash drive auto run a website link in Windows 7. I know the auto run function has been removed in Win 7, but can I at least make a pop up window appear whenever a USB flash drive is inserted in the PC and have the user the option to click and open the link??? ...
USB autorun in W7
Ok, I know this is a sore subject, but are there any work-a-rounds to get handy programs like PortableApps to at least be an option to run when you plug it in? It kind of defeats the purpose of the whole thing. I'm not plugging in rogue USB sticks from strangers in dark alleys, just my own USB...
General Discussion
Is missing or corrupted.. anyone have this prob..? I have dl'd and burned the iso 2x and have the same prob. let me say that in order to burn iso..i have just renamed the longnamed file to (the longname).iso i have been dl'ing it with ff and it is adding a ,dlm to the file and i have just been...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:01.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App