Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Lost MBR

02 Oct 2009   #1
comdude85

Windows 7 Professional 32-bit
 
 
Lost MBR

Hi all,
I've been running 7 Professional for a couple of weeks now, and all of a sudden it won't boot. All I've done is install a new hard drive as a data drive, and when I power up I get "DISK BOOT FAILURE, INSERT SYSTEM DISK AND PRESS ENTER". (Yes, the OS drive is still installed, see below). I've inserted the 7 install disc and tried several different repair suggestions I found online, including using the UI Startup Repair tool (which has, on 3 subsequent boots, claimed to have identified and repaired the same issue of no system partition found) and various command prompt methods. The installer will not acknowledge that I have any OS installed, but it will happily let me access the OS drive as C: via a command prompt. This is a bit of an emergency, is there some command to just create a new MBR?


My System SpecsSystem Spec
.
02 Oct 2009   #2
Bare Foot Kid
Microsoft MVP

W 7 64-bit Ultimate
 
 

Hello comdude85, welcome to Seven Forums!


When you added the second HDD did you move the SATA connector cable for the original HDD, if so put it back like it was?
My System SpecsSystem Spec
02 Oct 2009   #3
comdude85

Windows 7 Professional 32-bit
 
 

Nope, didn't move the original one.
My System SpecsSystem Spec
.

02 Oct 2009   #4
SquonkSC

Win7 Build 7600 x86
 
 

Quote   Quote: Originally Posted by comdude85 View Post
Hi all,
I've been running 7 Professional for a couple of weeks now, and all of a sudden it won't boot. All I've done is install a new hard drive as a data drive, and when I power up I get "DISK BOOT FAILURE, INSERT SYSTEM DISK AND PRESS ENTER". (Yes, the OS drive is still installed, see below). I've inserted the 7 install disc and tried several different repair suggestions I found online, including using the UI Startup Repair tool (which has, on 3 subsequent boots, claimed to have identified and repaired the same issue of no system partition found) and various command prompt methods. The installer will not acknowledge that I have any OS installed, but it will happily let me access the OS drive as C: via a command prompt. This is a bit of an emergency, is there some command to just create a new MBR?
There's nothing wrong with your system.

Only thing that happened is by putting in the other disk, the boot sequence changed.

Go in the BIOS, and change the first device to boot to the old drive.

Don't mess around with the W7 install, you might ruin it.

Good luck.
My System SpecsSystem Spec
02 Oct 2009   #5
comdude85

Windows 7 Professional 32-bit
 
 

The BIOS boot sequence is correct, double checked that after I first saw the problem. What I don't get is how if bootrec.exe /scanos finds my OS install, how come bootrec.exe /fixmbr won't solve the problem... fixmbr has never let me down with other versions of Windows...
My System SpecsSystem Spec
02 Oct 2009   #6
comdude85

Windows 7 Professional 32-bit
 
 

Several times in a row, the Startup Repair function has reported "The partition table does not have a valid System Partition." as the root cause, and claimed to have repaired it. It has not. I can't imagine what partition is missing since, as I said, I can see my data just fine from the command prompt.
My System SpecsSystem Spec
02 Oct 2009   #7
SquonkSC

Win7 Build 7600 x86
 
 

Quote   Quote: Originally Posted by comdude85 View Post
The BIOS boot sequence is correct, double checked that after I first saw the problem. What I don't get is how if bootrec.exe /scanos finds my OS install, how come bootrec.exe /fixmbr won't solve the problem... fixmbr has never let me down with other versions of Windows...
Just a question.

You said you can go to the prompt, and you see C:\ right?

When you type dir and press enter, do you see the directories, like program files, and windows?
My System SpecsSystem Spec
02 Oct 2009   #8
comdude85

Windows 7 Professional 32-bit
 
 

Yes, all of my data is there.
My System SpecsSystem Spec
02 Oct 2009   #9
SquonkSC

Win7 Build 7600 x86
 
 

Quote   Quote: Originally Posted by comdude85 View Post
Yes, all of my data is there.
Did you install a new second disk or a used one?
My System SpecsSystem Spec
02 Oct 2009   #10
comdude85

Windows 7 Professional 32-bit
 
 

Brand new, unformatted.
My System SpecsSystem Spec
Reply

 Lost MBR




Thread Tools




Similar help and support threads
Thread Forum
Lost space on external drive - Lost 1TB of 2TB drive
I have a WD Red 2.0 TB drive (1.8 TB formatted) and have been watching it fill up (%used) for some time now. I have lost 1 TB to "unknown" according to WinDirStat. VSS is NOT RUNNING, which I read about in the tutorial here:...
Performance & Maintenance
Lost my HP Touchsmart LOGO since I lost resetted my BIOS (I guess)
Hi All I have a HP Touchsmart 300-1060a (Home Premium Windows 7 64 BIT) which I bought few years back. Now for the last 6 months or so I started getting issues with my machine was not displaying anything at all after turning it on. So I had to hard reset my power from the machine and then...
Hardware & Devices
lost use of all usb's
hi all ive got a right pain in the ass problem. i was reinstalling a driver to a usb freeview dongle when i lost use of all my usb's. i rebooted incase it was just a driver issue. im not that lucky. next i switched which input the usb's where conected to and reset the cmos. rebooted and pc boots...
Hardware & Devices
MCE Is Lost
I don't use it very much, so it has been quite some time since I looked for it, but now I can't find it in the Start Menu. I would like to create a shortcut to put there, but I'm not finding the program by searching...where is it?
Media Center
The ???? ;) (I just lost, and so did you)
So who here knows about the game (not the rapper)? For those that don't, check this out: THE GAME :D Well, I just lost the game.
Chillout Room
Lost Dual Boot Screen?...Lost Windows 7
I have Vista Home Premium 64 bit and I downloaded 64 Bit RC Windows 7 and did a clean install on another partition of my hard drive. Dual boot was working for about 4 days then all of a sudden it doesnt come up any more. The partition is still there with Windows 7 installed on it but its not...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:26.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App