Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Can't Fix or Reinstall Windows 7 HomePrm; Missing DLLs

16 Jan 2013   #11

Windows 7 Home Premium 32bit
Quick Update

Greetings Gregrocker,

Followed your instructions: downloaded fresh iso and installed on usb drive then booted troubled pc via usb. booted and began install. After choosing 'custom install' installation began then after 9% at 'Expanding Windows Files' an

Error Message: Windows cannot install required files. The file may be corrupt or missing. Make sure all files required for installation are available and restart installation.

Error Code: 080070570

shut down and restarted from usb, same error occurred. Going to unplug cd/dvd drive and replug to see if it will work...thanks again.

My System SpecsSystem Spec
16 Jan 2013   #12
Microsoft MVP


The installer is likely bad. Confirm the ISO size and write to stick using UltraISO Software To Create Bootable USB Flash Drive.

Can you try DVD install?
My System SpecsSystem Spec
16 Jan 2013   #13

Windows 7 Home Premium 32bit
i did, results follow...

Thanks, gregrocker,

after my last post i did try cd install, also tried the original vista recovery disk. Both efforts failed in same manner as the earlier attempt. the cd install ended immediately after <install> with same missing cd driver error. the recovery said 'no mbr, use control, alt, delete to restart'.

there was one different problem when i tried the cd iso install, the pc scrn froze midway in loading software. that happened twice before it loaded the software and gave me the language scrn. my concern is growing that a hardware problem may exist.

headed to Ultraiso to give it a go.

as always, thanks for your time and skill.
My System SpecsSystem Spec

17 Jan 2013   #14
Microsoft MVP


If stick written by Ultra errors out similarly then test your HD with Data Lifeguard Diagnostic for DOS (CD) extended CD scan.

If it checks out OK test your RAM - Test with Memtest86+ for 5-6 passes or overnight.

Then move HD to another PC to run a full Disk Check, then wipe it with Diskpart Clean Command. This should force the installer to start itself when you move HD back.

If no other PC boot free Partition Wizard bootable CD to run Check File System on all partitions, or create one large partition to run it on. Then Quick Wipe the HD from Disk tab, create new NTFS primary partition, rightclick it to Modify>Set to active, OK, Apply. Reboot into installer which should autostart to begin install.
My System SpecsSystem Spec
17 Jan 2013   #15

Windows 7 Home Premium 32bit

Ultra stick error-ed out. 'had trouble getting to cd drive at c-prompt and opted to run Memtest 86+ v4.20 first.

DOS scrn freeze at Memtest 7:36 Walltime on first try. Second try scrn freeze at 22:12 Walltime.

Third try Memtest scrn freeze at 3:02:49 Walltime on Test 7 Random number sequence, Pass 5, found 158 errors but did Not identify channel...i could only see errors 150 to 158. No errors were found until late in Pass 5.

Do you agree I need to get new memory? I am concerned that there may be a board or power unit problem, especially since a channel was not identified...of course I could not see errors 1-149.

My problem with the cd may have been due to using the win7 install disk to 'repair' in order to get to c-prompt. Perhaps i need to burn a dos boot cd instead.
My System SpecsSystem Spec
17 Jan 2013   #16
Microsoft MVP


Use the installer DVD for your licensed version for repairs and to have for reinstall: Clean Reinstall - Factory OEM Windows 7

Follow the RAM - Test with Memtest86+ tutorial to test sticks and slots to isolate the problem. If it's stick(s) then replace it, making sure it's spec'd correctly. I google the mobo or PC model + RAM upgrade to compare results, confirm with Crucial System Scanner software to find out what type of memory is in your computer to get definitive specs before ordering online.

Even better is to go to a Tiger Direct, CompUSA parts counter or PC shop to have them confirm specs since it's much easier to take back if wrong.
My System SpecsSystem Spec
18 Jan 2013   #17

Windows 7 Home Premium 32bit

This has been a long day, gregrocker. The board has 2 banks with 2 slots each. Only 2 sticks of 1024 ddr2-667 in bank A slot 0 & Bank B slot 0. Removed bank B ram and immediately noted the ram top securing snaps at bank A slot 1 and bank B slot 0 are missing and not in the case. 'Tried to place a snap at bank B slot 0 but could not; may be a broken snap piece blocking within. BTW this is a refurb. Bank A ram ran 9 passes without error. Then added remaining stick to bank B slot 1; ran 11 passes without error, though I know the config may slow things down...what's your advice? but there's more...

Tried installing Win7 at internal cd/dvd but received the same error as before "missing driver"; then tried usb drive install but received the same error as yesterday. Last resort, hooked up usb dvd and Win7 installed and seem to update fairly well, but...

Received error: PCI Simple Communications Controller missing driver. Then DNS Server not responding.
I think the PCI driver is installed with the motherboard or chipset, but I really don't know. I tried installing trial of PCIScope and it caused a blue scrn crash so I abandoned that.

I'm mighty confused but I'm not lost long as you will continue to impart K. Thanks again, especially for your tenacity.
My System SpecsSystem Spec
18 Jan 2013   #18
Microsoft MVP


Install the chipset from the gateway Support Downloads webpage for your model PC here: Gateway Support - Downloads & Support Documents - Desktop / GT Series / GT5628.

Have you run all IMportant and Optional Updates after enabling Automatically deliver drivers via Windows Update (Step 3) as specfied in the tutorial to get a perfect reinstall? There will be several rounds with reboots.

Have you tried both RAM sticks in A bank slots? Consult your Manual on the Gateway Downloads webpage for your model. I'm not absolutely sure since every mobo is different but you can try it. Ask in our hardware forum if it fails to register or messes up performance. It might also advise you by running Crucial System Scanner software to find out what type of memory is in your computer.

I also asked my buddy Dave who's a top RAM expert here to consult.
My System SpecsSystem Spec
20 Jan 2013   #19

Microsoft Community Contributor Award Recipient

Windows 7 Ult x64 - SP1/ Windows 8 Pro x64

You are having proven RAM issues, broken snap locks may be the cause.

Is your refurb still under warranty?

Some motherboards can run the RAM is different slot without issues, maybe yours is one of them.
Quote   Quote: Originally Posted by do2 View Post
BTW this is a refurb. Bank A ram ran 9 passes without error. Then added remaining stick to bank B slot 1; ran 11 passes without error, though I know the config may slow things down...what's your advice?
Run memtest86+ with both RAM cards installed, one in bank A slot 0 (with snap lock) and the other in bank B slot 1 (with snap lock).
This should tell us if your system will be stable with RAM in those slots.

Let us know the results.
My System SpecsSystem Spec
20 Jan 2013   #20

Windows 7 Home Premium 32bit

Greetings Dave76,

Thanks for your input. Refurb no longer under warranty. I have ran both RAM cards in bank A slot 0 and also both installed: 1 in bank A slot 0 and 1 in bank B slot 1 through at least 11 passes and both ways zero errors. Used bottom clip from bank A slot 1 to insert into top clip recess at bank B slot 0 but haven't been able to seat.
Used Crucial Scanner to ID Ram -ddr2 667 mhz.

Also set MS update to install all drivers + updated chipset driver software at Gateway.

Continue to have errors when trying to backup data and image with error 0x8007045D. Reviewed and used fix recommended in MS support pps. which was Chkdsk/R C: and again for external WD 2.5Tb drive. Result: same error. Getting another error 0x8078002A - headed back to MS support for possible fix. Plan to try to run backup w/ image to DVD and hope it works. DVD drives may still have problems but plan more checks.

I fear commercial driver software but read good reviews of 'driveeasy', that will be a last resort, if ever. Still have the problem with PCI simple communications controller and under devices and printers the PC has a yellow ! problem sign.

Gateway lists a number of BIOS updates for the board, but it appears an Intel board BIOS has been installed and not sure which Gateway BIOS is the equal...don't know if a BIOS can be flashed 'backward' (just in case I pick an older one by mistake). Kinda stuck here but still working to make things right.

Thanks to you and gregrocker for fine advice.
My System SpecsSystem Spec

 Can't Fix or Reinstall Windows 7 HomePrm; Missing DLLs

Thread Tools

Similar help and support threads
Thread Forum
So Much Missing DLLs & some programs won't start
First time of installation Windows 7 x64 Ultimate, there was no problem. Everything was fine. Recently, there were a missing 3 dll file for a one time my Windows opening, and then there was no missing file but lots of errors were there. Google Chrome's some setting buttons won't opening,...
General Discussion
Windows 7 reinstall cd/dvd driver missing
Hi, I have been searching online for two days trying to get help with this. I have a Sony Vaio SVE1511P1EW. I am trying to reinstall Windows 7 home premium from USB. It worked once and I then reinstalled backup. Something in my back up is corrupting computer so I tried to reinstall and now...
General Discussion
missing dlls error
ive just installed black mirror 2 but when i try to start the game i get errors first error was d3dx9_35.dll missing i downloaded directx latest and installed it but now get this error trivium.dll is missing from your computer any help appreciated
path used to search for DLLs? Install.exe can't find DLLs on DVD?
I just looked at my environment PATH setting, and the only thing that's there is the path to UltraEdit. I was trying to install new software from a DVD (setup.exe at the outer layer), and it could not find any of the DLLs that were located in folder on the same DVD. How do I set up...
General Discussion
Explorerframe.dll Folders missing, default dlls, theme manager
Ok I have 3 questions so I'm going to jam them all in one topic instead of making 3. I installed this theme and its explorerframe.dll: PlastiQ Aero 1.1 by ~Lukeedee on deviantART Now when I open a window that involves folders like this: ...
Themes and Styles

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:54.
Twitter Facebook Google+