Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Memory problems with RC1

03 Oct 2009   #1
oarad

Windows 7
 
 
Memory problems with RC1

Hi All, I installed RC1 on my LG Notebook LW70 M 2Ghz Processor 2G Memory.

Problem is that I have the Low Memory warning message popping on me every time I run more than 3 or 4 apps.
Every time I start windows the "Performance Options" dialog appear by itself but it wont commit any changes I make on it anyway. Currently it's set to "No Paging File"

I should note that me and my wife are using different user accounts on the system (as we did with no problems on the same machine with XP) but the above behavior occurs whether we both are logged in or just me.

Thanks for any advice,
Oren


My System SpecsSystem Spec
.
03 Oct 2009   #2
Brink

64-bit Windows 10 Pro
 
 

Hello Oren, and welcome to Seven Forums.

The paging file will need to be turned back on, and set to be system managed to avoid this. Some apps will require the page file to run properly no matter how much RAM you have installed.

Virtual Memory Paging File - Change - Vista Forums

Hope this helps,
Shawn
My System SpecsSystem Spec
04 Oct 2009   #3
oarad

Windows 7
 
 

Hi, Thank you Shawn,

Problem is that I can't seem to commit any changes I make in the Paging file dialog, it just ignores what I set anyway.

Oren
My System SpecsSystem Spec
.

04 Oct 2009   #4
Brink

64-bit Windows 10 Pro
 
 

That's strange. Do you have enough free space on the selected C: drive, and are you doing this from within an administrator account?
My System SpecsSystem Spec
04 Oct 2009   #5
oarad

Windows 7
 
 

I'm sure I do, it's a 100 GB drive and i'm using maybe 35-40% of it. I am an Administrator.
Any thoughts?
Oren
My System SpecsSystem Spec
04 Oct 2009   #6
H2SO4

Win7x64
 
 

Quote   Quote: Originally Posted by oarad View Post
I'm sure I do, it's a 100 GB drive and i'm using maybe 35-40% of it. I am an Administrator.
Any thoughts?
Oren
It might be registry corruption or a registry permissions issue. Can you fire up Regedit.exe and find the following key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

On the left-hand regedit pane, if you right-click the "Memory Management" key and select "Export", you'll be given a choice of where to save a *.reg file with the contents of that key.

Please change the REG extension to TXT, then upload it here. (I'd suggest avoiding the temptation to edit the values directly, at least for now :))
My System SpecsSystem Spec
04 Oct 2009   #7
oarad

Windows 7
 
 

Here goes:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management]
"ClearPageFileAtShutdown"=dword:00000000
"DisablePagingExecutive"=dword:00000000
"LargeSystemCache"=dword:00000000
"NonPagedPoolQuota"=dword:00000000
"NonPagedPoolSize"=dword:00000000
"PagedPoolQuota"=dword:00000000
"PagedPoolSize"=dword:00000000
"SecondLevelDataCache"=dword:00000000
"SessionPoolSize"=dword:00000004
"SessionViewSize"=dword:00000030
"SystemPages"=dword:000c3000
"PagingFiles"=hex(7):3f,00,3a,00,5c,00,70,00,61,00,67,00,65,00,66,00,69,00,6c,\
00,65,00,2e,00,73,00,79,00,73,00,00,00
"PhysicalAddressExtension"=dword:00000001
"TempPageFile"=dword:00000001
"ExistingPageFiles"=hex(7):5c,00,3f,00,3f,00,5c,00,3f,00,3a,00,5c,00,70,00,61,\
00,67,00,65,00,66,00,69,00,6c,00,65,00,2e,00,73,00,79,00,73,00,00,00,00,00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\PrefetchParameters]
"BootId"=dword:00000016
"BaseTime"=dword:101598cd
"EnableSuperfetch"=dword:00000003
"EnablePrefetcher"=dword:00000003
"EnableBootTrace"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\StoreParameters]


What can you make of this?
Thanks,
Oren
My System SpecsSystem Spec
04 Oct 2009   #8
H2SO4

Win7x64
 
 

Quote   Quote: Originally Posted by oarad View Post
What can you make of this?
A small pagoda in the late Song Dynasty style

Actually, it tells me several things:

- You (your user account) are able to access the key without problems. Hence, assuming the changes made though the pagefile settings UI are made in the context of the user who presses the "apply" button, this does not appear to be a permissions issue.

- The ExistingPageFiles value translates to "\??\?:\pagefile.sys". If it wasn't for the existence (in your case) of the TempPageFile=1 value, I'd think that was odd.

Can you temporarily uninstall your anti-virus and try again? There's a chance that registry writes are being prevented or hampered by some sort of non-default security software on that machine. Alternatively, if you're conversant with Process Monitor (sysinternals.microsoft.com), you might want to log the attempt to apply changes and look for obvious failures.

Also, does the same failure to apply new pagefile settings happen with other admin accounts, even if you have to create one specifically for the sake of testing?
My System SpecsSystem Spec
05 Oct 2009   #9
oarad

Windows 7
 
 

I removed AV but to no avail, changes I make in the page file dialog will note be saved.
There is one other issue that bothers be and since you brought up registry access it may be related. My canon digital camera software has a "run when camera connected" function but I can't seen to set this option because whenever I check this options and hit OK, then reopens the dialog this option is uncheched.

Related???

But whatever this is, I guess it's not because of a security app.

Oren
My System SpecsSystem Spec
05 Oct 2009   #10
Brink

64-bit Windows 10 Pro
 
 

Oren,

You may have a bad install or a bad copy/burn of Windows 7. You might see if doing a repair install may be able to fix this without losing anything.
My System SpecsSystem Spec
Reply

 Memory problems with RC1




Thread Tools




Similar help and support threads
Thread Forum
Windows Memory Diagnostic Reports Memory Problems
Hi, I ran Windows Memory Diagnostics multiple times (1GB Ram = 2X512), sometimes it reposrts errors, and sometimes not! I'm running two OS: Windows Server 2008 R2 SP1 64Bit, where I'm encountering bad performance, and Windows 7 32Bit which runs smoothly. I'm not sure if it's really a...
BSOD Help and Support
Memory compatibility problems
I ordered a pair of 1 GB PC3200 DDR400 sticks and they sent me a pair that say MDD400 128X64. These are not compatible with either of my 2 machines running Win7 64. :cry: What's the difference?
Hardware & Devices
Memory Problems
I had 4x 1GB DDR2 6400 chips. Just swapped out 2 of them for 2GB DDR2 6400 chips. Task manager performance used to show 4 GB of memory, It now shows 3GB. I should have a total of 6GB now. I'm confused. Think I did the install right according to the board manual. Positions are: Channel A DIMM 0...
Hardware & Devices
Memory problems......
Hi all, I've built my set-up as per my spec in my profile. Intel core i7, Gigabyte motherboard. I'm having memory problems. I bought 8 gig of DDR3 PC1333 but the computer gives various beeps and won't start at all with any combination other than one, 2 gig module in. It only runs with 2 gig...
Performance & Maintenance
SD memory card problems plz help!!!
ey guys my pc has ports for SD memory cards and such, and after upgrading from vista to win 7 no SD cards will read, nor will they read while the card is in my mob phone while trying to access it through the phones software. could it be some sort of driver problem? however the phones...
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:39.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App