Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: "Destination Folder Access Denied" when modifying Program Files folder

13 Feb 2013   #1

Windows 7 Ultimate x64
"Destination Folder Access Denied" when modifying Program Files folder

Destination Folder Access Denied
You'll need to provide administrator permission to copy to this folder.
<Folder/Sub-Folder Name>
Date created: <Creation Date>
I get this dialog files whenever I try to modify (copy, delete or edit) contents of the "C:\Program Files" folder or its sub folders. When I click the Continue button, everything goes on fine without any problem. Some programs give write errors when I try to modify a file inside Program Files with them (e.g.; Notepad++ gives write error when I try to edit a text file inside one of the sub-folders of the Program Files folder).

I'm the only user on this computer, and I'm already the administrator who installed this Windows. There is no other OS installed on this machine.

This problem has been occurring for a long time. At first I ignored it, but later it started to became bothersome. I don't remember how have it started, or what had I done before it first appeared.

What can I do to stop Windows showing me this dialog box? I want to freely modify contents of any directory in my computer. This is a home computer, I have no social privacy concerns.

(OS: Windows 7 Ultimate x64 SP1, Up-to-date)

My System SpecsSystem Spec
13 Feb 2013   #2

Windows 7 Professional 32bit

My System SpecsSystem Spec
14 Feb 2013   #3

64-bit Windows 10 Pro

Hello HK,

This is because these are protected system files. This is done as a security measure to help prevent unauthorized changes and access to system files. For example, from malware.

By default, you could modify the file on your desktop, then copy it back into it's Program Files folder with the Continue prompt.

Your administrator account is an unelevated administrator account until you use "Run as administrator" to run or open something elevated.

If you like, you could also enable and log on to the built-in elevated "Administrator" account when you wanted to do modify files like this to have full unrestricted access.

Built-in Administrator Account - Enable or Disable

Hope this helps, :)
My System SpecsSystem Spec

14 Feb 2013   #4

Windows 7 Ultimate x64

Quote   Quote: Originally Posted by Cancerous View Post
You could try disabling UAC.
Since it was easiest, I tried Cancerous' advice first, and it worked.

It was strange that UAC was already appeared to be turned off (the slider was at the bottom). I get suspicious of it, I moved the slider to an upper position, then I clicked OK, then I moved the slider to bottom again, then clicked OK again, and then restarted my computer.
I did nothing else and just doing it solved my problem.

User Account Control - UAC - Change Notification Settings

Thank you Cancerous, and thank you for your reply Brink.
My System SpecsSystem Spec
14 Feb 2013   #5

64-bit Windows 10 Pro

Glad to hear it worked for you. :)
My System SpecsSystem Spec
20 Sep 2013   #6

Windows 7 64-bit
UAC method worked

I tried disabling UAC and it also worked for me. The UAC slider also appeared all the way off, but when I moved it up then clicked ok, then moved it back down and clicked ok I was able to copy the file immediately with no restart. Very strange.
My System SpecsSystem Spec

 "Destination Folder Access Denied" when modifying Program Files folder

Thread Tools

Similar help and support threads
Thread Forum
Denied permission when trying to get access to folder named "1055"
From somewhere, somehow, a folder named "24cd9e4542d29590bce925ec30" has been created in my W7x86pro root dir. Trying to look inside, I had to "permanently get access". But then inside it, there are a whole lot of folders named things like 1025, 1028, 1029, etc, ending with 3076, and 3082. ...
General Discussion
Windows 7 Destination Folder access denied
So here's the scenario. i have a media server set up where i store all my media files so they are shared with my household. The problem is that when i try and do anything in the shared folder (mapped as a network drive) i get a "destination folder access denied: you need permission to perform...
Network & Sharing
Destination folder access denied
hi All, Have a problem moving files from my laptop to my desktop. They are on a Homegroup, both running Win 7. When I try copying files from my laptop to my desktop, and I initiate this on the laptop, I get an error saying "Destination folder access denied. You need permission to perform this...
General Discussion
Folder Shared, Permission Granted File "Access denied"
On both 64Bit & 32Bit Win7 machines I get an error message, denying access to a file in a folder within another folder. All have been shared, permissions granted & drives mapped to each folder. That is in addition to initially applying the changes to the file folder, subfolders, and files. The...
Network & Sharing
Ex windows 7 documments folder get "Access denied"
Hello, recently uninstall Windows 7 to re-install xp for some reason, well my old user account password windows 7 not even had much less some sort of encryption, I mean the main library folder "documents" now that I try to access this folder from xp I get an access denied error not to do and...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:38.
Twitter Facebook Google+