Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Could not find this item - when deleting files

12 Jun 2010   #11

Windows 7

Thank you so much. I had a file on my desktop and it was fricking annoying.

My System SpecsSystem Spec
01 Jul 2010   #12

Windows 7 Ultimate 6.1.7600 x64

I used to do the dir /x thing and it worked but I had this one file that even THAT didn't work so I found my own SIMPLE solution that worked great.

I just created a new directory, moved the bogus file into it (I didn't think it would move it but it did!) then in the new directory, the file got a new icon and then I just deleted the new directory and it was gone.
My System SpecsSystem Spec
03 Sep 2010   #13

Win 7 Homne Prem
Thanks Tachy

The ~ worked !
My System SpecsSystem Spec

05 Sep 2010   #14

Windows 7 ultimate x64

Thanks tachy!

Your methood worked perfectly on 3 files and 1 dir on different locations that has been a pain in the neck for me .. :)

thanks for sharing the solution

have a good one

My System SpecsSystem Spec
12 Sep 2010   #15

7 ultimate 32

Tachy's method worked for me also, with one exception...

1) Open cmd prompt
2) 'cd c:\users', to get to the directory,
3) 'dir/x' to list the directory files... but there was no 8.3 formatted filename for the file I was trying to delete (most likely related to why it won't delete)
4) Tried deleting it using the original filename, e.g. 'del windows.old' and it worked!

Something I never would have thought to do. Thanks so much. And it's never too late Tachy!
My System SpecsSystem Spec
16 Sep 2010   #16

Windows 7 Ultimate 32bit

I'm replying to anyone that is having trouble deleting a file. Been working on it half the day myself, reading through a lot of post could and not find a solution. So I gave it one more try. The file I was trying to delete was located in my download folder, but was not placed with-in a folder itself. So I created a new folder without renaming it, and dragged the file into the new folder. Do not copy and paste, it will only make the same problem. After that I just right clicked and deleted the folder. Work out fine for me. Hopefully for you too. Hope I explained it well. Good Luck
My System SpecsSystem Spec
28 Sep 2010   #17

Windows 7

Here's how i fixed it:

i had this problem with a folder that had an incredibly large name and i think some files were inside of it that had the same filename..

i couldn't delete or rename or do anything with it. i couldn't even go into it to see if anything was inside.

so i tried the advice here and none of it worked either.

but i got it eventually.. and here is what i did:

since i couldn't move that folder, i renamed and moved the folder that held it (parent folder) to the number "1" and moved it to the root of the drive and it let me.. thus making the total filename/directory structure a little shorter.. I dont know if that was needed but thats what i did.

Then i tried to delete that problem folder again and it still didn't work.. and still couldn't rename it to something shorter.. so then i tried something else.

I ran "cmd" and in DOS i went to the directory "1" that was holding the problem-folder and then i typed "dir/x" to get the 8.3 format of the folder.. and tried "del <foldername>" and it didn't work.. Then i tried the rename command..

"Ren <8.3foldername> <new shorter foldername>"

and guess what? it worked!!!!!

it actually let me rename it and then i closed DOS and went back to explorer and now it's acting like a regular folder that can be deleted or whatever again.
My System SpecsSystem Spec
03 Oct 2010   #18

Windows 7 professional
This problem is wider than you all state

I get the same message, but it occurs when I create, move or delete a folder, including a zip folder (eg, when trying to create an archive). It is easily fixed by clicking &quot;try again&quot;. But a more permanent solution would be helpful - ideas anyone? LATER: Found a solution which worked for my 32 bit Windows 7 system. [MSUPDATE KB980408]Warning To All Win7 x64 Users. - Page 2 - - scroll down to HellGates
My System SpecsSystem Spec
08 Oct 2010   #19

windows 7

i had a very similer problem and nothing here worked for me, but i finally deleted it very simply, befor it said the file wasnt there even when i used all the methods here, but strangely enough it let me move it to the desktop and i used a program called unlocker and it deleted it, before hand unlocker said the file wasnt there either but worked fine when i moved, go figure.
My System SpecsSystem Spec
10 Dec 2010   #20

Windows 7 Ultimate Service Pack 1 RC 1 64 bit

I came across this issue as well. I believe the problem was caused when the item was moved but the registry or desktop.ini file never updated the desktop settings, making it believe that the item was there when it did not exist, thus giving the "Could not find the item" error. I'm not perfectly sure what could cause that issue. On occasions when Windows is dealing with a ton of other things it "forgets" to update the desktop settings just as when a person is dealing with a ton of things in the office, they can forget to do certain things at times. That is just a scenario for some cases and is different from situation to situation. When you press the F5 button, in a good portion of cases it forces Windows to stop what it is doing and makes it update the desktop and its settings.
My System SpecsSystem Spec

 Could not find this item - when deleting files

Thread Tools

Similar help and support threads
Thread Forum
Item Not Found: Could Not Find This Item
Hello! I've had a problem with a particular folder on my desktop for a while now and have finally decided to fix it. There is a folder that has some thing to do with Camtasia 7 (Software for screen recording and video editing) stuck on my desktop that I can't delete/rename. ...
General Discussion
Could Not Find This Item error when moving files from specific folder
I have a folder in my documents full of music samples to make songs out of and I am trying to move the folder to an external hard drive and every time I do I get the following error "Could Not Find This Item" "This Is No Longer Located in C:\<username>\My Documents\Music_maker\ Verify the item's...
General Discussion
"Could not find item" when moving or deleting files
Hi. Im running Windows 7 64bit and every time I move or delete a file, I get the "could not find item" message, but the tasks still performs successfully. Any ideas?
General Discussion
'Could not find this item'
Driving me crazy having to rename and move folders to do basic work in Win 7. Right-Click / copy pops up -'Item Not Found' dialog. Well - I just right clicked it - it IS there... Older posts in this forum were work-arounds. Is this fixed, yet? Many thanks from a very frustrated...
General Discussion
Windows 7 - Could not find this item - when deleting files
I have two, empty folders on my Desktop. When I try to delete them, the system says, that it can't find the file, because it's no longer located in... What can I do?
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:26.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App