Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Could not find this item - when deleting files

03 Mar 2014   #51

Windows 7 Ultimate x64
DelinvFile tool wored!

DelinvFile tool worked for me! Thanks to @galmeida for the help :)

My System SpecsSystem Spec
28 Mar 2014   #52
sean vida

Windows 7 Home x64

This just happened to me and though I'm usually pretty computer savvy - I just couldn't follow the cmd: fixes...
Anyway, here's how I got rid of mine (which were all on an external Hard drive).
Click on the File/Right Click and go down to Properties/Click on Details/At bottom of Pop up Box click 'Remove Properties & Personal Information (which is highlighted in blue)/Click Select All (in the Pop Up Box) and OK/Another Box will appear saying "The Search Results in you want to create it...../click Yes/ Another Box will appear saying 'Not all Properties were cleared....just click close. If file has not gone - click delete and it should be.... Worked for mine.
My System SpecsSystem Spec
06 Oct 2015   #53

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
Deletion of files that cannot be found

Quote   Quote: Originally Posted by tachy View Post
I know this is a bit late, but I found a quick workaround:

1) Open a Command Prompt.
2) Browse to the folder containing the buggy file.
3) Type 'dir /x' to obtain the 8.3 formatted filename.
4) Delete the file using the 8.3 filename, e.g. 'del NEWDOC~1.DOC'

Hope this information may spread and help other users with the same problem.
I followed this post by Tachy and it solved my problem! Thanks Tachy. Perhaps an old post but very helpful.
My System SpecsSystem Spec

31 Oct 2015   #54

Windows 7 Home Premium 64 bit, Windows 7 Ultimate

Quote   Quote: Originally Posted by tachy View Post
I know this is a bit late, but I found a quick workaround:

1) Open a Command Prompt.
2) Browse to the folder containing the buggy file.
3) Type 'dir /x' to obtain the 8.3 formatted filename.
4) Delete the file using the 8.3 filename, e.g. 'del NEWDOC~1.DOC'

Hope this information may spread and help other users with the same problem.
Thanks Tachy. This solved my problem!
My System SpecsSystem Spec
30 Dec 2015   #55

Win7 Pro 32bit

Tachy and Niklet´s answer worked for me, ie: rename to 'del windows.old' then delete. Finally! I have wasted days on this problem. Thanks guys.
My System SpecsSystem Spec
07 Jan 2016   #56

Windows 7 Home Premuim 64bit
Fix - Actually Works

I had this issue as well and after continously trying to delete/use cmd etc and refresh (or F5, as you all put it) it did. not. work. I was pretty infuriated at all the comments repeating the same use of F5 because you have prgrammes open that require a large amount of RAM. This was not the case and I'm fairly sure the OP said that.

However I did find out this is the easiest way to delete these unwanted files / folders. And since I'm a beginner with computers, this was how I did it and I'll explain it like you SHOULD to a begininger. I feel as though many people didn't take that into consideration as most of the comments just go over my head.
  • Open cmd. (Start>Type cmd>Hit Enter)
  • Type "cd /d {location of file/folder}"
  • Press Enter
  • Type "dir /x"
  • Press Enter. - A list of dates / times / and finally the name of your file or folder will show up.
  • Find the name that is similar to your file/folder name. This is the directry name "FILE~1" for example.
  • Type "rmdir /q /s {FILE~1}"
  • Press Enter.
  • The File should now be deleted.

Hope this helps anyone else out!
My System SpecsSystem Spec
02 Feb 2016   #57


I created a .RAR file and dragged (MOVED) the bad file/folder into that .RAR and then deleted the .RAR file successfully
My System SpecsSystem Spec
25 May 2016   #58

7 Ultimate 32 bit.

Tachy - that did it! Many thanks :)
My System SpecsSystem Spec
18 Apr 2018   #59

Win 7 Pro x32

Hoping someone has found a solution to "could not find item" using Win7:SP1:x86

In Windows Explorer I create a "New Folder". Folder is created.
Attempt to "ReName" New Folder and receive "could not find item".
Tried reboot and still same error. Folder exists as New Folder but cannot be renamed.
Have not tried using DOS as I use Windows Explorer frequently and having
to shell to DOS for various file actions will be a Pain!!

NOTE: I messed with Windows Libraries to remove / hide them. Saw some comments
as possible cause of problem. I believe may be more related to fact "New Folder" has
a space and is longer than 8 characters and API call is defaulting to short file names
for whatever reason.


Workaround Solution #1
Hitting the "Try Again" button works

Workaround Solution #2
1) RIght Click New Folder
2) Select Properties
3) General Tab
4) New Folder is shown near top dialog in an editable textbox
5) Enter Folder Name desired.
6) Apply

Possible Reg Edit solution
a) have not tried as using Win7:Pro:x86
b) fix is for x64

For me re-executing my REG file to get rid of libraries restored my ReName.
(1) The following reg file applies to the x64 post Not libraries.
The forum pushed it to last in line after this solution for some reason.

(2) FWIW Only reason I got rid of libraires (special folders) in the first place
was because when using Windows Explorer the caret would always jump to them
1st rather than allowing me to deal with the current directory that I was on.
This is an MS bug, which has NOT been corrected through Win10 as I understand it.

Attached Files
File Type: reg FolderDescriptions.reg (233.6 KB, 0 views)
My System SpecsSystem Spec

 Could not find this item - when deleting files

Thread Tools

Similar help and support threads
Thread Forum
Item Not Found: Could Not Find This Item
Hello! I've had a problem with a particular folder on my desktop for a while now and have finally decided to fix it. There is a folder that has some thing to do with Camtasia 7 (Software for screen recording and video editing) stuck on my desktop that I can't delete/rename. ...
General Discussion
Could Not Find This Item error when moving files from specific folder
I have a folder in my documents full of music samples to make songs out of and I am trying to move the folder to an external hard drive and every time I do I get the following error "Could Not Find This Item" "This Is No Longer Located in C:\<username>\My Documents\Music_maker\ Verify the item's...
General Discussion
"Could not find item" when moving or deleting files
Hi. Im running Windows 7 64bit and every time I move or delete a file, I get the "could not find item" message, but the tasks still performs successfully. Any ideas?
General Discussion
'Could not find this item'
Driving me crazy having to rename and move folders to do basic work in Win 7. Right-Click / copy pops up -'Item Not Found' dialog. Well - I just right clicked it - it IS there... Older posts in this forum were work-arounds. Is this fixed, yet? Many thanks from a very frustrated...
General Discussion
Windows 7 - Could not find this item - when deleting files
I have two, empty folders on my Desktop. When I try to delete them, the system says, that it can't find the file, because it's no longer located in... What can I do?
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 06:25.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App