Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows won't load after failed registry backup-Import

20 Feb 2013   #1

Windows won't load after failed registry backup-Import


I tried to import an entire registry backup, I received an error message similar to this one:" Error accessing the registry.".
then, Via "regedit" I tried to give permissions to my WinUser, (giving full control ).

I still received the same message, so I restarted my pc,And now all I get is black screen when I logon to my user,Same in safe mode.

(I made the backup via regedit, using the export option on every "HKEY" folder, and on "Computer", so I have 6 reg files )

I still have the entire REG backup on my hard drive.

I have hiren's boot and erd commander if it helps, they have some registry tools.

Is it possible to import the backup to my windows?

Thank you.
My System SpecsSystem Spec
20 Feb 2013   #2

64-bit Windows 10 Pro

Hello Supdoc,

To restore the complete registry, you would normally use system restore instead.
Registry - Backup and Restore
If you have a restore point available dated before this happened, you could do a system restore at boot with the restore point to do so.

Hope this helps, :)
My System SpecsSystem Spec
20 Feb 2013   #3


Thank you for your massage!

All I have is backup I made :/
Is it possible to convert the reg files to a system files? Maybe I an do it on other PC, and then move the files to my hard drive?

Is it possible to import reg BU via other tool?
My System SpecsSystem Spec

20 Feb 2013   #4
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8

Sure there are many registry backup programs. The most known is Erunt. But there are also RegBak, RegKey Backup, Registrar Registry Manager and others.

My guess would be that those restore only backups that you made with their program. If you have no restore points or images, I am afraid you'll have to do with what you have.
My System SpecsSystem Spec
20 Feb 2013   #5

64-bit Windows 10 Pro

You could use the free program ERUNT to try and import the .reg file with. Use the ZIP download, extract to a USB flash drive, boot to a command prompt at boot, and run ERUNT from the USB flash drive.

ERUNT Download

Like Wolfgang posted above, I'm not sure the program will work unless you restore what the program exported/backed up.
My System SpecsSystem Spec
21 Feb 2013   #6


I managed to make a new account via locksmith, and fix the permissions via registry tool.

I can log in to my guest account, But when I try to login to my user account it says the group policy client service failed the logon access is denied

I tried this solution:
- open registry editor on the machine which stores the users profile (make sure you are logged in as administrator)
- highlight HKEY_USERS
- File -> Load Hive, browse to the location of failing roaming profile and open NTUSER.DAT file, click open
- Under Key Name, enter any name you like, but remember what you have entered, eg.: enter "Vista"
- Expand, HKEY_USERS, you should see new registry hive called "Vista" or any name you entered earlier
- Right click on that "Vista" hive and choose permissions
- Confirm that the following users have permissions:
- Administrators: Full Control
- SYSTEM: Full Control
- User (or group) that owns this profile: Full Control
- if permissions were wrong, correct them, then click on Advanced tab
- on Advanced tab and enable "Replace permission entries on all child objects with entries shown here that apply to child objects" and click Apply
- highlight "Vista" registy hive, then click on File -> Unload Hive to release handle on NTUSER.DAT file.
When I try to "unload hive" I get access is denied

Please advice
My System SpecsSystem Spec

Thread Tools

Similar help and support threads
Thread Forum
Windows can not load classes registry file
Source User Profile Service; Event ID: 1542, the system can not find the file specified :shock: What should I do?
Installation & Setup
Windows failed to load because the system registry fie is missing..
Status: 0xc0000001 Info: Windows failed to load because the system registry fie is missing or corrupt How do I fix this without using installation disks(or any other disks)?? Thanks! :)
replace failed HDD with SMALLER SSD and load from windows backup?
Dual 500gb asus gh73jh-a1 laptop had C: drive fail, I have a good backup on external HDD that was made by windows backup. I've got an intel 530 240gb SSD coming that I want to load the backup to to make it the new C: drive. I've heard an extra step is required if going to the smaller drive, is...
Backup and Restore
.bat reg import gives error accessing the registry
Hello everyone, im new here! now, ive got a .reg file that id like to import automatically via .bat file to the registry. if i type the code myself in CMD it does work, but the same code via the .bat file refuses to add and get the error of: error accessing the registry im using the code :...
General Discussion
Can t import registry from a x32 application to my x64 OS
Hi all this is my first post in the forum.I have windows 7 professional x64.I am using an application called smart install maker Smart Install Maker - Custom setup files made easy.This software generally creates setups (i make exe files).It s a x32 application.I create setups where i copy some...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 02:15.
Twitter Facebook