Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Corrupted Partition Table on External USB Data Backup Drive

18 Mar 2013   #1

Windows 7 Ultimate 64-bit
Corrupted Partition Table on External USB Data Backup Drive

I have a Western Digital MyBook ES 500 GB external hard drive (USB and eSATA interfaces) for data backups formatted from a Windows XP PC that I now use with my laptop running Windows 7 64-bit Home Premium. Recently my son connected it to his Apple PC and tried to create a partition to back up his files. Apparently this corrupted the partition table. I can no longer access any data on the hard drive. The drive does not appear in Computer but does appear in Device Manager and Disk Management.

I believe the problem is that the partition table (formatted for Windows) was modified by an Apple computer so that Windows can no longer tell what file system is on the partitions. My son is gone for a month and I no longer have access to his Apple computer so I can't plug the drive into an Apple computer to check if the drive gets detected.

I looked at the drive using:

1. Windows 7 Disk Management
2. Acronis Disk Director 11
3. EASEUS Partition Recovery (latest version)
4. Partition Wizard 5.2

None of them could do anything except delete or format the partitions. I saw no repair option or ability to mark the partitions as NTFS file system.

The partitions on my external drive are still there but no file system is shown for most of them. Acronis Disk Director shows the following information:

Disk 1 (GPT)
EFI 200 MB 200 MB Basic GPT FAT32 Healthy
Local Volume 232.9 GB 226.7 GB Basic GPT Unsupported Healthy
Unallocated 128 MB
Local Volume 232 GB 218.6 GB Basic GPT Unsupported Healthy
Local Volume 619.9 MB 130.1 GB Basic GPT Unsupported Healthy

I believe the partitions were originally created with the NTFS file system. My guess is that the partition table needs to be corrected to indicate that the partitions are NTFS. I'm not sure how to do this or how to rebuild the partition table. Is there anyway to repair the partition table and possibly access the data?

My System SpecsSystem Spec
18 Mar 2013   #2
Microsoft MVP


A big chunk is unallocated. Was some of your data there? If so try Partition Wizard Partition Recovery Wizard - Video Help.

See if PW can also run Partition Wizard Check File System which can recover some partitions that are not readable.

If not some success has been reported repairing the partition table using Disk Genius trialware:
My System SpecsSystem Spec
18 Mar 2013   #3

Windows 7 Ultimate 64-bit

I tried Partition Wizard Partition Recovery Wizard and it deleted all of the partitions but one. That one was empty so the data is gone. I just reformatted the drive.

Thank you for you help.
My System SpecsSystem Spec

19 Mar 2013   #4

Windows 7 Ultimate 64-bit

The drive in question is an external USB data-only drive that I use for backups. It has no Windows or other operating system on it. I will keep your suggestions for future use when I need to re-install Windows.

Thanks again for your help.
My System SpecsSystem Spec

 Corrupted Partition Table on External USB Data Backup Drive

Thread Tools

Similar help and support threads
Thread Forum
Best way to sort out a corrupted partition table?
Hi, My Hitachi Touro 4TB disk partition got corrupted. Originally it was one 4TB partition with about 2.5TB of files. One minute it was fine, then it came up with "Need to format hard disk before use", then it wouldn't even start up. The disk is currently mounted in a disk dock. The disk...
Backup and Restore
Corrupted Windows partition Table
Hello Sir, First of all,to inform you, this has happened due to my mistake! :( and i am really very guilty about it. The thing is that i have both ubuntu 12.04 and win 7 home basic installed on my system. I installed ubuntu later so as expected the win7 loader was replaced by the grub...
Performance & Maintenance
Data recovery problem, Can reach corrupted data but no external space.
Hi everyone.. My external USb Wd mybook box has 1 tb Seagate Sata 3 and i use original Wd disc as W7 installed... in My PC Case as sata II Today my old problem appears again as Corrupted disc... I have Get Data Back NTFS (and i used before plenty of times for recovery, loss data or...
Hardware & Devices
0xc000000e - Partition Table Repair - corrupted F:\windows
Silly me, I just saw the instructions here on how to post which I somehow missed before: Is Windows 7 Professional - x64 (64 bit) - the original installed OS on the system? yes - an OEM version - OEM = NOT pre-installed - I installed myself when I build machine - age of system...
BSOD Help and Support
Win 7 Not Reading External Drive (with backup data)
:cry: I used a Maxtor OneTouch 4 Plus to backup data in Vista 32bit, then formatted HDD and did clean install of Windows 7 64bit over it. Now when I go to "Computer Management > Disk Managent, it says "You must Initialize a disk before Logical Disk Manager Can acess it". Because it's asking me...
Backup and Restore

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:26.
Twitter Facebook