Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Unable to display current owner

30 Mar 2013   #11
Layback Bear

Windows 10 Pro. 64/ version 1709 Windows 7 Pro/64

This might help and might not, but it cost nothing.
Go back to restore point before the power outage.

Just go to Start Orb and type Restore and you will see the option.

My System SpecsSystem Spec
30 Mar 2013   #12

Windows 7 Ultimate x64

1. I was already running from an elevated command prompt, so that's not it.

2. I had already tried going back to each of my previous restore points, with no change to this issue.

My System SpecsSystem Spec
30 Mar 2013   #13


Good morning.

Let's try something with permissions:

1. Right click your D drive > Click "Properties" > Click the "Security" tab (if you can't find the security tab, go to disk management, right click on D there, then click properties).

2. Now click the "Continue" button if it's there. Permissions box will open up.

3. Now click "Add" button. Type in the Username of the current windows user account you are logged in into the text box.

4. Now your username will appear under 'Group or usernames'.

5. Select your username from that list.

6. Under 'Permissions for <username>', click the check box against "full control" under the 'allow' column. Make sure all check boxes are checked under the Allow column.

7. Click OK. Now wait and watch a bit and click continue whenever asked.

8. Now try accessing the drive. If still not accessible, try after a reboot.

Hope this helps.
My System SpecsSystem Spec

31 Mar 2013   #14

Windows 7 Ultimate x64

When I right click on my D: drive and select Properties, then select the Security tab, I see the message "You do not have permission to view or edit this object's permission settings."

There's an Advanced button available, but it only leads to more instances of the message above, except for the Owner tab, which says "Unable to display current owner."

In your list of 8 steps, I can only do Step 1.
My System SpecsSystem Spec
31 Mar 2013   #15


Click start -- right click Computer -- click Manage.

On the left pane, click Users and group.
On the right pane, right click 'Administrator' (the one which has "builtin admin account" as description).
Click Properties.
Uncheck 'This account is disabled' (or similar, I don't remember exactly) so as to enable the admin account and click OK.
Now logoff and log on to newly available Administrator account.

Now can you access D drive?

Now follow all those 8 steps and while adding username, make sure you enter the username of the account you were normally using.

Report back.
My System SpecsSystem Spec
31 Mar 2013   #16

Windows 7 Ultimate x64

I'm sorry, I thought I had mentioned earlier that I had tried using the (normally hidden) Administrator account. Nothing changes when I use that account - still the same exact messages as before.

I appreciate the effort!
My System SpecsSystem Spec
31 Mar 2013   #17


Ok lemme try a bit more:

Run elevated cmd.
Type this out: takeown /f d: and hit enter.
Now type this: icacls d: /grant <yourcomputersname>\simon:F and hit enter. You can find your computer name in device manager I suppose, at the top.

Now what happens?

If you can't find computer name, see here:

EDIT: OK, so actually I did not read your initial post properly. I think you've already tried this, now it's beyond my scope, sorry.
My System SpecsSystem Spec
31 Mar 2013   #18


You could try this:

Backup data on D:
Delete the D drive using disk management.
Create new partition again.

Seems like some serious corruption went there.
My System SpecsSystem Spec
31 Mar 2013   #19

Windows 7 Ultimate x64

Those last two commands give me "Error. Access is denied."

I agree, I should back that stuff up and recreate the volume, but unfortunately I have no more room anywhere to put it. I guess I'll live with it for a bit until I can get more storage space.

Thanks for hanging in there. I agree, it looks like some kind of corruption of the security/permissions bits.
My System SpecsSystem Spec
31 Mar 2013   #20


I don't advice doing this, but if this had happened to me, I would have used a linux live distro such as Ubuntu and boot using it, then go to D and remove the 'System volume information' folder (I am not at all sure if permissions are stored here or not) and remove anything extraterrestial located at the root.

If you suddenly decide to do this (I don't advice so please) make sure you have your data backups. Some time ago I had played around with SVI folder, even somehow deleted it but Windows simply created a fresh copy again.
My System SpecsSystem Spec

 Unable to display current owner

Thread Tools

Similar help and support threads
Thread Forum
Access Denied - unable to display current owner.
I save a lot of files as PDFs. Recently, I saved a financial document to PDF and it seems to be secured somehow. It's a pdf. Adobe complains opening it, complaining "There was an error opening this document. Access denied." Instead of opening it with a right-click, I tried starting Adobe and...
System Security
Limit Explorer display to current folder
Problem: I go to a specific folder and change the view from Details to Icons. All the folders above and below this one (all the way up to Documents) have their view changed. How do I restrict the change only to the current folder? I seem to remember that in previous versions of Windows I had...
General Discussion
"Access is denied" - "Unable to display current owner"
Hi, I just tried to install the latest iTunes update, but keep getting an error when it tries to access the C:\Program Files\iPod folder. When I try to access the iPod folder directly through Windows Explorer, I get "Access is denied". The same happens when logged in with the system...
Network & Sharing
Unable to Display Current Owner!
I am accessing another computer by read/write rights to specific folders. Today, I was at the host computer and I saw a file, that I deleted before, still there. When I was permanently deleting it, it was going off; but when I refresh, it was coming back. When I tried to just delete - recycle -...
Network & Sharing
Unable to display current owner
I suspect this to be network-related, offline-related and possibly to an abandoned account. Can someone shed some light on this?
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:33.
Twitter Facebook Google+