Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Unable to delete empty registry entry

30 Mar 2013   #11


Quote   Quote: Originally Posted by Britton30 View Post
Quote   Quote: Originally Posted by calccrypto View Post
I ran Auslogics Registry Cleaner, and it found many errors, and deleted all but one of the registry entries. I ran it a few more times, and it was still unable to delete it. So, I went into the registry and tried to manually delete it. Regedit tells me that it is "Unable to delete all specific values". The value is like NULL string (not a NULL string pointer) or something (REG_SZ, no value set)

What else can I do to delete it?
I'd quit using Auslogics, it is aggressive and may bork your system and require a reinstall, however, proceed as you wish.

Yes, in my case, it totally killed my office installation. I couldn't even repair it, I had to re-install. So, dear OP, you are requested to stop using this particular tool cuz deleting a few registry keys will NOT speed up your system. Windows 7 is optimized enough to keep the registry in good condition.

My System SpecsSystem Spec
30 Mar 2013   #12
Layback Bear

Windows 10 Pro. 64/ version 1709 Windows 7 Pro/64

Simple rule of the thumb.
If regedit says it can't delete a key leave it alone and go worry about something else like running anti virus and malware scans. If they find nothing and your system is working as it should be happy.
I also recommend getting rid of that Auslogics thing.
My System SpecsSystem Spec
30 Mar 2013   #13

W7 Pro SP1 64bit

Quote   Quote: Originally Posted by Britton30 View Post
I'd quit using Auslogics, it is aggressive and may bork your system and require a reinstall, however, proceed as you wish.
I decided to see what errors it would find on a fresh install (no 3rd party apps or drivers installed, just the fresh OS). It found 23 errors - but Uniblue found more than 200 errors on that same fresh OS, so Unitblue must be the better product..... NOT!

It is scary that Kaspersky was distributing this Uniblue crapware.

(not my video - you might want to mute the sound)

And while we are on the topic - "empty" registry keys are not useless. It might not be wise on a programmer's part to create/use just a key (with no data), but it is done. One user complained about repeatedly having to setup a program like it was the first time it had been run. We tracked it down to his use of a registry cleaner that was removing "empty" keys. If the program could not find that key, it started its setup wizard.
My System SpecsSystem Spec

30 Mar 2013   #14
Microsoft MVP

Windows 7 Ultimate X64 SP1

Oh-oh, I think at one time any mention of that "Blue" name was banned here. It is real crapware.
My System SpecsSystem Spec
23 Jul 2013   #15

Windows 7 Home Premium 64bit

I have been using Auslogics Boostspeed for a couple years now with zero problems. Just today, 7/23/13, I got the exact same problem and never had it before.

The registry file is a read only and it will not let you change the settings(or it shows you did but immediately reverts back) so you cannot delete it.

To the person who had a value for this registry item: every computer is unique and just because you have a program that utilizes this registry key does not mean that every computer should have a value in it.

It is not a big deal at all. If you are concerned about it, update and run your antivirus/antimalware program(if you are ultra paranoid, run windows defender and Microsoft security essentials as well to ease your mind.) If nothing comes up, I would not give it a second thought unless you start to notice your computer seriously bogging down big time.

The bogging down big time is always my litmus test for if something is wrong but then again, I keep my laptop very well maintained. So much so that I do not use, or need, a constantly running antivirus.

I have had issues like this before and they almost always resolve themselves by the next time I run all the scans.

BTW, if you use Auslogics Boostspeed and you do not know how to fix computer problems than you should not mess around with anything labeled "advanced".

How about this, if you do not understand what a hard drive partition is and what they are used for, do not even install Boostspeed because you are not computer literate enough to be messing around with the things this program allows you to do.
My System SpecsSystem Spec

 Unable to delete empty registry entry

Thread Tools

Similar help and support threads
Thread Forum
Registry Entry to delete specific User Profile entries
I work for a University as a Lab Manager where we have over 300 computers running Domain Profiles. We have begun updating from XP to 7 and started to notice TEMP profiles being created. I have figured out how to resolve the issue by going to the registry ...
General Discussion
Cannot delete Registry entry
After trying to recover from severe malware infection, I ran Spybot S&D. It removed several Registry entries but one it could not. I tried manually but it could not be removed. It is located at Hkey-users\S-1-5-21-200258984-2800820833-1255355968\Software\DataMngr. It has subdirectories "Files",...
System Security
Unable to delete key/string from registry
Here is a problem that I have been struggling with all evening and I need some help please.:cry: I deleted Zone Alarm Extreme Security using Revo Uninstaller, I managed to get rid of everything bar a folder containing 1 dll file (in Program Files (64) and its registry settings. CCleaner and...
System Security
What is the strange registry entry and how can I delete it?
I have the following registry key that appears to do nothing but keeps re-creating itself: HKEY_CURRENT_USER\Software\Microsoft\WindowsNT\CurrentVersion\Winlogon This key contains a Shell value that points to an empty directory on my system: C:\Users\Birk\AppData\Local\bc53345c\X If I...
Unable to Delete Empty Folders; Tried many fixes
I have a folder with subfolders that I have been totally unable to delete. The folders all have 0 bytes of data in them. I can rename them, move them, etc. but cannot delete them. The folders are unique in that their names are in blue print instead of black as are all other folders on the hard...
Performance & Maintenance

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:15.
Twitter Facebook Google+