Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Black Screen With Cursor

11 Apr 2013   #1

Windows 7 64bit home premium
Black Screen With Cursor

Hello, I am new to this forum [joined so i could post this plea for help] so sorry if this is posted in the wrong place.

Every once in a while when I wake up and turn on my monitor it is just black.
That starts me worrying. So I lift up my laptop lid/screen and expect to see the HDD password prompt.
Most of the time I can put in my password stuff and boot into windows.
You see I have the windows updates set to install and reboot as needed.

Today was a little different.
Today after the password stuff I saw the usual windows 7 booting up bar thing.
Normally shortly after that disappears I am greeted by my backdrop and login prompt.

Today instead of the login prompt I just get a black screen with the mouse pointer.

So I think hmm lets wait for it to maybe do something, so I leave it for a while. No signs of life.

Tried booting with f8 - last good, safe mode, safe mode command, safe mode vga etc.
No joy - still same black screen with cursor.

I think windows is at a stage just prior to the login prompt?

I get into the bios and put cd/dvd rom as first boot.
I decrypt the truecrypted system partition with my truecrypt rescue disk. That worked fine.
I put in my downloaded windows 7 64 bit recovery disk.

Note - dell do not supply users with an installation disk for windows 7 64bit.
Hence the downloaded recovery disk.
Due to similar issues with widows updates I have used this recovery disk with success in the recent past.

I select us keyboard and see windows 7 home premium as c: os
I try the option on that screen to use a previous image. No joy.

I select my one and only windows install ie windows 7 home premium as cs
I try automated repair. It says searching for problems and then start up repair could not detect a problem.

I try system restore - since a lot of stuff i use auto creates restore points i should have loads of them from quite recently - great stuff. No restore points found !

I try restore from previous back up. None found. There probably are none but work a look.

I try launch command line - YAY I get the x:\ cmd window.
change to c: and I see my install of windows - great.

I try bootrec.exe /fixmbr bootrec.exe /fixboot. They work. No joy - still got the same black screen with pointer.

I try chkdsk /r. That runs fine. No joy.

I try rstrui.exe - no restore points found.

I believe there are restore points or a point because there is something in -
c:\system volume information\system restore

Please help.

I would love to use a previous restore point.
Failing that just login prompt as normal.

My other PC's got rebooted by auto update over night but they are working ok.
I have had problems with mcafee updates doing something similar but atm i am pointing my finger at ms.

Any thoughts anyone ?

My System SpecsSystem Spec
11 Apr 2013   #2

Windows 7 Ultimate 32-Bit & Windows 7 Ultimate 64-Bit

Lets try to do a sfc /scannow at boot

SFC /SCANNOW : Run in Command Prompt at Boot

You should run Startup Repair at least 3 times.
My System SpecsSystem Spec
11 Apr 2013   #3

Windows 7 64bit home premium

At present the only way I can get a command prompt is to boot via cd the rescue disk and select launch command prompt.

Ran sfc /scannow. Got an interesting reply.
"There is a system repair pending which requires reboot to complete. Restart windows and run sfc again."
So guess I will reboot and post the results here. Fingers crossed.
My System SpecsSystem Spec

11 Apr 2013   #4

Windows 7 64bit home premium

After rebooted pc with rescue cd. sfc /scannow gave same message.
Googled message.

diskpart, list volume
volume 0 c os ntfs partition 116gb healthy
volume 1 e [blank] raw partition 440gb healthy
volume 2 d storage ntfs partition 931gb healthy
These results are what I expected, nothing out of place.

chkdsk /r /f c:
force dismount Yes
checked and found no problems.

sfc /scannow /offbootdir=c:\ /offwindir=c:\windows
beginning system scan. this process will take some time.
cursor flashing so I guess I will let it get on with it. will post more later.
My System SpecsSystem Spec
11 Apr 2013   #5

Windows 7 64bit home premium

Result -> windows resource protection found corrupt files but was unable to fix some of them.
details are included in the cbs.log windir\logs\cbs\cbs.log
ok so cbs.log is a big file. 25,556,516.
So i renamed it to cbs.log.old and ran
sfc /scannow /offbootdir=c:\ /offwindir=c:\windows
lets see what the new cbs.log tell us :)
My System SpecsSystem Spec
11 Apr 2013   #6

Windows 7 Ultimate 32-Bit & Windows 7 Ultimate 64-Bit

Once you're done upload the logs
My System SpecsSystem Spec
11 Apr 2013   #7

Windows 7 64bit home premium

Very disappointing. cbs.log was created via notepad. result of sfc was zip, nada, nothing.
renamed cbs.log.old back to cbs.log.
ran sfc again. no change in cbs.log file.
Looks like cbs.log is not updated by the sfc, it tells lies
My System SpecsSystem Spec
11 Apr 2013   #8

Windows 7 Ultimate 32-Bit & Windows 7 Ultimate 64-Bit

Upload the log file
My System SpecsSystem Spec
11 Apr 2013   #9
Microsoft MVP


Work through these steps which prioritize everything that can possibly be done Troubleshooting Windows 7 Failure to Start leading up to rescuiing your files to run Factory Recovery or get the superior Clean Reinstall if necessary.
My System SpecsSystem Spec
11 Apr 2013   #10

Windows 7 64bit home premium

@VistaKing Hi and thank you for taking an interest in this problem.
Obviously I cannot upload the cbs.log from the laptop with the problem.
I am not sure how to get it from the laptop to this pc.
I will try a usb stick, however like I said sfc is not updating the log.
My System SpecsSystem Spec

 Black Screen With Cursor

Thread Tools

Similar help and support threads
Thread Forum
Unable to start - black screen or empty blue screen w cursor??
Hello, My laptop will not boot. I end up with an empty black screen or a blue screen with no icons, just a cursor. I get choices for 'normal startup' or ' repair' but not safe mode. Any help appreciated.
General Discussion
Black screen with movable mouse cursor before login screen appears
Hi, I have an office desktop pc (HP COMPAQ ELITE 8100) running 64-bit Windows 7. I was manually running Windows update and manually updating some of my drivers when the pc suddenly turned itself off. I turned it back on and now it doesn't get to the login screen anymore. It just displays a...
BSOD Help and Support
Black screen w/cursor after Windows load screen - Nothing fixes it
Whenever the Windows loadscreen passes the screen goes black and I can move a cursor around the screen. I have had this happen before and fixed it with bootrec.exe but I can't seem to get that to work this time... Startup repair says it cannot help - Safe mode has the exact same black screen...
General Discussion
Black Screen of Death with Mouse Cursor before Login Screen
The issue started a few hours ago when I was playing League of Legends, specifically when the game has finished its loading and crashed to Desktop which is a common problem on my laptop. As usual I would restart the game, but before I could do that explorer.exe crashed, my entire Desktop has turned...
BSOD Help and Support
Black screen on startup, showing cursor, doesn't go to log in screen.
I'm using I have a DELL4500S desktop, on startup it will not go to the login screen, the screen is just black with the cursor showing. I've tried restarting the computer, unplugging everything and restarting it. Nothing is working. When it first starts a pop up shows and says "This Application...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:23.
Twitter Facebook Google+