Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Unallocated Space in Disk Management

18 Jun 2013   #1

Windows 7 Pro x64 ,Windows 8 Ent x64 and Windows Xp SP2
Unallocated Space in Disk Management

I have installed Win7 Ultimate (x86) on my 350GB SATA HDD.(2 partitions NTFS) and one old IDE HDD is used as slave (two partitions NTFS) (both disks MBR) (OLD HDD has WinXP Pro installed)

Win 7 disk management shows 8mb and 9mb space as unallocated at the end of partitions (on both HDD).
but the same disks wont show such unallocated disk space when checked through Win XP disk management

what is the reason ? what actually is the real case ? some space unallocated or not ?


My System SpecsSystem Spec
18 Jun 2013   #2

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bits 7601 Multiprocessor Free Service Pack 1

Post screenshot please so I can see it
My System SpecsSystem Spec
18 Jun 2013   #3

Windows 7 Pro x64 ,Windows 8 Ent x64 and Windows Xp SP2

@ Kaktussoft


Attached Thumbnails
Unallocated Space in Disk Management-win7_diskmgmt.jpg   Unallocated Space in Disk Management-winxp_diskmgmt.jpg  
My System SpecsSystem Spec

18 Jun 2013   #4

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bits 7601 Multiprocessor Free Service Pack 1

My System SpecsSystem Spec
18 Jun 2013   #5

W7 Ultimate SP1, LM18.3 MATE, W10 Home, #All 64 bit

You may not be able to eliminate those leftover bits.

I've had that issue occur when I have resized partitions.
Even unallocated space at the end of partitions, couldn't be reintegrated into the existing ones.

The only way (that I've found) that works 100% of the time, is to obliterate everything and repartition the drive from scratch (it isn't worth the effort for a few MB).

I suspect that it must be due to some sort of "rounding" issues.
For example, when you create partitions using GParted, it has an option like "Round to nearest cylinder" (the wording might not be correct/exact).
My System SpecsSystem Spec
18 Jun 2013   #6

Windows 7 Pro x64 ,Windows 8 Ent x64 and Windows Xp SP2

Quote   Quote: Originally Posted by Kaktussoft View Post
Do you really care about 9MB and 11MB?
true...i really don't care about those few mb..but i was really willing to know why these two OS show the space differently...
My System SpecsSystem Spec
18 Jun 2013   #7
Microsoft MVP


Have you tried to extend your Logicals in Disk Mgmt?

Then try Partition Wizard Resize Partition - Video Help.

If the Home version won't do it the CD version might. It's a great tool to have handy anyway.
My System SpecsSystem Spec
18 Jun 2013   #8

Windows 7 Pro x64 Windows 10 Pro x64

That`s just what you get when you install XP on a drive.

You won't see the unallocated from XP, but you will from 7.

It`s totally normal.
My System SpecsSystem Spec
18 Jun 2013   #9
Lady Fitzgerald

Win 7 Ultimate 64 bit

I ran into the same thing with the 2TB WD Black from my old XP machine (may the old machine rest in h...ah...peace). I would up with a single 9MB unallocated partition I couldn't get rid of for love nor money (nor creative language). After fooling around with the piece of...with it in Disk and the free version of Minitool Partition Wizard, I managed to make the unallocated partition 54MB (mutter mutter, mumble mumble). I tried formatting the unallocated space and somehow wound up, not only formatting it, but spanning it with the other partition (censored)! I was able to delete the partition, after which Minitool was able to expand the remaining partition into the unallocated volume. I now have just one volume on the drive.

My suggestion would be to try to format the unallocated space, then delete the new partition, then try to expand the other partition into the space. Apparently formatting erases whatever was in the way...I guess. Heck, I don't know; I'm just glad I got the stupid thing fixed!
My System SpecsSystem Spec
19 Jun 2013   #10

Windows 7 Pro 64 bit

I believe this space is reserved for the use of Dynamic disk. When a disk is converted to Dynamic disk it uses this space to store volume information and other information. Without this reserved space the conversion would not be possible.
My System SpecsSystem Spec

 Unallocated Space in Disk Management

Thread Tools

Similar help and support threads
Thread Forum
SSD unknown in Disk Management - not initialised, no unallocated space
Hi everyone, I need some help desperately with my Samsung 840 EVO 250GB SSD. Until yesterday, I had been using it for less than a year on a desktop PC to run a Windows 7 Professional x64 installation. After it suddenly stopped working, it can no longer boot into Windows ("BOOTMGR is missing"...
Hardware & Devices
Disk Management will not create a partition in unallocated space
I cannot create partitions on any of my HDDs in Win 7, I can shrink or extend volumes. I have used Diskpart to clean Disk 0 after using Ubuntu to move all the files to an other disk When I boot into Ubuntu 13.04 I can create NTFS partitions in unallocated space using Gparted and am able to...
General Discussion
Unallocated disk space error, Can not partition volume space
hello, I recently formated my desktop, I have everything saved on the (F) partition, and i formatted the primary partition (C) which leaves me with huge chunk of Unallocated space that is unable to use. Everytime i try to create a new partition, it says that space is not enough ( i even tried...
Performance & Maintenance
Upgraded laptop hard drive, disk management unallocated space problem
I upgrade my laptop hard drive to 1tb hitachi travelstar and restoring the image with macrium reflect went well and prompted to reboot. After rebooting, it showed the hp logo then a black screen with an underscore on the top left, no hard drive activity. Windows boot manager said "the boot...
General Discussion
Disk Management- Merging unallocated space
I dual boot Windows 7 with Ubuntu. I have allocated 10GB as a partition to hold Ubuntu and any of the relatively small amounts of data I would store there, Ubuntu had the ability to look at and open the files on Windows anyway-- but Windows cannot read the Linux partition format. When I...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:54.
Twitter Facebook Google+