Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows Installer Service cannot be accessed

29 Jun 2013   #1

Windows 7 Home Premium x64
Windows Installer Service cannot be accessed

Whenever i download a program and try to install it i always receive the error that says "the windows installer service could not be accessed, this can occur if windows installer is not correctly installed. contact your support personnel for assistance", then i open "services" and view windows installer and click start and it starts fine but i still cannot install any programs, I've searched for Windows installer downloads but they're only available for Microsoft XP, im running a Dell Inspiron N5110 I5 core with Windows 7, also another perhaps correlated problem is whenever i run an already installed program it says "(program name) has stopped working" immediately after double clicking, even when run as admin, thanks for reading, if necessary i will post a MalwareBytes Report or other Data

My System SpecsSystem Spec
30 Jun 2013   #2
A Guy

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium x64 SP1

Welcome to Seven Forums . See if these steps help

Error "The Windows Installer Service Could Not Be Accessed" when installing or updating programs on Windows 7 or Windows Vista

It appears you may have a larger problem if your currently installed programs do not work. When did this problem begin? Do you have a System Restore Point from before the problem began? That may be easiest.

You might want to run the System File Checker, and see if it detects any problems.

SFC /SCANNOW Command - System File Checker

This site has the reg fix already created

Error "The Windows Installer Service could not be accessed" in Windows Vista - The Winhelponline Blog

Good luck, let us know how it goes. A Guy
My System SpecsSystem Spec

 Windows Installer Service cannot be accessed

Thread Tools

Similar help and support threads
Thread Forum
Windows 7 installer service could not be accessed
I have tried all the suggestions I can find, including the ones listed here 2+ years ago. I tried MS's repairs, the unregister, etc. Any ideas?
General Discussion
Windows Installer Service cannot be accessed.
Okay, so i was trying to install .Net Framework 4.5, when all of a sudden, it rolls back the download, and displays a message "Installation did not succeed, .Net Framework has not been installed because: The Windows Installer Service could not have been accessed. This can occur if the Windows...
General Discussion
Windows Installer Service could not be accessed.
This happened the last time I reformated and I don't really understand what's going on. I have 4 harddrives. 1 SSD and the rest are standard 7200RPM drives. This is the error I get when I try to install something. Weird thing is...
BSOD Help and Support
Windows installer service could not be accessed
I suffered from a Power_driver_state_failure problem, which Windows7 forums helped fix. However at some point the problem appears to have damaged my windows Installer. I am having problems installing new updates on my Norton and itunes no longer works and will not reinstall. The message I keep...
BSOD Help and Support
The Windows Installer Service could not be accessed
Get "The Windows Installer Service could not be accessed" error message whenever run any msi file. have tried running msiexec /regserver also checcked service registry settings which appear to be ok (service is actually running) other thing to note is that msi files don't appear with an icon,...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 07:42.
Twitter Facebook Google+