Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Denied Access to D:\ drive

19 Oct 2009   #11

Windows 7 build 7600 64 bit

Aaand it has been solved! thank you all for the replies, and tanks Flavius for the solution!

My System SpecsSystem Spec
09 Aug 2010   #12

Windows 7

Hi Guys,
I have exactly the same problem as Hakon, only, I still cannot access my drive trough TC. Can you help me find the solution that worked for you?

I ran TC via PsExec as you suggested, but My Total Commander still returns Access Denied when I try to get the properties of my F:/ Drive.

What I did was delete all user rights and then click Apply. I was planning to recursively set all rights to "Everyone" after that. Stupid mistake ofcourse.

Any way to bring my files back?
My System SpecsSystem Spec
09 Aug 2010   #13

Windows 7 Professional x64 PL

Try unmount partition (remove partition letter) +restart and next mount it again in diskmgmt.msc
My System SpecsSystem Spec

10 Aug 2010   #14

Windows 7 build 7600 64 bit

Try using cacls to set permissions in a NT_AUTORITY\SYSTEM elevated command prompt, using PsExec
My System SpecsSystem Spec

 Denied Access to D:\ drive

Thread Tools

Similar help and support threads
Thread Forum
Access denied message on G drive
I am attempting to retrieve files from a Sandisk Cruzer flash drive, but I get a message saying "G not accessible, access is denied." I went to change the permissions to take ownership of the drive but there was no security tab. I searched thru the forums and first tried the recommendation...
General Discussion
Access denied on dvd drive
Just started - upon clicking dvd drive, message says "may not have permission." I can right click and open and play the movie, so drive is operable. I went into registry and followed directions to delete lower filter. - no change. I checked permissions and that is OK as well. I also...
Hardware & Devices
Access denied when trying to remove a CD Drive
When I try to remove a CD Drive (CDFS), it tells me access denied. It's frustrating because I've tried deleting it with a command prompt, but no luck. It says that it is a removable storage, but it was a download gone wrong. I finally managed to delete the file it came from, but the thing won't go...
Hardware & Devices
WD 1TB Drive; Is not accessible/Access Denied
Greetings! First Post. Problem is that I'm unable to access my WD Drive. I get a message that says Access Denied. This drive was originally formatted with a version of VISTA using recovery disks. I then went over top with W7. I no longer use the drive as my main OS but rather as a storage drive...
Hardware & Devices
Access Denied To C: Drive
Hello, I was messing around trying to share my local disk on my home network and in an attempt to give everyone access I deleted some Users from the Groups or User Names box and added "Everyone" with full permissions. Now when I click on the c: drive I get a message saying "Access Denied" Has...
Network & Sharing
Access Denied to Windows Drive.
Hello, I managed to remove all user access to the windows drive by mistake. Now i cant access my main windows drive. Windows runs fine but i can't run some software, save any files to desktop and stuff. Please help as i don't want to reinstall ! I tried following...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:38.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App