Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: I don't have permission for hard drive

28 Jul 2013   #1

Windows 7 64
I don't have permission for hard drive

I just had a new hard drive installed on my lap top. I do not have permission to open documents are word documents. These files include documents & pictures. When I try to open them, I'm denied. When I tried to transfer my pictures to Snap Fish, I was told that I need administrator's permission. I am the administrator & owner of the documents & pics. I even re-installed Microsoft Office 2003 & can only type a document, not able to save it.

My System SpecsSystem Spec
28 Jul 2013   #2

64-bit Windows 10 Pro

Hello Sal, and welcome to Seven Forums.

If you like, use the tutorial below to add "Take Ownership" to your context to be able to right click on these items you are denied access to take ownership of and "Allow" administrators "Full control" access rights. You should hopefully be able to access the files afterwards.

Take Ownership Shortcut

Hope this helps,
My System SpecsSystem Spec
28 Jul 2013   #3

Windows 7 Home Premium 32 bit

hi sal2229,

Yours is an OEM Machine by Compaq.. ( You have not indicated the model No. and what OS edition it originally came with.)

You have also not mentioned who changed the hard drive and how they reinstalled Windows on it, especially what media was used during the installation.

If not installed from the Recovery Disks for the system, the manufacturer-supplied reinstall media and in absence a validly licenced OEM(includes the COA sticker key on your desktop)/retail media, you are likely to encounter innumerable problems.
My System SpecsSystem Spec

29 Jul 2013   #4

Windows 7 64

Hello. My computer is Windows Home Premium. The model is Presario CQ62 Notebook PC. Staples did the new hard drive. I reinstalled Windows with discs that I received from HP. Here is exactly what happened. My computer was acting up. I could not access the windows. I got a screen that asked me if I wanted a system repair done. This happened 3 times. The third time, system repair was not able to repair anything. At the point, I was somehow able to get into the Recovery Manager & backup everything. The diagnostics showed that the hard drive had failed. After the the new hard drive was installed, I reinstalled the Windows. My discs that I backed up, showed everything as a WIM file. I did a restore per directions from HP from my discs. From there, everything was not able to be opened. I get this message--This file cannot be found. Try one or more of the following: Check the spelling of the name of the document, Try a different file name. C:\Users\...\DVDs Burned Revised doc. When I tried to transfer my pics to Snap Fish, I was told that I don't own them, I need to contact the administrator. I hope this all the info needed to help solve this problem. Thank you
My System SpecsSystem Spec
30 Jul 2013   #5

Windows 7 Home Premium 32 bit

Thanks for the info.

From your description I understand that you reinstalled Windows from the HP-provided Restore Disks and you only restored the data you backed up with the Restore Manager. And you have problems with the restored data. The only point I noted here is that the data backup was done during the failure phase of the previous HDD. I have no clue whether such data is corrupt and whether that causes the permission problem or the new HDD is causing the permission problems.

You may try what Brink has suggested in response to your query and see whether it resolves it.
My System SpecsSystem Spec

 I don't have permission for hard drive

Thread Tools

Similar help and support threads
Thread Forum
Permission error on Hard disk media files
Dear All, Greetings! I am facing an issue with respect to files stored on my external hard drive. I earlier had XP Professional on my machine and got Win 7 x32 Professional installed just yesterday. Now when I connect my hard disk, I cannot play any media file in one particular folder....
General Discussion
Hard Drive Permission to Share Specific PC on Network. Help
Hi everyone, I just want to ask, how am I supposed to add specific PC connected on my LAN. see Image below. you see, on the Properties of my hard drive > on the sharing tab > advance sharing > permission > then I want to add one. I'm stuck on...
Hardware & Devices
You need permission - happening on networked drive that has permission
Have looked at the other postings about Windows 7 and "You need permission" - this one seems new. I have a laptop and a desktop both running Windows 7, both part of HOMEGROUP. The desktop has two hard drives (C and D), both shared with full access to EVERYONE. I can see both but can only...
Network & Sharing
A file on my portable hard drives says it requires system permission
A file on my portable hard drives says it requires system permission but when i give it system permission it still doesnt let me delete it, it bother me, ive scanned it with 3 virus programs and it's not a virus.
System Security
permission from administration to hard disk drive????
how to download any in HDD when something is like this.
General Discussion
Hard drive permission messed up
I accidently changed the permission for my hard drive on Windows 7. I have C:\ and D:\ but after I altered the permisson of my D:\, now the access is denied. In the drive Properties under the Security tab, I ticked all the Deny boxes of the permission settings. I think the administrator was...
System Security

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:52.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App