Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: windows refuses to type anything !!!!!!

30 Aug 2013   #1
Essam Tarik

windows 7 ultimate service pack 1 , 32bit
windows refuses to type anything !!!!!!

hi , i have a problem , i have a samsung ativ book2 laptop
i started working on it and it was good , till i faced a weird problem , my keyboard stopped working , i tried using the fn key with some keys , but nothing happened , i thought my laptop was corrupted , so i tried using enter and shift caps lock keys , and they just worked , i tried using the on-screen keyboard and it still refused to type , so i knew the problem is with windows , it mostly gets fixed by rebooting , how can i fix this ?!!!!!!

My System SpecsSystem Spec
30 Aug 2013   #2

Windows 7 ultimate x64

Hi Essam Tarik, Welcome to Sevenforums.

Have you tried to connect a USB keyboard to your PC and check, if that is working or not. If it does, then you can take your machine to the vendor who sold you. Get it fixed.

If not, try this link. Troubleshoot keyboard problems
My System SpecsSystem Spec

 windows refuses to type anything !!!!!!

Thread Tools

Similar help and support threads
Thread Forum
Is default email account type deteremined by type of device?
I set up an Outlook account on a new-to-me laptop. I had been unable to download email for several months, since I didn't have a computer. I had been saving the emails I wanted to keep and had planned on downloading them into my new computer. After setting up the account, it appeared the system...
Microsoft Office
Windows.old refuses to delete
I don't know where this belongs, since I signed up just to post this problem, really. Most methods I try result in failure to delete this folder. Manually recycling says I need permission, and when I allow it permission, the process hangs up. When I attempt to use Lock Hunter, it tells me...
General Discussion
Windows 7 Refuses to Boot
I have a tower system based on an ASUS M5A78L running Windows 7, and it is refusing to go past the ASUS Boot Screen. I also have a dismountable USB based Seagate backup drive that if I remove before booting results in the boot process completing, but not if it is present. I have had USB problems...
Hardware & Devices
Windows Refuses to Start
I recently took my tower over to a friend's house to play lan games and what have you, it worked fine until i brought it home and set it back up. When i tried to boot it up it sat at Verifying dmi pool data and refused to move, I then inserted my 7 disc and tried t boot it that way only to be brick...
BSOD Help and Support
Windows 7 refuses to install
just got a new motherboard and wanted to reinstall windows 7 64bit but the installer just keeps freezing on me , not crashing ,just after windows loads the files and then the windows 7 wallpaper comes but then nothing happens after that i can still move the mouse so is not crashed like i said. i...
Installation & Setup
Windows 7 refuses to boot up
Hi, I was directed to these forums from so hopefully someone can help me with my windows 7 problem on here! I had a system failure the other week (a crash dump memory hardware failure type thing) and ever since windows 7 (32 bit) has felt sluggish. I decided to run a full system...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:15.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App