Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Existence of the Boot menu (MBR) denies access to other boot methods.

25 Oct 2013   #1

Windows 7 Professional 64 bit (and Linux Mint)
Existence of the Boot menu (MBR) denies access to other boot methods.

Hello. I just hit a problem for which I can see no immediate workaround. I'm hoping someone else can.

I had XP on a partition, the primary partition had/has Win7 Home Premium. I tried many ways to delete the XP partition, but no programs, including 7's disk management, would let me do that as it was a system partition, until I tried Paragon, which said OK. After rebooting, my computer failed to boot into 7, though the XP partition had been deleted. What Paragon did to damage the primary partition and my Win7 boot capabilities I don't know, but damage it it did. Had I had access to DOS's FDISK, I would have had no problems as I've done such things many, many times before without a single problem using FDISK.

I had previously used a program (EasyBCD) to successfully remove the XP entry from the boot menu, assuming there might be problems if I left it there. I booted from my Win7 DVD, and chose Repair. The Win7 installation was clearly there - I trawled it looking for some system file that Windows wanted me to find, but didn't name. I never did find anything suitable, because I wasn't told what I was looking for. So I moved away from that bit and on to Repair proper - no input from me. After a very long time, I was told to reboot to apply found solutions. I did so.

At boot, I got a message telling me that the file NTOSKRNL.EXE was missing from the Windows\System32 folder, and I should replace it. Impossible, of course, while I couldn't actually boot; I think I can be forgiven for asking, with some frustrated anger, why a file important for the boot process was missing AFTER that lengthy Repair process? Surely the Windows Repair process should ensure all such important files are where they are needed, particularly as in this case, as the Repair process subsequently stopped me from trying other methods. I'll explain.

The Repair process had recovered the old boot record that offered the boot menu with 7 OR XP, and that proved disastrous. No other choices were offered or available. And so I was completely helpless. The F8 menu that includes the Safe Boot options offered nothing else useful - I needed something to bypass the Boot Menu such as, "Boot Using Other Device" to try other things, such as booting from a boot DVD created with Macrium Reflect which would allow me to write a saved image of my drive. But because the boot menu, and the F8 menu ONLY were available, I was royally snookered - my only choices being to boot into 7 or XP, both of which were both now corrupted, and unbootable.

I have other hard drives, and have now installed XP on one in an attempt to recover that way, having disconnected the "problem" drive from the motherboard. Had I been able to override the frustrating boot menu, I might have saved a lot of time, but neither the boot menu nor the F8 menu offers the ability to boot from another device.

It is important to note that the Windows boot menu takes no notice of the BIOS setup boot order, where I had and have every boot option set to my DVD drive. Once the boot menu is displayed, one can only choose from that, and booting from CD/DVD, or any other device is not possible.

I had hoped to recover my "problem" drive once I got XP installed on this other disk - accessing the "problem" drive via USB adaptor, and copying the missing file to the System32 folder, and trying again to boot. (I have placed quotation marks around the word 'problem' when applied to my drive, as the drive itself wasn't actually the problem. The problem was the Repair process, which effectively denied me any control of the boot process. I could not bypass the boot menu to use other means.)

Anyway... having installed XP on the other drive, and placed the "problem" drive in a USB caddy, I immediately did a search for ntoskrnl.exe, and discovered that it actually IS in the System32 folder after all, despite the Windows boot message that it is not(????). This was not only unexpected, but effectively made further progress impossible. Windows says no, Explorer says yes.

The file also exists in \sysWOW64, and so I thought that maybe the file in \System32 was just corrupt, and tried to delete it prior to copying it back into the \System32 directory from the \sysWOW64 directory. No joy. I could do nothing to the files in the Windows directories despite the fact that I was accessing them from a USB drive which was no part of the current boot configuration. Such control is madness and mightily unhelpful. Protect system files, yes, but note where they are currently being accessed from.

I can do nothing while the boot menu continues to be displayed - I absolutely must delete it in order for me to boot from CD/DVD (or USB). Does anyone know where Windows keeps its boot menu information, so I can delete it? I need to remove the boot menu in order to access the DVD to reinstate the Macrium Reflect image to maintain this installation of Win7.

I can, and probably will have to, wipe and reformat the drive in order to be able to write the Macrium Reflect image, but I would like to keep the (EXISTING - it's all there) Windows 7 installation.

Your suggestions welcomed.

My System SpecsSystem Spec
25 Oct 2013   #2

Windows 7 32 bit

Maybe somebody who has done a lot of multiple OS lately can be more help. On my old 486 I had Dos Windows Linux and OS/2 multibooting. But that was some time ago. I did use Paragon Drive Backup imaging program. One thing I noticed was that when Vista came along, Paragon had problems. Even after they claimed to have solved them (Vista and later has some subtle differences in NTFS partitions) trying to create a recovery capsule on the drive hosed my partition table. But the point I'm making is, in future the first step I would take would be to boot Partition Wizard and undo the XP partition delete.

Where you are now it may be too convoluted to help. But I believe PW boot CD is more powerful than anything you can do with the system running Windows. But usually when you have XP booting with a Vista or later Windows, an issue involves and ntldr. XP installs them in the root of C: even if XP itself is on H: or whatever. It confuses the issue.

Hopefully somebody with more current experience will help dig you out of the hole, if it can be done.
My System SpecsSystem Spec
25 Oct 2013   #3
Microsoft MVP


The solution is the same as its been here since we developed it when Win7 was in beta: To remove another OS which holds the System flag, you should Mark Partition Active
the Win7 partition or it's 100mb System Reserved partition (preferred if you have it) then run Startup Repair - Run up to 3 Separate Times.

No other repair will do the job fully including rewrite the Repair My Computer link to the F8 boot options.

Usually we ask first to see a screenshot of Disk Management - Post a Screen Capture Image because having separate HD's or a Logical partition for Win7 can require special steps, like unplugging the unwanted OS's HD during repairs, or converting a Logical Win7 partition to Primary in order to mark it Active.

If these steps won't work now I would boot free Partition Wizard CD and take a camera snap to post back a screenshot of the drive map and listings which will tell us a lot. You can also use PW to Mark Active and then run Partition Wizard Rebuild MBR Video Help which may start it. Otherwise again run Startup Repair - Run up to 3 Separate Times
My System SpecsSystem Spec


 Existence of the Boot menu (MBR) denies access to other boot methods.

Thread Tools

Similar help and support threads
Thread Forum
Cannot access BIOS, Boot Menu, Safe Mode
I have a Dell Inspiron 570, with Win 7 Home Premium (SP1). I cannot access BIOS, Boot Menu, Safe Mode upon startup. I have tried using F2, F8, F12 numerous times and I have downloaded the latest BIOS update. I have read that I can remove the HDD and force the system into BIOS. I would like to not...
General Discussion
UEFI hard drive boot order and boot menu are completely ignored
I have a bit of a puzzle, and I don't know whether to blame the motherboard maker, Microsoft, or -- this is a really distant third choice, obviously -- myself. (That being said, UEFIs and GPT drives are new to me, so that distant third choice might not be as distant as I'd hoped.) I recently set...
PC Custom Builds and Overclocking
Unable to access System Recovery in Boot Menu, and unable to boot disk
Win 7x64 Acer-5251 Everything seems to be working fine, but as the title suggests, when i tap F8 the Advanced boot options DO appear, but when i engage "Repair Windows" it just goes into a normal boot. Ive tried booting from my installation CD that i've purchased from Acer, but does nothing....
Installation & Setup
System will not boot, cannot use F8, cannot access advanced boot menu
Hi all... My Gateway Laptop (NV55S05u) had a Norton scan today and found a trojan virus that Norton could not remove. I restarted the computer to try to get it in safe mode, and when I restarted I got a black screen with just a cursor. I was able to get into the BIOS (F2) and also able to...
General Discussion
Disk boot failure, can launch to safe mode through boot menu
I left my computer asleep. When I awoke it, it froze up, so I restarted it and it told me I had a disk boot failure, insert boot disk. If I reboot, and press f8 to get a boot menu from the bios, I can select the drive that has windows on it. If I do not intervene beyond this, it will boot to...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:48.
Twitter Facebook Google+