Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: cannot uncheck folders' read-only attribute

10 Nov 2013   #1

Windows 7 Ultimate x64
cannot uncheck folders' read-only attribute

Hi all.
I have troubles with the read-only attribute of folders.

I create folders and they are read-only by default. When I uncheck the read-only attribute it appears to obay my command but further inspection aftewards reveals that nothing has really happened.

I am the owner, I give to myself full rights but I cannot gain control on this feature.

It's very frustrating as I cannot edit the files in these folders.

I checked the web and found some pruposed solutions like using the dos attrib command but... no luck.

I'd appreciate any suggestions.

My System SpecsSystem Spec
10 Nov 2013   #2

64-bit Windows 10 Pro

Hello Skylos,

Double check using the tutorial below to see if it may help. In Windows, folders cannot be set as read-only. Only the files in the folders can be.

If the box is blue , then it's a default neutral setting that is always displayed. For a folder, it means all files in the folder not to be set as read-only.

Read-only File and Folder Attribute

Did you also take ownership of and set your account "Full control" of the files in the folder?

Take Ownership of file

Hope this helps,
My System SpecsSystem Spec

 cannot uncheck folders' read-only attribute

Thread Tools

Similar help and support threads
Thread Forum
Remove read only attribute of folder.
I have an executable file, which is a windows service. Now I cannot start it from service control management panel. I am the administrator. I guess the readonly attribute effects it. I found that the folder is readonly. I unclick it and apply it and click OK button. However next time when I look...
General Discussion
change Read only attribute
Recently I formatted my hard drive and all my data was again copied from different Hard drive.I use win 7 ultimate .This has resulted in the READ only Tried using properties and attrib command, both failed. How do I change the files to read/write? I have more than 300GB data.Whenever I try to...
General Discussion
Read only attribute for folders in properties
I recently tried to attach some photos to an email I was sending, only to discover that when I went through the browse option there was apparently nothing in the folder (which there was when I checked the folder in question) Having dug around I discovered that every folder appears to have read...
Music, Pictures & Video
All folders & subs suddenly have 'read only' attribute
I've been working on some 3d work. Tried to save a file and the program crashed saying it didn't have access to a particular folder (after months of working in the same folder btw). So I checked out the folder and it has a 'read only' attribute. Even if I de-check the 'read only' (using the highest...
General Discussion
Can't remove 'read-only' attribute from a folder
Things I have tried: 1) Enabled hidden administrator logon and logged onto it. 2) Edited user permission for entire drive and set to 'full control' 3) verified the folder is not locked/in-use even deleted it and then restored Still has the stupid 'read only' box checked when you hit...
General Discussion
Can't uncheck read-only attribute
I got a major problem. All folders i create have automatically the read-only attribute (blue box, not checked), and i can't get rid of it. I searched the forum but didn't find anything that would be of much help. Can anyone help me please? :cry::sleepy:
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:40.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App