Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: error code: 0x800b0001 & DirectX due to regsvr32 initpki.dll missing

07 Jan 2014   #1

windows 7 professional x64
error code: 0x800b0001 & DirectX due to regsvr32 initpki.dll missing

got that error code whilst trying to run MS security essentials, and while trying to install directX i got the "regsvr32 initpki.dll is missing" error. i can give pictures if needed. please help. ive tried several things. i know my way around a computer, i went to school for this type of stuff but im stumped. i ran sfc /scannow and apparently i have some corrupt system files. which btw the scan was NOT able to complete. i dont know how to manually fix them so im at a loss with that as well. i can provide pictures if needed. my first post on this forum, so thanks in advance.
1. the first pic is what happens when i try and open MS security essentials
2. the second is when i try and get directX
3. the third is an update that i have tried numerous times to install with no luck (figured it could be connected in some way)

also i would very much like to be able to solve this WITHOUT having to reinstall my OS. thanks. much love

Attached Thumbnails
error code: 0x800b0001 & DirectX due to regsvr32 initpki.dll missing-directx.png   error code: 0x800b0001 & DirectX due to regsvr32 initpki.dll missing-nvidia-update.png  
Attached Images
error code: 0x800b0001 & DirectX due to regsvr32 initpki.dll missing-mss.png 
My System SpecsSystem Spec
08 Jan 2014   #2

Windows 7 ultimate x64

Hi, Welcome to Seven forums.

For this error:

Failed to find updates with error code 800B0001

It indicated that Windows Update engine files has been corrupted.

Please use the following steps to re-register system files:

1. Click Start, Run, type: notepad C:\register.bat and press Enter. Choose "Yes"
when you are prompted.
2. Copy the following commands and then paste them into the opened Notepad window.

net stop wuauserv
regsvr32 wuapi.dll /s
regsvr32 wups.dll /s
regsvr32 wuaueng.dll /s
regsvr32 wucltui.dll /s
regsvr32 wuweb.dll /s
regsvr32 msxml.dll /s
regsvr32 msxml2.dll /s
regsvr32 msxml3.dll /s
regsvr32 urlmon.dll /s
net start wuauserv
regsvr32 softpub.dll /s
regsvr32 initpki.dll /s
regsvr32 mssip32.dll /s
regsvr32 wintrust.dll /s
regsvr32 dssenh.dll /s
regsvr32 rsaenh.dll /s
regsvr32 gpkcsp.dll /s
regsvr32 sccbase.dll /s
regsvr32 slbcsp.dll /s
regsvr32 cryptdlg.dll /s
regsvr32 jscript.dll /s

3. After the above commands have been pasted, please close the Notepad window.
Choose "Yes" when you are prompted to save the file.
4. Click Start, Run, type: C:\register.bat and press Enter to run the commands that
have been pasted.

Once you have completed the above steps, try to connect to the Windows Update site
and download the Updates again.

FOR DirectX issue.

1. navigate to \Windows\System32\directx\ or \Windows\SysWow64\directx
if you have Windows 7 x64.
2. Click on "organise" file menu, then "folder and search options" then
in the "View" tab check "show hidden files and folders" and then "ok"
3. websetup folder will be visible now. go in there and delete all
4. run "dxwebsetup" again.
My System SpecsSystem Spec
08 Jan 2014   #3

Windows 7 Pro x64 Windows 10 Pro x64

Why are you trying to install your video drivers through windows update ? You should be downloading it from here.

NVIDIA DRIVERS GeForce 332.21 Driver WHQL
My System SpecsSystem Spec

08 Jan 2014   #4

windows 7 professional x64

Hey guys firstly....thanks SO much for all the help. I'm currently working but I get off at 3:30. I'm gonna try these out first thing when I get home
My System SpecsSystem Spec
08 Jan 2014   #5

Windows 10 Pro

Also you cannot install "direct x" anymore. From vista onward, directx cannot be updated. It's built into windows. Your probably thinking like in windows xp you could upgrade direct x to the latest supported version. It does not work like that anymore.

Your version of direct x stays what it is from vista onward.

This is why it did not work, as well as why you received that error.
My System SpecsSystem Spec
08 Jan 2014   #6

windows 7 professional x64

where do i save the .bat file to? it said "Cannot find C:\ register.bat does not exist, would you like to create a new file?" i said yes...then i copy and pasted what you said to. then saved the file and got this...where do i put it ? or does it not matter.
My System SpecsSystem Spec
08 Jan 2014   #7

windows 7 professional x64

so are you saying that im....good? lol i just dont have to worry about it or...?
My System SpecsSystem Spec
08 Jan 2014   #8

windows 7 professional x64

thank a tad embarrassed that i didnt think of that already actually. lol
My System SpecsSystem Spec
08 Jan 2014   #9

windows 7 professional x64


one more thing...the DirectX folder does not exist in my system32 directory at all. but im guessing thats because i cant download it? idk...from what andrew said, maybe its supposed to not be there? idk
My System SpecsSystem Spec
08 Jan 2014   #10
Microsoft MVP

Windows 7 Ultimate 32bit SP1

You need to save the batch file to your desktop.

Is this an upgraded Windows installation? You may have incompatible programs or drivers working against you.
My System SpecsSystem Spec

 error code: 0x800b0001 & DirectX due to regsvr32 initpki.dll missing

Thread Tools

Similar help and support threads
Thread Forum
regsvr32 error
I am trying to register bthserv.dll in my registry as the bluetooth support service is missing from my services.msc; Dont ask how that happened! when running the command regsvr32 bthserv.dll im getting the error message; "the module bthserv.dll was loaded but the entry-point dllregisterserver...
BSOD Help and Support
Regsvr32 Error - PLEASE HELP
Hi All, I keep getting this error message every time I log on to my laptop. It's windows 7 64 bit. "The Module "C:\ProgramData\xklyoryq.dat" failed to load. Make sure the binary is stored at the specified path or debug it to check for problems with the binary or dependent .DLL files" ...
General Discussion
Regsvr32 error message...dll module not found
I am running Windows 7 Home Premium 64 bit. On start I keep getting the regsvr 32 error message that the module for qcncodecs4.dll cannot be found. Apparently this dll has been deleted. No problem. I am not interested in getting it back, I just want to stop the error message from appearing every...
General Discussion
just cause 2 showing fatal directx error code 15 plz help
hello everyone i have installed just cause 2 and i got fatal directx error code 15 on running game plz help I have laptop - compaq CQ61 my specs are 4GB RAM 1GB graphics memory and the mobile intel (r) 4 series express chipset family supports directx 10 and win7 which supports directx 11
Regsvr32 error when tryng to register ChilkatCrypt2.dll
I get this kinda error: When tryng to register it in my asus k533t. But when registrering with my other computer, which is Dell, it registres normaly. Both files are the same. Both computers are 32bit.
BSOD Help and Support
regsvr32 keeps running (dialog boxes missing)
Hello World, I have a programm that is copying a file (and its needed .dll files) to a selected folder. After the copy process the .dll files need to be registered with regsvr32. This is also part of the programm. On WIN XP there have been shown a dialog box that the regstration have been...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:17.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App