Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Class Not Registered

10 Jan 2014   #1

win 7 professional 64 bit
Class Not Registered

running win 7 Pro, "Class Not Registered" comes up any time I'm trying to access Admin areas. It's last research before format drive and install clean copy Os.. any thoughts Tnx

My System SpecsSystem Spec
10 Jan 2014   #2

Windows 7 Ultimate x64, & Mac OS X 10.9.2

try Running SFC scan.

System File Checker (sfc) scan will make Windows replace corrupt or missing system files on your computer.

Click Start, click All Programs, click Accessories, click Command Prompt
you may have to right click and run as admin.. but might not be able to with your issue.

In the Cmd promt window type, and press Enter:
sfc /scannow

if thw above doesnt work retry that method in safe mode.
My System SpecsSystem Spec
10 Jan 2014   #3

Windows 7 UnProfessional x64

Also, check your permissions. You can also try creating a new Admin account and then accessing said folders; sometimes if the issue is Malware, this is a way to sidestep it.
My System SpecsSystem Spec

11 Jan 2014   #4

win 7 professional 64 bit

Hello; did sfc/ report was a corrupt files found. said it included in the
CBS.Log windir\Logs\CBS\CBS.log example C:\Windows\Logs\CBS\CBS.log

Still get Class Not Registered.. How does one access the file? don't want to be a pain... thx
My System SpecsSystem Spec
11 Jan 2014   #5

Windows 10 Pro

Upload the cbs log file here please. Use the paperclip.
My System SpecsSystem Spec

 Class Not Registered

Thread Tools

Similar help and support threads
Thread Forum
class not registered
Please Help me guys. Im trying to save a word doc. file in my libraries and a pop up suddenly comes out saying class not registered and it happens in all microsoft office tools but when I tried to save it in the download folder it was ok. :confused::mad:also I was sending a file through my fb...
General Discussion
class not registered
Hi guys, When ever I download something in google chrome and I click show containing folder, an error comes up saying "class not registered". The same thing happens in uTorrent when I click show containing folder on one of my torrents. After that the program becomes unresponsive I was hoping...
General Discussion
Class Not Registered
Hi guys Desktop R click and select personalise and I get the above error. I have read through the previous forum threads covering this error and tried the various fixes via cmd.exe (as admin). I am either missing a .dll somewhere any easy fix?. Clean install yesterday and no naughty...
Class not registered error
Anyone know how to fix the attached error? This error comes up when I try to go into Computer Management, Services, Component Services but not MSConfig. I have tried System Restore points, but no go.
Performance & Maintenance
mmc.exe class not registered error
Haven't had this error since Win 2000, but after installing a clean copy of Windows 7 on my workstation, and a number of programs, when I try to run mmc from the run prompt I get a Class Not Registered Error, which is causing havoc on all my software installations. Any ideas on how to fix or...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:00.
Twitter Facebook Google+